Subject: Re: [pcp] Comments on draft-wing-pcp-flowdata-00

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Wed, 22 Jan 2014 12:10:46 +0000

Hi Hassnaa, 

Thanks for the review. Please see inline [TR]

Hi Dan, Reinaldo and Tiru,
 
To follow up the discussion on  draft-wing-pcp-flowdata-00, I have some questions as follows:
 
In Section 3.2 (Figure 1 and Figure 2): what does the PCP server represent, is it an edge router in the network? Does it have specific role for QoS management (is there any association with diffserv operation at that node) ?

[TR] PCP Server could be the edge router in the network. For example in a home network the flow description can propagate from in-home CPE router to the ISP's access router, and in an enterprise network the flow description can propagate within the enterprise network and up to the ISP's access router.  

In Section 3.2: the second paragraphs mentions the use of "FlowData option" for flows terminated by the PCP client (when operating s server): this example (when operating as a server) is not clear for me. Is there a concrete service example for that ?

[TR] Yes. For example Bittorrent acting as a Server in Home Network can signal the flow characteristics to the PCP Server. 
 
In Section 3.4: 
-        it is mentioned that the PCP client can use the information in the Flowdata fields in PCP response to influence the traffic it sends and receives: how can the PCP client influence the traffic it receives?

[TR] If we consider video adaption use case in draft http://tools.ietf.org/html/draft-eckel-aeon-use-cases-00#section-2.5.1 then HLS client can select the chunk (bitrate) based on PCP FLOWDATA response. For example HAS client will not retrieve a too high-bit rate chunk based on PCP FLOWDATA response. This way adaptive bit rate applications can improve user experience by avoiding attempts to exceed the network's upper bandwidth limit

-        An example is also given for Flowdata response indicating how the network can accommodate a flow for a certain downstream bandwidth: is this also valid for upstream case?

[TR] Yes. For example PCP FLOWDATA option could be used in SIP/WebRTC call for media session (audio, video) which includes both upstream and downstream bandwidth for media streams.
 
In Section 3.6: It  is not clear why the mapping is sent 3 times in Figure 5
 
[TR] It's sent multiple times because it is a unsolicited PCP response sent to the client, unsolicited PCP response (over UDP)  is sent multiple times because it could be lost. 

In section 7: It is mentioned that the short lived flows will receive no benefit from the flowdata signaling: The reason is not that clear for me especially if the short flows needs certain level of QoE. 

[TR] It's up to the application to decide if there is benefit in signaling flow characteristics to the network or not. Some short lived sessions  (HTTP session which get terminated just after a single response) may not see benefit from this approach.

-Tiru. 

Thanks for your feedback on these questions.
 
Hassnaa

---

From: "Moustafa, Hassnaa" <[email-masked]>
Date: Wed, 22 Jan 2014 14:35:24 +0000

Thanks for these details and clarification.

Hassnaa

-----Original Message-----
From: Tirumaleswar Reddy (tireddy) [mailto:[email-masked]] 
Sent: Wednesday, January 22, 2014 4:11 AM
To: Moustafa, Hassnaa
Cc: [email-masked]
Subject: RE: [pcp] Comments on draft-wing-pcp-flowdata-00

Hi Hassnaa, 

 

 
In Section 3.4: 

 

-Tiru. 

Hassnaa