Subject: [Pearg] Call for Adoption: Two drafts on Numeric IDs

From: Sara Dickinson <[email-masked]>
Date: Wed, 7 Aug 2019 12:56:35 +0100

Hi All, 

There are currently 3 drafts related to Numeric IDs that have been discussed on various IETF/IRTF lists:

* https://tools.ietf.org/html/draft-gont-numeric-ids-history
* https://tools.ietf.org/html/draft-gont-numeric-ids-generation
* https://tools.ietf.org/html/draft-gont-numeric-ids-sec-considerations

This email starts a two week Call for Adoption for two of these drafts which have been proposed as suitable work for PEARG:

1) Unfortunate History of Transient Numeric Identifiers: https://tools.ietf.org/html/draft-gont-numeric-ids-history-05

2) On the Generation of Transient Numeric Identifiers: https://tools.ietf.org/html/draft-gont-numeric-ids-generation-04

Please review both these draft to see if you think they are suitable for adoption by PEARG and send comments to the list, clearly stating your view.

** Because they are so closely related, we are requesting that people send an initial single response to this email but state their opinion separately for each of the above drafts in that response ** 

Note that the third draft is currently in the IETF stream as an AD sponsored submisssion.

This call for adoption ends on 21st August 2019.

Sara.

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Wed, 14 Aug 2019 07:33:57 -0600

I support adoption of these documents

On Wed, Aug 7, 2019 at 5:56 AM Sara Dickinson <[email-masked]> wrote:

> This email starts a two week Call for Adoption for two of these drafts
> which have been proposed as suitable work for PEARG:
>
> 1) Unfortunate History of Transient Numeric Identifiers:
> https://tools.ietf.org/html/draft-gont-numeric-ids-history-05
>
> 2) On the Generation of Transient Numeric Identifiers:
> https://tools.ietf.org/html/draft-gont-numeric-ids-generation-04
>
> Please review both these draft to see if you think they are suitable for
> adoption by PEARG and send comments to the list, clearly stating your view.
>
> ** Because they are so closely related, we are requesting that people send
> an initial single response to this email but state their opinion separately
> for each of the above drafts in that response **
>
> --
> Pearg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/pearg
>

-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

---

From: "Eliot Lear (elear)" <[email-masked]>
Date: Wed, 14 Aug 2019 13:56:32 +0000

This is good work. One question:

Do people really care that much about a complete woeful history of RFCs that got it wrong?  Might it make sense to get a bit more succinct and in the process combine the docs?  That way the 2nd doc is well motivated.

Anyhow I view this point as editorial.

Eliot

On Aug 14, 2019, at 09:35, Joseph Lorenzo Hall <[email-masked]<mailto:[email-masked]>> wrote:

On Wed, Aug 7, 2019 at 5:56 AM Sara Dickinson <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

Sara.
--
Pearg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/pearg

--
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www..cdt.org<https://www.cdt.org>]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked]<mailto:[email-masked]>, p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

--
Pearg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/pearg

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Wed, 14 Aug 2019 09:53:03 -0600

obviously, outside the scope of the call for adoption but I would
definitely support some re-organization that maybe pointed to paradigmatic
examples and then listed the others as "see also" (if that makes sense).
best, Joe

On Wed, Aug 14, 2019 at 7:56 AM Eliot Lear (elear) <[email-masked]> wrote:

> Do people really care that much about a *complete* woeful history of RFCs
> that got it wrong?  Might it make sense to get a bit more succinct and in
> the process combine the docs?  That way the 2nd doc is well motivated.
>
> On Aug 14, 2019, at 09:35, Joseph Lorenzo Hall <[email-masked]> wrote:
>
>> ** Because they are so closely related, we are requesting that people
>> send an initial single response to this email but state their opinion
>> separately for each of the above drafts in that response **
>>
> Chief Technologist, Center for Democracy & Technology [
> https://www..cdt.org <https://www.cdt.org>]

---

From: Fernando Gont <[email-masked]>
Date: Thu, 15 Aug 2019 21:06:44 +0300

On 14/8/19 16:56, Eliot Lear (elear) wrote:
> This is good work. 

Thanks!

> One question:
> 
> Do people really care that much about a *complete* woeful history of
> RFCs that got it wrong?  Might it make sense to get a bit more succinct
> and in the process combine the docs?  That way the 2nd doc is well
> motivated. 
> 

Responding to your comment:

Originally, the two documents being part of the wg call for adoption,
plus draft-gont-numeric-ids-sec-considerations, where all part of the
same document (draft-gont-predictable-numeric-ids).

We split the document into three pieces, upon request by folks at a
secdispatch (?) meeting. -- the rationale was that -history was mostly
informational, whereas -generation was more of a bcp, and
-sec-considerations was a different kind of bcp.

As authors, we wouldn't mind if the two docs where merged. Although I'd
agree that that would be kind of "editorial", and the high order bit
know is weather the RG wants to work on these docs.

Thanks!

Cheers,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Fernando Gont <[email-masked]>
Date: Thu, 15 Aug 2019 21:09:12 +0300

On 14/8/19 16:56, Eliot Lear (elear) wrote:
> RFCs that got it wrong?  

As an additional note, the timelines are intended to provide the
motivation of this work, and illustrate how hard and painful has been to
get numeric ids right in a number of protocols due to lack of
appropriate advice in this area.

Thanks!

Cheers,

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Wed, 21 Aug 2019 23:20:06 -0400

Hi pearg folks--

> 2) On the Generation of Transient Numeric Identifiers: https://tools.ietf.org/html/draft-gont-numeric-ids-generation-04

I think these drafts should be adopted by the PEARG.  Thanks to Fernando
for his persistence in working on them thus far!

At the IETF we've had a difficult time thinking systemically about these
problems, both for security and privacy implications.

The work in these drafts is some of the only attempts i've seen at a
larger overview of IETF work, looking for patterns, trying to learn from
our past mistakes, and formulating guidance for future IETF work based
on that research.  It's all done with an eye toward privacy concerns as
well, something we have traditionally not been as good about within the
IETF.

This is precisely the sort of research that i think the IRTF should be
supporting in PEARG.

As for the two documents -- i don't have a strong feeling about whether
they should stay separate or merged together, and i don't think it's
something that we need to decide before RG adoption.  For maintenance
work, i think it's useful to be able to update the documents in the
future separately.  if we have new guidance for generation there's no
need to update the history draft.  and if someone uncovers some
additional use of transient numeric identifiers, we can update the
history draft without needing to touch the guidance document.

        --dkg

---

From: Sara Dickinson <[email-masked]>
Date: Fri, 23 Aug 2019 13:24:36 +0100

Hi All, 

Many thanks to those who responded. The chairs have agreed that there is enough support to adopt both drafts, with further discussion expected on whether they should be combined into one document or not. 

Regards

Sara. 

> On 7 Aug 2019, at 12:56, Sara Dickinson <[email-masked]> wrote:
> 
> Hi All, 
>