Subject: Re: [Pearg] Review of draft-irtf-pearg-numeric-ids-history-01

From: "Christopher Wood" <[email-masked]>
Date: Fri, 10 Apr 2020 16:18:32 -0700

On Sun, Mar 29, 2020, at 5:49 PM, Fernando Gont wrote:
> Hello, Chris,
> 
> Thanks a lot for your feedback! In-line!
> 
> On 28/3/20 21:44, Christopher Wood wrote:
> > Document: draft-irtf-pearg-numeric-ids-history-01 [https://tools.ietf.org/id/draft-irtf-pearg-numeric-ids-history-01.txt]
> > 
> > Assessment: Almost ready
> > 
> > Thanks for putting this information together! I think the analysis and timeline are
> > a testament to the importance and subtleties of numeric identifier generation.
> > The amount of detail is quite comprehensive. Even if there are glaring omissions,
> > I think the overall point is made clear.
> 
> I'm curious about the omissions... which ones? If only for the sake of 
> curiousity. :-)  (FWIW, for the most part we documented numeric IDs from 
> different layers that we were closely involved in... not that there are 
> not other, though!)

Sorry, I meant that I don't know what's omitted, if anything!

> > I only have some high level comments on the document, along with several nits.
> > (If it'd be easier, and if you have the repository on GitHub, I can submit a PR
> > for the nits.)
> 
> Here it is: https://github.com/fgont/numeric-ids  . The working copy of 
> the I-Ds are the ones with the "-latest" suffix.
>
> 
> 
> > 
> > Comments:
> > 
> > - Section 2: Neither hard nor soft failures are used in the document. Can we just remove
> > these terms altogether?
> 
> Definitely yes. Done!
> 
> 
> > - Section 3: Perhaps it's worth mentioning that we consider the standard Dolev-Yao
> > style attacker as outlined in RFC3552?
> 
> Does RFC3552 actually mention it?
> 
> 
> > - Section 5, second paragraph: It looks the start of this sentence (or paragraph)
> > was accidentally deleted:
> > 
> >     he interoperability requirements for TCP ISNs are probably not
> >     clearly spelled out as one would expect.
> 
> s/he/The/ -- done, thanks!
> 
> 
> 
> 
> > Nits:
> 
> [...]
> I have not applied these yet. If you want, you can send pull requests. 
> Otherwise I will incorporate these comments tomorrow.

I assume you've done this since tomorrow has come and gone. Please let me know if that's not the case, and I can try to make time for it. (Otherwise, I'll leave it to your judgement to make changes.)

> Thanks a lot!

My pleasure!

Best,
Chris

---

From: Fernando Gont <[email-masked]>
Date: Thu, 16 Apr 2020 14:40:58 -0300

On 10/4/20 20:18, Christopher Wood wrote:
[....]
> I assume you've done this since tomorrow has come and gone. Please let me know if that's not the case, and I can try to make time for it. (Otherwise, I'll leave it to your judgement to make changes…

Posted! ;-) (rev -02)

Ready to ship?

Thanks!

Cheers,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492