Subject: [Pearg] Research Group Last Call for draft-irtf-pearg-numeric-ids-history-03

From: Sara Dickinson <[email-masked]>
Date: Wed, 4 Nov 2020 13:34:18 +0000

Hi All, 

This email starts a two week Research Group Last Call for the draft 'Unfortunate History of Transient Numeric Identifiers. The draft is available at: https://tools.ietf.org/html/draft-irtf-pearg-numeric-ids-history-03 <https://tools.ietf.org/html/draft-rao-pitfol-02>

Please review this document and send comments to the list.

This RGLC ends on 18th Nov 2020.

Thanks

Sara, on behalf of the chairs. 

P.S. Please note that a separate RGLC will be started for the related draft 'On the Generation of Transient Numeric Identifiers’ (https://tools.ietf.org/html/draft-irtf-pearg-numeric-ids-generation-03) immediately after this RGLC closes.

---

From: Sara Dickinson <[email-masked]>
Date: Mon, 16 Nov 2020 17:39:27 +0000

Hi All,

Just a reminder that this RGLC ends in 2 days on Wednesday 18th Nov. 

We have not had any reviews to date, comments are still welcome. The draft will move forward unless we hear any objections!

Best regards

> On 4 Nov 2020, at 13:34, Sara Dickinson <[email-masked]> wrote:
> 
> Hi All, 
> 
> P.S. Please note that a separate RGLC will be started for the related draft 'On the Generation of Transient Numeric Identifiers’ (https://tools.ietf.org/html/draft-irtf-pearg-numeric-ids-generation-03 <https://tools.ietf.org/html/draft-irtf-pearg-numeric-ids-generation-03>) immediately after this RGLC closes. 
> -- 
> Pearg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/pearg

---

From: Kris Shrishak <[email-masked]>
Date: Mon, 16 Nov 2020 18:51:50 +0100

Hi all,

Please find me review below with minor comments:

Best,
Kris

Comments:

- I am not sure if it is within the scope of this document, but when I
am reading a document as a history, then I am also interested in why
certain choices were made and not only the order in which they were
made. Maybe mailing lists can give us some insight on this. For
instance, the use of global counters for IPv6 when the issue of global
counters for TCP Initial Sequence Numbers was already raised well before
RFC2460 was published. It could just be that the authors and the WG were
unaware or did not consider the issue relevant.

- Section 1: "Recent history indicates that ... specification or
selected by implementers."

If recent history refers to the examples preceding this paragraph or to
the timelines presented in the following sections, then the framing of
this sentence can make it explicit. Maybe something along the lines of
"these examples indicate" will add clarity. Otherwise, a reference to a
couple of recent RFCs can substantiate the claim of recent history.

Chris Wood [1] also raised this issue a while back in the context of
https://datatracker.ietf.org/doc/html/draft-irtf-pearg-numeric-ids-generation-02

- Section 1, 5, 6, 10: I am not quite sure what "negative security and
privacy properties" means. Maybe it is just me, but this could be
formulated differently. An example formulation, similar to RFC 7217,
could be "negatively affect the privacy and security properties".

[1] https://mailarchive.ietf.org/arch/msg/pearg/7GAOjlLssjFBORob3KEqMovBfP4/

---

From: Sara Dickinson <[email-masked]>
Date: Mon, 23 Nov 2020 17:46:41 +0000

Hi All, 

With only minor comments received we’ll be progressing this document beyond RGLC. Authors - please respond to the comments and submit a revised I-D!

Best regards

> On 16 Nov 2020, at 17:39, Sara Dickinson <[email-masked]> wrote:
> 
> Hi All,
> 
>> On 4 Nov 2020, at 13:34, Sara Dickinson <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi All, 
>> 
>> [email-masked] <mailto:[email-masked]>