Subject: [Pidloc] Comments on REQUIREMENT DRAFT draft-xyz-pidloc-reqs-00

From: Shunsuke Homma <[email-masked]>
Date: Wed, 19 Jun 2019 17:10:36 +0900

Hi, 

It was disappointing that the BoF proposal could not get approval, but I reviewed PS and Req drafts, and 
send some comments.

I felt that the situation  where privacy problems would occur is ambiguous, and thus I’d like propose following categorization on deployment scenarios of ID-Loc as additional sections .

----
X. Deployment Scenarios of ID-Loc and Potential Risks 

There are several variations on deployment of ID-Loc architecture. This section describes the overviews of some deployment scenarios and their potential risks.

X.1. Internal of Single Administrative Domain
In this scenario, all of ID Loc functions, such as mapping database or ID-Loc node, run within a single administrative domain.  For example, an enterprise data center or a carrier network are categorized to this. The locators are generally never know by 3rd parties, and there are few risks that location or movement privacies are exposed. 

X.2. Across Multiple Trust Domains
In this scenario, ID-Loc functions are connected via domains of other trusted administrators. For example,  enterprise with multiple sites connected via dedicated line is categorized to this. ID-Loc functions on each site communicate over networks operated by other administrators, and thus ID, locator, and  the mapping may be grasped by the administrators of the intermediate network.

X.3. Across Un-Trusted Domains
In this scenario, ID-Loc functions are connected via un-trusted domains such as Internet. Both  data and control planes of ID-Loc are communicated via unspecified networks, and thus there are risks to be stolen information about location or movement of ID by 3rd persons.

X.4. Globally Distributed
In this scenario, ID-Loc is used instead of current IP mechanism, and every packet is forwarded based on locators independent from IDs. ID-Loc mapping system runs as hierarchical or decentralized system to provide mapping of ID and locator for ID-Loc nodes of multiple (administrators) domains. (I.e., ID-Loc mapping system runs as similar with DNS server.) In such case, ID-Loc mapping system should be accessible for unspecified nodes, and this means unspecified nodes are able to get the mapping information. In addition, it is possible to be a target of attacks such as DDoS attack.

----

Also, I have some small comments as below.
- The status of such documents should be "Informational".
- Scalability is actually important requirement, but the meaning is very wide. It would be able to be broken down into several aspects such as system implementation and the number of accommodated users.
- Flexibility can be broken down  as well.

If you have any questions or opinions, please feel free to contact me.

Best regards,

Shunsuke

From: Pidloc [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Tuesday, May 28, 2019 12:15 AM
To: [email-masked]
Cc: Padma Pillay-Esnault; <[email-masked]>
Subject: [Pidloc] REQUIREMENT DRAFT draft-xyz-pidloc-reqs-00 SUBMISSION

Folks,

Just now, we submitted the requirement draft Rev. 00.

Please read it, it is very short.

Send your comments, text contributions to the list.

Have a nice Memorial Day.

Regards,

Behcet

A new version of I-D, draft-xyz-pidloc-reqs-00.txt
has been successfully submitted by Behcet Sarikaya and posted to the
IETF repository.

Name:           draft-xyz-pidloc-reqs
Revision:       00
Title:          Requirements to Secure End to End Privacy in IdLoc Systems
Document date:  2019-05-27
Group:          Individual Submission
Pages:          6
URL:            https://www.ietf.org/internet-drafts/draft-xyz-pidloc-reqs-00.txt
Status:         https://datatracker.ietf.org/doc/draft-xyz-pidloc-reqs/
Htmlized:       https://tools.ietf.org/html/draft-xyz-pidloc-reqs-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-xyz-pidloc-reqs

Abstract:
   Use of Identifier Locator separation systems is proposed for various
   use cases to allow for efficient and service aware flexible end-to-
   end routing.  A statement on the issue of privacy preservation of
   both users and devices identity and location describes major
   challenges identified for this problem.  This document attempts to
   derive requirements towards a potential solution space of approaches
   to preserve privacy in Identifier-Locator split (PidLoc) protocols.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: 선경재 <[email-masked]>
Date: Thu, 27 Jun 2019 22:40:45 +0900

Hi behcet and Dirk,

I am sorry to give comments for pidloc draft.

When I read requirements document, I agree with Shunsuke’s comment about “Flexibility” part.

Not only privacy can be provided differ depending time and space, even sometimes it has to be maintain stable privacy requirement when time or space is changed.

In my opinion, “Flexibility” part should be covered both aspects.

Regards,

KJ

Kyoungjae Sun / K. J. SUN (Ph. D. Student)
----------------------------------------------------------------------------
Distributed Computing & Network laboratory (DCN Lab)
School of Electronic Engineering, Soongsil Univ.
369 Sangdo-ro, Dongjak-gu, Seoul.
----------------------------------------------------------------------------
Tel. +82-2-814-0151
Mobile +82-10-3643-5627
Email [email-masked]

> 2019. 6. 19. 오후 5:10, Shunsuke Homma <[email-masked]> 작성:
> 
> Hi, 
> 
> I felt that the situation  where privacy problems would occur is ambiguous, and thus I’d like propose following categorization on deployment scenarios of ID-Loc as additional sections ..
> 
> 
> ----
>   <>
> From: Pidloc [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Behcet Sarikaya
> To: [email-masked] <mailto:[email-masked]>
> Cc: Padma Pillay-Esnault; <[email-masked] <mailto:[email-masked]>>
> URL:            https://www.ietf.org/internet-drafts/draft-xyz-pidloc-reqs-00.txt <https://www.ietf.org/internet-drafts/draft-xyz-pidloc-reqs-00.txt>
> Status:         https://datatracker.ietf.org/doc/draft-xyz-pidloc-reqs/ <https://datatracker.ietf.org/doc/draft-xyz-pidloc-reqs/>
> Htmlized:       https://tools.ietf.org/html/draft-xyz-pidloc-reqs-00 <https://tools.ietf.org/html/draft-xyz-pidloc-reqs-00>
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-xyz-pidloc-reqs <https://datatracker.ietf.org/doc/html/draft-xyz-pidloc-reqs>
> 
> 
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> The IETF Secretariat
> 
> -- 
> Pidloc mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/pidloc <https://www.ietf.org/mailman/listinfo/pidloc>

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 27 Jun 2019 09:40:45 -0500

Folks,

Thanks for all the comments.
Now that we received some feedback from SEC ADs, we need to consider those
and take future steps based on that. One feedback was if I am not wrong
there were too many use cases.
Dirk is going to talk to the ADs during IETF 105 week next month and
hopefully get a more clear picture of what they want.
Let's see what they say. I think that any further action on the existing
work should be delayed until that time.

Right now I can say that we drop the side meeting plan and replace it with
SAAG presentation on Thursday July 25.
Those who are attending IETF 105 please make sure to be there at the SAAG
meeting.
SAAG meeting attracts a large audience, usually SEC area WG chairs shortly
present their sessions, and some additional presentations like proposed
BOFs.

Regards,
Behcet

On Wed, Jun 19, 2019 at 3:10 AM Shunsuke Homma <
[email-masked]> wrote:

> I felt that the situation  where privacy problems would occur is
> ambiguous, and thus I’d like propose following categorization on deployment
> scenarios of ID-Loc as additional sections .
>
>
> ----
> There are several variations on deployment of ID-Loc architecture. This
> section describes the overviews of some deployment scenarios and their
> potential risks.
>
>
> In this scenario, all of ID Loc functions, such as mapping database or
> ID-Loc node, run within a single administrative domain.  For example, an
> enterprise data center or a carrier network are categorized to this. The
> locators are generally never know by 3rd parties, and there are few risks
> that location or movement privacies are exposed.
>
> In this scenario, ID-Loc functions are connected via domains of other
> trusted administrators. For example,  enterprise with multiple sites
> connected via dedicated line is categorized to this. ID-Loc functions on
> each site communicate over networks operated by other administrators, and
> thus ID, locator, and  the mapping may be grasped by the administrators of
> the intermediate network.
>
>
> In this scenario, ID-Loc functions are connected via un-trusted domains
> such as Internet. Both  data and control planes of ID-Loc are communicated
> via unspecified networks, and thus there are risks to be stolen information
> about location or movement of ID by 3rd persons.
>
> In this scenario, ID-Loc is used instead of current IP mechanism, and
> every packet is forwarded based on locators independent from IDs. ID-Loc
> mapping system runs as hierarchical or decentralized system to provide
> mapping of ID and locator for ID-Loc nodes of multiple (administrators)
> domains. (I.e., ID-Loc mapping system runs as similar with DNS server.) In
> such case, ID-Loc mapping system should be accessible for unspecified
> nodes, and this means unspecified nodes are able to get the mapping
> information. In addition, it is possible to be a target of attacks such as
> DDoS attack.
>
> ----
>
> - Scalability is actually important requirement, but the meaning is very
> wide. It would be able to be broken down into several aspects such as
> system implementation and the number of accommodated users.
> *From:* Pidloc [mailto:[email-masked]] *On Behalf Of *Behcet
> Sarikaya
> *Sent:* Tuesday, May 28, 2019 12:15 AM
> *To:* [email-masked]
> *Cc:* Padma Pillay-Esnault; <[email-masked]>
> *Subject:* [Pidloc] REQUIREMENT DRAFT draft-xyz-pidloc-reqs-00 SUBMISSION
>
>
>
> Folks,
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-xyz-pidloc-reqs-00.txt
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-xyz-pidloc-reqs
>
>
> Abstract: