Subject: Re: Header Stripping in Cellular

From: Zoran Kostic <[email-masked]>
Date: Fri, 22 Oct 1999 15:27:30 -0400 (EDT)

Phil wrote:
> 
> Sorry, what do you mean by "header stripping"?
> 
> Phil
> 

 Phil, 

  Please take a look at the PILC mail  
  archive where Ali Irfan quotes the
  text from a proposal for a cellular
  standard (e-mail subject is Header Stripping
  dated Oct. 7)... I think that is not the only
  document where the idea appears.

  This is how I understand what "header stripping" 
  relates to and what it means:

  * There are channels similar to the category of
    dedicated packet channels that maintain
    the link between the base and the mobile
    even in the absence of actual packet transmissions
    (for power control, ...) 
  * These channels look like circuit switched 
    channels
  * Proponents of "header stripping" argue that
    new TCP segments hitting these
    channels are going to a single mobile. Many 
    of these (or all) could have the same header.
    Why transmit the header more than once when
    possible ? That is to say, let's do header stripping
    at the transmit side and recreation (reappending) 
    at the reciver side of the wireless link.

  Zoran

---

From: Phil Karn <[email-masked]>
Date: Fri, 22 Oct 1999 12:34:13 -0700

So how does this differ from, say, VJ TCP/IP header compression?

There's nothing wrong with compression as long as the end-to-end
semantics are preserved. VJ header compression does this by passing
the TCP header checksum unchanged in the compressed frame. If the
decompression fails for whatever reason, the checksum will fail and
the end-to-end protection afforded by TCP is preserved.

If, on the other hand, you terminate the TCP connection at a gateway,
stripping out *all* of its header info, and passing just the user data
into a newly originated connection of some sort, you have violated the
end-to-end sematics of TCP and you should have your hand slapped. That
is apparently what WAP (Why Another Protocol?) does, and why it's such
a bad idea.

Phil

---

From: Gabriel Montenegro <[email-masked]>
Date: Fri, 22 Oct 1999 15:14:57 -0700 (PDT)

> So how does this differ from, say, VJ TCP/IP header compression?

it's interesting to go read good ol' rfc1144 (vj compression) appendix C
on "More Aggressive compression". footnote 50 condemns compressing
the tcp checksum, but vj himself admits eliding it towards the end of
appendix C for a special case. 

it does seem awful risky, though.

-gabriel