Subject: Comments on draft-ietf-pilc-2.5g3g-04 part 1

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 01 Nov 2001 10:25:22 +0000

Comments on draft-ietf-pilc-2.5g3g-04 
31-Oct-2001

I haven't got time at this moment to look through this
in as much detail as I would have hoped, sorry.

Most of the points raised earlier have been addressed.
There are just a few areas in which more clarification may 
be desirable....

I'll send minor issues (NiTs) in a separate email.

Gorry Fairhurst

---

page 5 section 3.1.2 para 1: Delayed ACK
I think delayed ACK is a standard mechanism - so better
to say so rather, than say "widely deployed".

page 5 section 3.1.2 final para: Gateway?
"between a gateway and a mobile node".
The term "gateway" is one that has many meanings, 
suggest the ID clarifies this by saying the "wireless gateway" 
or something. I think this needs to be clearer, because 
the ID seems to say that >2 segments is safe in some case, 
but don't say exactly what that is. Does this refer
to a form of PEP??? or is it an ip-level gateway???

page 6 section 3.1.7: ECN?
The discussion of a "CE bit" would probably be better
saying a CE signal, or CE bit(s), given the promising
nature of the ECN-NONCE scheme being discussed in the
transport area working group. Check progress there,
or rephrase to be more general (as above).

The last sentence says "use of ECN" is heavily dependent
on the ... support of relevant routers.  This isn't
really correct - correct operation doesn't imply
that the routers have to be ECN capable, since the ECN
scheme is backwards compatible with non ECN capable routers.
I think it could be better to say the "potential 
improvement in performance can only be achieved when
ECN capable routers are deployed along the path".

Would you like to recommend deployment of ECN in 2.5/3G networks
- why?

NEW RENO?
The ID doesn't mention "New Reno" at all. This may be
useful to mention at some place, since the ID explicitly
mention RENO and traditional (does this mean Tahoe?)
TCP already.

---

---

From: Lloyd Wood <[email-masked]>
Date: Thu, 1 Nov 2001 14:24:05 +0000 (GMT)

> scheme is backwards compatible with non ECN capable routers.

in theory. this presumes 'unused' bits are preserved in all
implementations.

L.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>