Subject: L2 Triggers Bar-BOF

From: Aaron Falk <[email-masked]>
Date: 11 Mar 2002 10:22:26 -0800

Hey-

There's going to be a Bar-BoF in Minneapolis on Layer 2 triggers which
might be of interest to the folks on this list.  See below for the
invitation and a (discarded) draft description for a real BoF.  I'm
including the BoF description since it's the best overview I have on the
issues.  One of the goals of the Bar-BoF will be to understand L2
trigger applications to ensure that an IETF effort (wg or bof) will have
an architectural approach that has the right balance of minimalism and
specificity. 

--aaron

On Thu, 2002-03-07 at 18:37, Carl Williams wrote:
> A L2 triggers pre-BOF will be held at the IETF
> on Monday nite at 10:00pm.  We will meet
> at 10:00pm in front of the bulletin board near
> the IETF registration desk  and 
> proceed to an empty conference room.
> 
> Aaron Falk ([email-masked]) and myself
> will co-chair the pre-BOF discussion on
> L2 triggers.  Aaron is currently co-chair
> of the PILC working group and we will
> work together in faciliating a good discussion
> on L2 triggers in preparation for
> an official BOF in Japan.
> 
> There have been several L2 related internet
> drafts both dealing with more wireless area.
> We would like to get some discussion about 
> how L2 triggers can be broadened out of being
> strictly a wireless related thing and be more general. 
> 
> Please join us in this pre-BOF L2 triggers debate
> on Monday, March 18.
> 
> 
> Thanks
> 
> Carl and Aaron
> Co-chairs of L2 Triggers Pre-BOF
> 
> L2 Trigger Pre-BOF
> 10:00pm on March 18 (Monday evening)
> In front of IETF bulletin board (near IETF registration)

BoF Description
---------------

Since the PILC working group was formed, an additional
set of problems involving the interaction between wireless
link layers and IP has emerged. These problems all have in
common the need for timely information from the link layer
about certain processes that are unique to wireless networks,
and which critically impact the performance or ease of implementation
at the IP layer. Such information has generically been called L2
triggers.

Specific examples of L2 triggers are information required to 
improve handover performance, particularly for real time traffic,
and to allow IP dormant mode host alerting (a.k.a paging)
to utilize link layer paging support. Drafts discussing these
particular problems are draft-manyfolks-mobilereq-l2-04.txt,
for handover, and draft-guri-seamoby-lahap-00.txt, for paging.
Additional possible uses of L2 triggers that have been
suggested are for MANETS and for radio QoS signaling. This 
BOF will discuss currently proposed and suggested uses for L2 triggers,
and whether enough work in this area exists to form a working
group.

Possible Topics for a Working Group Charter (should one be deemed
desirable)
----------------------------------------------------------------

- Accept draft-manyfolks-mobilereq-l2.txt as a WG draft and 
complete to Informational RFC status.

- Accept that part of draft-guri-seamoby-lahap-00.txt dealing
with L2 triggers for paging and complete to Informational RFC status.

- Solicit Internet drafts on L2 triggers of MANETs, in conjunction with
the MANET group, and radio QoS signaling, in conjunction with the NSIS
group, for completion to Informational RFC status.

- Develop and standardize an IP protocol for handover L2 triggers
between bridging access points and access routers. This would be for L2
protocols in which a wired IP access network separates the access point
from the access router.

- Discuss with IEEE 802.11, and any other SDO that might need it, the
possibility of including L2 triggers in their L2 protocols.

---

From: Patrick Cipiere <[email-masked]>
Date: Mon, 11 Mar 2002 19:47:17 +0100

Where can I get draft-manyfolks-mobilereq-l2.txt and 
draft-guri-seamoby-lahap-00.txt

Thanks,
Patrick.
-- 
UDcast: Full IP over Broadcast Media

Phone:  (+33) (0)4 93 00 16 99
Mobile: (+33) (0)6 14 21 55 98
Fax:    (+33) (0)4 93 00 16 61                 http://www.UDcast.com

---

From: "Carl Williams" <[email-masked]>
Date: Mon, 11 Mar 2002 10:53:13 -0800

http://www.potaroo.net/ietf/ids/draft-manyfolks-l2-mobilereq-01.txt

For draft-manyfolks-l2-mobilereq-01.txt

and

      http://mirrors.sunsite.dk/drafts/draft-guri-seamoby-lahap-00.txt

for:

         Layer-2 aided mobility independent dormant host alerting
                             protocol

----- Original Message -----
From: "Patrick Cipiere" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Monday, March 11, 2002 10:47 AM
Subject: Re: L2 Triggers Bar-BOF

---

From: Aaron Falk <[email-masked]>
Date: 11 Mar 2002 10:51:57 -0800

> Where can I get draft-manyfolks-mobilereq-l2.txt and 

http://search.ietf.org/internet-drafts/draft-manyfolks-l2-mobilereq-01.txt

> draft-guri-seamoby-lahap-00.txt

http://search.ietf.org/internet-drafts/draft-guri-seamoby-lahap-00.txt

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 12 Mar 2002 08:46:25 -0800 (PST)

Hello  Aaron,
  As a coauthor let me suggest a correction to your
email,
The draft that defines an API for paging triggers is:
http://search.ietf.org/internet-drafts/draft-guri-seamoby-paging-triggers-00.txt

while the draft:

used these triggers in defining an IP Paging protocol.

  Therefore I think that the reference in your BOF
description should be changed to 
draft-guri-seamoby-triggers-00.txt.

Regards,
> possibility of including L2 triggers in their L2

__________________________________________________
Do You Yahoo!?
Try FREE Yahoo! Mail - the world's greatest free email!
http://mail.yahoo.com/

---

From: Aaron Falk <[email-masked]>
Date: Sun, 17 Mar 2002 16:18:15 -0800

Reminder of the L2 Triggers bar bof:

  A L2 triggers pre-BOF will be held at the IETF on Monday nite at
  10:00pm.  We will meet at 10:00pm in front of the bulletin board
  near the IETF registration desk and proceed to an empty conference
  room.

Drafts worth reading are:

    draft-guri-seamoby-paging-triggers-00.txt

    draft-manyfolks-l2-mobilereq-01.txt

    (note: there were some typos in the earlier draft names I sent
    out)

--aaron