Subject: Question about IEEE 802.11 RLC and Error control?

From: Qiang Ni <[email-masked]>
Date: Tue, 12 Mar 2002 18:10:44 +0100

Dear all PILC experts:

I am a research engineer in INRIA. And I am very interested in TCP/UDP
over IEEE 802.11.
I know 802.11 specify the MAC layer function as DCF,PCF and PHY as
DSSS,FHSS and Infrared.

But I have a question about 802.11 link layer, does it have a error
control(FEC,ARQ) or RLC
layer for radio error control?Or it only use 802.2 LLC for data link
control the same as 802.3
Ethernet? 

Please help me to answer my question.

Thanks a lot,

Qiang Ni
-- 

***********************************
Planete Group,
Sophia Antipolis,INRIA,France
[email-masked]
(+33) 4 92 38 79 59
***********************************

---

From: Qiang Ni <[email-masked]>
Date: Tue, 12 Mar 2002 18:42:55 +0100

Hi,Miguel Sanchez:

But 802.11 does link layer ARQ(ACK) only for collision avoidance. And if
there is some
shadowing or fading,the receiver will not receive the frame correctly
and will not send 
the ACK frame, then the sender will misunderstand it come from collision
and backoff,that
will degrade the throughput, especially inefficient for realtime
error-torelent apllication.
Is my argument right?

Best,
Ni

Miguel Sanchez wrote:
> 
> Hi,
> 
> 802.11 does link layer ARQ (that's the purpose of the ACK frame). You can
> get the whole specs from grouper.ieee.org
> 
> Of course this is true for unicast frames, not for broadcasts.
> 
> Miguel Sanchez
> Polythecnic University of Valencia, Spain
> 
> ----- Original Message -----
> From: "Qiang Ni" <[email-masked]>
> To: "pilc" <[email-masked]>
> Sent: Tuesday, March 12, 2002 6:10 PM
> Subject: Question about IEEE 802.11 RLC and Error control?
> 
> > Dear all PILC experts:
> >

--

---

From: "Miguel Sanchez" <[email-masked]>
Date: Tue, 12 Mar 2002 19:43:14 +0100

Hi Qiang,

Don't think so.

ACK mission is to inform the sender about ok reception of the frame. Failure
to get ack will signal a reception problem but NOT a collision.

RTS/CTS will prevent the collision to happen.

If you don't use RTS/CTS then the absence of an ack could mean a collision
though.

Regards,

Miguel Sanchez