Subject: [pilc] Re: BCP 69, RFC 3449 on TCP Performance Implications of Network Path Asymmetry

From: Aaron Falk <[email-masked]>
Date: Thu, 19 Dec 2002 17:52:58 -0800

Congratulations Hari, Venkata, Gorry, and Mahesh!  Another pilc
milestone accomplished.  Thanks to the working group for your help in
crafting and reviewing this doc.

Again many thanks,

--aaron

[email-masked] wrote:
> 
> A new Request for Comments is now available in online RFC libraries.
> 
> 
>         BCP 69
>         RFC 3449
>                                       
>         Title:      TCP Performance Implications of Network Path
>                     Asymmetry
>         Author(s):  H. Balakrishnan, V. Padmanabhan, G. Fairhurst,
>                     M. Sooriyabandara
>         Status:     Standards Track
>         Date:       December 2002
>         Mailbox:    [email-masked], [email-masked],
>                     [email-masked], [email-masked]
>         Pages:      41
>         Characters: 108839
>         See Also:   BCP 69
>                                       
>         I-D Tag:    draft-ietf-pilc-asym-08.txt
> 
>         URL:        ftp://ftp.rfc-editor.org/in-notes/rfc3449.txt
> 
> 
> This document describes TCP performance problems that arise because of
> asymmetric effects.  These problems arise in several access networks,
> including bandwidth-asymmetric networks and packet radio subnetworks,
> for different underlying reasons.  However, the end result on TCP
> performance is the same in both cases: performance often degrades
> significantly because of imperfection and variability in the ACK
> feedback from the receiver to the sender.
> 
> The document details several mitigations to these effects, which have
> either been proposed or evaluated in the literature, or are currently
> deployed in networks.  These solutions use a combination of local
> link-layer techniques, subnetwork, and end-to-end mechanisms,
> consisting of: (i) techniques to manage the channel used for the
> upstream bottleneck link carrying the ACKs, typically using header
> compression or reducing the frequency of TCP ACKs, (ii) techniques to
> handle this reduced ACK frequency to retain the TCP sender's
> acknowledgment-triggered self-clocking and (iii) techniques to
> schedule the data and ACK packets in the reverse direction to improve
> performance in the presence of two-way traffic.  Each technique is
> described, together with known issues, and recommendations for use.  A
> summary of the recommendations is provided at the end of the document.
> 
> This document is a product of the Performance Implications of Link
> Characteristics Working Group of the IETF.
> 
> This document specifies an Internet Best Current Practices for the
> Internet Community, and requests discussion and suggestions for
> improvements.  Distribution of this memo is unlimited.
> 

_______________________________________________
pilc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pilc
http://www.ietf.org/html.charters/pilc-charter.html
http://pilc.grc.nasa.gov/

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 20 Dec 2002 09:03:38 -0600

Yes, just to echo Aaron's congratulatons - thanks for your hard work and diligence.

And now, to LINK ...

Spencer

> -----Original Message-----
> From: Aaron Falk [mailto:[email-masked]]
> Sent: Thursday, December 19, 2002 7:53 PM
> To: PILC IETF working group; Gorry Fairhurst; [email-masked];
> [email-masked]; [email-masked]
> Subject: [pilc] Re: BCP 69, RFC 3449 on TCP Performance 
> Implications of
> Network Path Asymmetry
> 
>