Subject: Re: Comments on draft-ietf-pim-v2-dm-01.txt

From: Sangeeta Mukherjee <[email-masked]>
Date: Mon, 14 Dec 1998 16:10:44 -0800 (PST)

> From [email-masked] Mon Dec 14 15:57:17 1998
> To: Sangeeta Mukherjee <Sangeeta.Mukherjee@Eng>
> cc: [email-masked], [email-masked]
> Subject: Re: Comments on draft-ietf-pim-v2-dm-01.txt 
> Date: Mon, 14 Dec 1998 15:57:03 PST
> From: Bill Fenner <[email-masked]>
> 
> Actually, I think the draft shouldn't mention IGMP at all, other
> than describing it as one way of determining group membership on
> an interface.  PIM's actions can then be described with respect to
> group memberships on interfaces.
> 
>   Bill
> 

I agree with you Bill. There needs to be no mention of IGMP, but I wanted to 
point out that the routers with no group state, DONT exactly do nothing
in that scenario, as it is stated in the draft. Somehow, IMHO, it should
be stated that the PIM router records group membership in some form
in this scenario, to be later used when the datagram does arrive.

You agree?

> From [email-masked] Mon Dec 14 15:50:49 1998
> From: [email-masked] (Ravi Shekhar)
> Subject: Re: Comments on draft-ietf-pim-v2-dm-01.txt
> To: Sangeeta.Mukherjee@Eng (Sangeeta Mukherjee)
> Date: Mon, 14 Dec 1998 18:50:34 -0500 (EST)
> Cc: [email-masked], [email-masked]
> 
> >
> >Routers with no group state do nothing on  receipt  of  IGMP  reports,
> >since   dense-mode   PIM  will  deliver  multicast  datagrams  to  all
> >interfaces when creating state for a group
> >
> >>From an implementation point of view, is this exactly correct? When a router
> >receives IGMP join request from a directly connected ( say on interface 1)
> >host for group X, and has no (S,G) state for group X, 
> >it needs to record the request somehow that there is a
> >membership request on interface 1 for group X. Then when the router gets a 
> >datagram packet for group X, it would create and (S,G) entry and create
> >a outgoing interface list containing interface 1. 
>     
>     Isnt it the responsibility of the IGMP running on the router to keep
>     this state?
> 
>     How a multicast protocol gets that information from IGMP would depend 
>     on the router implementation. For eg: PIM-DM might be started after
>     IGMP has already been started. In which case there has to be a separate
>     mechanism to inform PIM-DM about the group memberships which were 
>     expressed by hosts before PIM-DM was started.
> 
> 	- Ravi Shekhar.
> 
> 
> >
> >Should this be stated in the draft in some form?
> >
> >Sangeeta
> >
> 
>

---

From: Bill Fenner <[email-masked]>
Date: Mon, 14 Dec 1998 16:29:30 PST

In message <[email-masked]>you write:
>in that scenario, as it is stated in the draft.

I figured that just removing the mention of IGMP, including removal
of the wording that says that the PIM router does nothing in that
situation, would be enough.  Then, the first paragraph of section
5 is sufficient to describe how the outgoing interface list is
populated ("interfaces that have PIM routers present or host members
for group G").

The PIM *portion* of the router can be thought of as doing nothing
when a new group member appears when there's no state for group G,
as long as you imagine it querying whatever mechanisms are being
used to track members when traffic arrives (as implied in section 5).

  Bill