Subject: Re: PIM-SM receiving (S,G) Prune question

From: Vera Volfson <[email-masked]>
Date: Thu, 10 Dec 1998 13:50:42 -0500

>Hi,

>On Thu, 10 Dec 1998, Vera Volfson wrote:

>> [(S,G)RPT prune]
>> 2. For each address, Sp, in the prune list whose RPT-bit is set and whose
>>  WC-bit cleared:
>> 
>>    2.If there is an existing (Sp,G) route entry, the router lowers the entry's
>>      Oif-timer for I to its Oif-Deletion-Delay, allowing for other downstream 
>      routers on a multi-access LAN to override the prune.
>      However, on point-to-point links, the oif-timer is expired immediately.
> 
> ...
> 
> and the paragraph 4 states for both cases:
> 
>     4.If there exists a (Sp,G) entry, with or without the RPT-bit set, 
>       the oif-timer for I is expired, and the Entry-timer is restarted.
> 
> 
> My interpretation is that when the router receives the first prune
> oif-timer is lowered to oif-deletion-delay.
> When the next prune is received the oif is deleted and e-timer restarted.
> 
> Is that correct interpretation?
> 

>I dont think so.  3.2.2 prune-list #2 (d) is not needed IMHO.  This is
>covered separately by 3.2.2 prune-list #1 (a) and 3.2.2 prune-list #2 (a) 
>as you pointed out. I think rusty also points this out in an errata to the
>spec that he maintains.  I hope that it will be incorporated in the new
>spec if it really is the case (question for the authors maybe??). This and
>other errata are at: 

>http://www.isi.edu/~eddy/pim/pim-specv2-notes.html

Hi Shahzad and thanks for the reply.

The errata says 
3.2.2 Prune 2d) should be removed, this is caught by the previous section (a) 

and it seems the right thing to do.

Than my question is - if we set the oif-timer to deletion-delay (70sec)
(as 3.2.2 a states) and the next Prune arrives in 60 sec we should
not reset oif-timer again and just let the oif timeout.

Is that correct?

Thanks,
Vera
-

>Cheers,

>-Shahzad Ali
>ECE Grad University of Delaware.
>Software Enginner, Torrent Networking Tech.

---

From: Shahzad Ali <[email-masked]>
Date: Thu, 10 Dec 1998 14:07:17 -0500 (EST)

Hi,

> not reset oif-timer again and just let the oif timeout.

Sorry.  I didnt get your question right the first time.

3.2.2 Prune-list 2 (a) and 3.2.2 1 (a) say:
"....the router lowers the entry's Oif-timer for I..."
 		^^^^^^

This should explain it.  And yes, I think that you dont reset the timer
and belive that is what the spec also implies.

-Shahzad Ali
ECE Grad University of Delaware.
Software Engineer, Torrent Networking Tech.

---

From: Shahzad Ali <[email-masked]>
Date: Thu, 10 Dec 1998 14:07:17 -0500 (EST)

Hi,

-Shahzad Ali