Subject: PIM-SM: receiving (S,G)RPT prunes

From: Ardas Cilingiroglu <[email-masked]>
Date: Mon, 15 Feb 1999 12:06:28 -0500 (EST)

I believe, section 3.2.2 Receiving Join/Prune Messages, 
the part for receiving (S,G)RPT prunes should be extended
with the following item:

  - if the router is the Last-hop Router on the interface 
    that the (S,G)RPT prune is received, and there are 
    local receivers for the group G, then ignore the prune
    for (S,G)RPT.

The following case explains the reason: 
                           
                               1 
                          RTA---
                           |
                        DR |2
      ------------------------
        |3           |
        |            |
   4---RTB      local-receiver

 RTA: (*,G) iif=1 oif={2}
 RTB: (*,G) iif=3 oif={4} with RPF being RTA

When RTB receives a Prune for (S,G)RPT on interface 4, 
it will create (S,G)RPT entry with iif=3 and oif=NULL, 
and trigger a Prune for (S,G)RPT towards RTA.

At this point, RTA will also create (S,G)RPT entry with 
iif=1 and oif=NULL. This will deprive the local receiver
from (S,G) data.

thanks,
Ardas

---

From: [email-masked]
Date: Tue, 16 Feb 1999 08:42:35 -0800 (PST)

you're corrcet.  the wording in the spec may be unclear, or even non
existant, in general, no iface should be removed from the oif list
of an entry if there are local members.

- rusty