Subject: Interop

From: Mani M <[email-masked]>
Date: Thu, 4 Nov 1999 18:24:05 +0530

The Draft draft-thaler-multicast-interop-p3.txt says
"The MBR consists of two or more active multicast routing components, each running an instance of multicast routing protocol"

(i) Applying the above statement specifically to interop between SM and DM. does it mean that two independent tasks run in SM and DM mode respectively ? 

(ii) In cases where a the multicast router is a domain router where all the interfaces are configured in eiether SM mode or DM mode, does an independent instance(task) of a protocol run in each interface or a single instance(task) takes care of all interfaces.

Thanks
Mani

---

From: Dave Thaler <[email-masked]>
Date: Thu, 4 Nov 1999 12:32:52 -0800 (PST)

> The Draft draft-thaler-multicast-interop-p3.txt says
(This document is now RFC 2715)

> "The MBR consists of two or more active multicast routing components, 
> each running an instance of multicast routing protocol"
> 
> (i) Applying the above statement specifically to interop between SM and 
> DM. does it mean that two independent tasks run in SM and DM mode 
> respectively ? 

Not quite.  It implies that PIM-SM and PIM-DM are two "components"
in the language of the RFC.  As stated in the same paragraph
> No assumption is made about ... the nature of a "component".
So whether there is one task per component or multiple components
in the same task is an implementation decision.

> (ii) In cases where a the multicast router is a domain router where 
> all the interfaces are configured in eiether SM mode or DM mode, does 
> an independent instance(task) of a protocol run in each interface or 
> a single instance(task) takes care of all interfaces.

A single instance.  See the next paragraph which states
> The router has one or more active interfaces
> in each domain, and one component per domain.
This implies multiple interfaces per "component".
(a "task" is not defined in this document, so you'll have to
interpret according to your own definition of "task" that you use).

-Dave