Subject: PIM-SM and DM interoperation

From: Mani M <[email-masked]>
Date: Fri, 19 Nov 1999 15:47:57 +0530

Hi

The Interop RFC 2715 says

(i) The MBR consists of two or more active multicast routing
components, each running an instance of some multicast routing
protocol.  
(ii) Each component typically keeps a separate multicast routing table with any type of entries.

If we consider PIM as a single component configuring one the PMBR's interface in SM mode (connected to the SM domain) and the other in DM Mode (connected to the DM domain), The  statement (i) and (ii) becomes invalid, I suppose as there is a only a single component in The MBR and only a single MRT. 
PL correct me if i'am wrong

Will be same arguement apply in the case of PIM-SM and DVMRP ?

In all My doubt is When and WHy separate Multicast routing tables required ?

Thanks in Advance
Mani

---

From: Dave Thaler <[email-masked]>
Date: Fri, 19 Nov 1999 06:48:47 -0800 (PST)

Mani writes:
> If we consider PIM as a single component configuring one the PMBR's 
> interface in SM mode (connected to the SM domain) and the other in DM Mode 
> (connected to the DM domain), The  statement (i) and (ii) becomes invalid, 

Those statements are saying that the rules in this RFC apply to
architectures that fit these assumptions.  If you choose to
describe an implementation in a different way, then you're
on your own.  PIM-SMv2 (RFC 2362 or whatever) doesn't fit your
description though.

> I suppose as there is a only a single component in The MBR and only a 
> single MRT. 

If you choose to view a router as a single component with
one interface in PIM-SM "mode" and one interface in "DVMRP mode"
you're on your own.  This RFC says how you can get interoperability
if you describe them as two components.

> In all My doubt is When and WHy separate Multicast routing tables required ?

Different protocols keep different information, different timers, etc.
For example, DVMRP keeps (Sprefix,G) state, whereas PIM-DM keeps
(S,G) state, and PIM-SM keeps any or all of (*,G), (S,G) and (*,*,RP)
state.

-Dave