Subject: PMBR Nad threshold configurations for PIM

From: Mani M <[email-masked]>
Date: Thu, 11 Nov 1999 16:26:31 +0530

Hi

How does one configure the Border router and threshold values for 
group and sources.

separate mib objects should be provided in the pim mib draft for
 
(i)  Configuring a router as a BORDER ROUTER.
(ii) Configuring the threshold values for group and sources
within the group.

Bye
Mani

---

From: Peter Livesey <[email-masked]>
Date: Thu, 11 Nov 1999 11:48:05 +0000

possible mib table for Thresholds?

-- PIM enterprise SPTSwitching table

pimEntSPTSwitchingTable OBJECT-TYPE
    SYNTAX SEQUENCE OF PimEntSPTSwitchingEntry
    ACCESS not-accessible
    STATUS     mandatory
    DESCRIPTION
            "The (conceptual) table listing Shared Tree (RPT) to Shortest Path
Tree (SPT) Switchover and SPT to RPT Switchback, management parameters and
counters, specific to one or more RPT routes of type
pimEntSPTSwitchingRouteType. This table only applies to SPT Switching initiated
by a leaf router."
    ::= { cascpim 3 } 

pimEntSPTSwitchingEntry OBJECT-TYPE
    SYNTAX     PimEntSPTSwitchingEntry
    ACCESS not-accessible
    STATUS     mandatory
    DESCRIPTION
            "An entry (conceptual row) in the pimEntSPTSwitchingTable."
    INDEX      {pimEntSPTSwitchingRouteType,
 		pimEntSPTSwitchingAddress,
 		pimEntSPTSwitchingMask }
    ::= { pimEntSPTSwitchingTable 1 }

PimEntSPTSwitchingEntry ::= SEQUENCE {
    pimEntSPTSwitchingRouteType
      INTEGER,
    pimEntSPTSwitchingAddress
      IpAddress,
    pimEntSPTSwitchingMask
      IpAddress,
    pimEntSPTSwitchingExistState
      RowStatus,   
    pimEntSPTSwitchingOverStartThreshold
      Integer32,
    pimEntSPTSwitchingOverStopThreshold
      Integer32,
    pimEntSPTSwitchingBackThreshold
      Integer32,
    pimEntSPTSwitchingOverAdminState
      INTEGER,
    pimEntSPTSwitchingBackAdminState
      INTEGER,   
    pimEntSPTSwitchingOverPeriod
      Integer32,
    pimEntSPTSwitchingBackPeriod
      Integer32,   
    pimEntSPTSwitchingOverCount
      Counter32,
    pimEntSPTSwitchingBackCount
      Counter32
}

pimEntSPTSwitchingRouteType OBJECT-TYPE
    SYNTAX INTEGER {
                    	 group (1),
                    	 rp (2)
    }
    ACCESS not-accessible
    STATUS mandatory
    DESCRIPTION
     	    "The type of RPT route(s) that this entry applies to. An entry with 
pimEntSPTSwitchingRouteType of Group applies to either a specific (*,G) route or
a set of (*,G) routes. . An entry with  pimEntSPTSwitchingRouteType of RP
applies to either a specific (*,*, RP) route or a set of (*, *, RP) routes."
    ::= { pimEntSPTSwitchingEntry 1 }

pimEntSPTSwitchingAddress OBJECT-TYPE
    SYNTAX IpAddress
    ACCESS not-accessible
    STATUS mandatory
    DESCRIPTION
            "An address prefix matching either an exact route or a set of routes
of type pimEntSPTSwitchingRouteType. A 0.0.0.0 address can be used in
combination with a 0.0.0.0 mask to indicate that this entry applies to all
routes that don't match a more specific entry. Longest matching entry is
applied."
    ::= { pimEntSPTSwitchingEntry 2 }

pimEntSPTSwitchingMask OBJECT-TYPE
    SYNTAX IpAddress 
    ACCESS read-write
    STATUS mandatory
    DESCRIPTION
     	    "Either a host mask (255.255.255.255) meaning this entry applies to an
exact route or a mask meaning this entry applies to a set of routes. A 0.0.0.0
mask can be used in combination with a 0.0.0.0 address to indicate that this
entry applies to all routes that don't match a more specific entry. Longest
matching entry is applied."
    ::= { pimEntSPTSwitchingEntry 3 }

pimEntSPTSwitchingExistState OBJECT-TYPE
             SYNTAX RowStatus
             ACCESS read-write
             STATUS mandatory
             DESCRIPTION
                 "The existence state of this entry. This object follows
                 the Row Status behavior."
             DEFVAL { active }
    ::= { pimEntSPTSwitchingEntry 4 }

pimEntSPTSwitchingOverStartThreshold OBJECT-TYPE
    SYNTAX Integer32 (1..2147483647)
    ACCESS read-write
    STATUS mandatory
    DESCRIPTION
     	    "The threshold (in KBPS) at which Shortest Path Trees are initiated
for the RPT Route(s) that match this entry."
    DEFVAL     { 1024 }
    ::= { pimEntSPTSwitchingEntry 5 }

pimEntSPTSwitchingOverStopThreshold OBJECT-TYPE
    SYNTAX Integer32 (1..2147483647)
    ACCESS read-only
    STATUS mandatory
    DESCRIPTION
     	    "If the data rate (in KBPS) drops below this threshold, then if SPTs
are being created for the RPT route(s) matching this entry, SPTs shall stop
being initiated."
    DEFVAL     { 1024 }
    ::= { pimEntSPTSwitchingEntry 6 }

pimEntSPTSwitchingBackThreshold OBJECT-TYPE
    SYNTAX Integer32 
    ACCESS read-only
    STATUS mandatory
    DESCRIPTION
     	    "If the data rate (in KBPS) on a SPT drops below this threshold then
the SPT will be switched back to its RPT initiated form an RPT route matching
this entry."
    DEFVAL     { 1024 }
    ::= { pimEntSPTSwitchingEntry 7 }

pimEntSPTSwitchingOverAdminState OBJECT-TYPE
    SYNTAX INTEGER {
                    	 disable (2),
                    	 enable (1)
    }
    ACCESS read-write
    STATUS mandatory
    DESCRIPTION
     	    "Whether RPT to SPT Switch Overs are to be made for the RPT route(s)
matching this entry."
    DEFVAL     { disable }
    ::= { pimEntSPTSwitchingEntry 8 }

pimEntSPTSwitchingBackAdminState OBJECT-TYPE
    SYNTAX INTEGER {
                    	 disable (2),
                    	 enable (1)
    }
    ACCESS read-write
    STATUS mandatory
    DESCRIPTION
     	    "Whether SPT to RPT Switch Backs are to be made for SPTs initiated
from the RPT route(s) matching this entry."
    DEFVAL     { disable }
    ::= { pimEntSPTSwitchingEntry 9 }

pimEntSPTSwitchingOverPeriod OBJECT-TYPE
    SYNTAX Integer32 
    ACCESS read-only
    STATUS mandatory
    DESCRIPTION
"The period (in seconds) in which the aggregate data flow on the RPT route(s),
matching this entry, is to be taken in order to compare against the associated
Switchover threshold."
    DEFVAL     { 1 }
    ::= { pimEntSPTSwitchingEntry 10 }

pimEntSPTSwitchingBackPeriod OBJECT-TYPE
    SYNTAX Integer32 
    ACCESS read-only
    STATUS mandatory
    DESCRIPTION
     	    "The period (in seconds) in which the aggregate data flow on an SPT,
initiated from an RPT route matching this entry,  is taken to compare against
the Switchback threshold."
    DEFVAL     { 60 }
    ::= { pimEntSPTSwitchingEntry 11 }

pimEntSPTSwitchingOverCount OBJECT-TYPE
    SYNTAX Counter32
    ACCESS read-only
    STATUS mandatory
    DESCRIPTION
     	    "The number of RPT to SPT switchovers that have been made for RPT
routes matching this entry."
    ::= { pimEntSPTSwitchingEntry 12 }

pimEntSPTSwitchingBackCount OBJECT-TYPE
    SYNTAX Counter32
    ACCESS read-only
    STATUS mandatory
    DESCRIPTION
     	    " The number of SPT to RPT switchbacks that have been made to RPT
routes matching this entry."
    ::= { pimEntSPTSwitchingEntry 13 }

-- 
______________________________________________________________________

Pete Livesey,                		Tel:   +44 (1252) 360068
Lucent Technologies Inc.,       __      Fax:   +44 (1252) 360077
InterNetworking Systems UK,   //  \\
Suites 11/12, First Base,     ||  ||    URL:   http://www.lucent.com
Beacontree Plaza,             \\__//        
Gillette Way,		        
Reading, Berks, RG2 0BS,                Email: [email-masked]
United Kingdom.
_____________________________________________________________________

---

From: Hitoshi Asaeda <[email-masked]>
Date: Fri, 12 Nov 1999 02:29:42 +0900 (JST)

Sorry if I talk about different topic.

I recognize "Border router" and "PMBR" are different meaning.
Former is a border router to make a boundary between adjacent PIM
domains in order to avoid flooding BSR msg to neighbor PIM domains.
Later is also a border router, but this is connected with *another
routing protocol's domain*, like DVMRP, BGMP domain.

Actually, I'm talking about the terminology. But I believe this
should be clear in a next I-D/RFC, despite I'm correct or not.

Regards.
--
Hitoshi Asaeda