Subject: PMBR

From: Mani M <[email-masked]>
Date: Fri, 19 Nov 1999 15:35:27 +0530

Hi 
 
Assuming a Multcast Border Router(MBR) with  3 components running,
according to the draft there will be 

(i) there will be 3 separte multicast routing tables(MRT)  built and

(ii) there will be a common forwarding cache(CFC)  built and shared
by all the 3 components.

The tables will be maintained by the owner of the component.

Where does the (CFC) reside ? what is it's purpose when there are 
3 multicast forwarding tables ? what is the exact use of the CFC ?

what's the relation between the MRT and CFC generally and in a MBR ?

what roles do the CFC and MRT play in a MBR?

Thanks in advance
Mani

---

From: Dave Thaler <[email-masked]>
Date: Fri, 19 Nov 1999 06:42:15 -0800 (PST)

> (i) there will be 3 separte multicast routing tables(MRT)  built and

There MAY be 3 tables.  (The RFC says "typically")  This is up
to the implementation.

> Where does the (CFC) reside ? 

Up to the implementation.  There's usually one in the "kernel"/fast
path, but it depends on the router architecture.

> what is it's purpose when there are 

The forwarding cache is what the forwarder actually uses
to route packets as they arrive.

> what's the relation between the MRT and CFC generally and in a MBR ?

Up to the implementation.  In software architectures like
mrouted, gated, pimd, etc, the MRT is the join/prune state kept
by the protocol, and the CFC is in the kernel and duplicated
in user space too.  Other router architectures may vary.

> what roles do the CFC and MRT play in a MBR?

A MRT contains protocol-specific information.
The CFC is generic shared information (typically only things
the forwarder needs).

-Dave