Subject: Re: WG Last Call?

From: Ardas Cilingiroglu <[email-masked]>
Date: Wed, 01 Dec 1999 10:51:16 -0500

Liming Wei wrote:

>  o  New text to deal with source's first hop router receiving packets when
>     there is no (S,G) state.
>
>            5 If a packet is received from S on the RPF interface to S, and
>              there is existing (*,G) but no (S,G) state, the implementation
>              MUST guarantee that packets from this source are not forwarded
>              via the RP Tree onto the source subnet. In the absence of
>              other efficient mechanisms to enforce this, an implementation
>              in this situation MAY create (S,G) state, with an outgoing
>              interface list of null, and discard the packet.

I think there are two problems with the above statement:

- (S,G) state should not be created with a NULL oif-list, but
its oif-list should be copied from the parent (*,G) oif-list
(excluding the iif for (S,G) of course).

- Condition "there is existing (*,G) but no (S,G) state"
should be "there is existing (*,G) or (*,*,RP) but no (S,G) state".

>
> Once the draft is in, lets start the WG last call timer.
>
>  Thanks,
> -Liming

---

From: "Parantap Lahiri" <[email-masked]>
Date: Wed, 1 Dec 1999 13:10:38 -0500

Shouldn't the packet get stopped from getting forwarded in the first
place because it didn't arrive on the designated incoming interface i.e
the RPF interface towards the RP.

If, the RPF interface towards RP and S somehow happens to be same, that
interface wont be in the oif list of the (*,G) entry.

Sorry, I may be missing something here.

Thanks

-Parantap

----- Original Message -----
From: Ardas Cilingiroglu <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Wednesday, December 01, 1999 10:51 AM
Subject: Re: WG Last Call?

---

From: "Parantap Lahiri" <[email-masked]>
Date: Wed, 1 Dec 1999 13:55:36 -0500

Misunderstood the initial point, cleared it up with Liming. Thanks
Liming

-Parantap

----- Original Message -----
From: Parantap Lahiri <[email-masked]>
To: Ardas Cilingiroglu <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Wednesday, December 01, 1999 1:10 PM
Subject: Re: WG Last Call?

Thanks

-Parantap

----- Original Message -----
From: Ardas Cilingiroglu <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>

---

From: Liming Wei <[email-masked]>
Date: Sat, 4 Dec 1999 15:07:14 -0800 (PST)

Ardas,

Good point. I know I forgot something. Now fixed the text to say:

           5 If a packet is received from S on the RPF interface to S, and
             there is existing (*,G) or (*,*,RP) but no (S,G) state, the
             implementation MUST guarantee that packets from this source are
             not forwarded via the RP Tree onto the source subnet. In the
             absence of other efficient mechanisms to enforce this, an
             implementation in this situation MAY create (S,G) state with an
             outgoing interface list copied from the associated (*,G) or
             (*,*,RP), and discard the packet.

 Thanks,
-Liming
------------