Subject: Re: WG Last Call?

From: [email-masked] (Billy Ng)
Date: Wed, 1 Dec 1999 12:56:58 -0500

> From [email-masked] Tue Nov 30 23:11:12 1999
> 
> 
> Okay, then lets start the timer...
> 
> I'm submitting the sm draft now. It is the same as the last one posted
> except for the following change, based on feedback at the DC meeting:
> 
> 
>  o  New text to deal with source's first hop router receiving packets when
>     there is no (S,G) state.
> 
>            5 If a packet is received from S on the RPF interface to S, and
>              there is existing (*,G) but no (S,G) state, the implementation
>              MUST guarantee that packets from this source are not forwarded
>              via the RP Tree onto the source subnet. In the absence of
>              other efficient mechanisms to enforce this, an implementation
>              in this situation MAY create (S,G) state, with an outgoing
>              interface list of null, and discard the packet.
> 

Sorry I might be missing something here since I was not at the meeting.

If this is the first hop router, it should always prune its own traffic
if it already has a (*,G) state.  However, when creating the (S,G) state,
it should copy the OIF from the (*,G), so why is (S,G) being created
without any outgoing interfaces?

--Billy

> Once the draft is in, lets start the WG last call timer.
> 
>  Thanks,
> -Liming
>

---

From: "Shekhar, Ravi" <[email-masked]>
Date: Wed, 1 Dec 1999 14:27:11 -0500

>              interface list of null, and discard the packet.

  I think it should be clarified as to which packet is 
  being "discarded" - the one coming from RP or the one
  coming from the source directly. 

  If its the one coming from the RP which is being 
  discarded, then SG entry should have iif as the interface 
  on which S is present, and the copy of oifs from <*, G>/<*, *, RP>
  minus the interface on which source is present.
  Also <S, G> prune should be sent towards RP etc. (which will 
  automatically follow if we treat it as SG-SPT transition).

  If the intention is to discard the packets coming from source
  directly, then an SG-RPT entry should be created with iif as 
  RPF towards RP, and oifs again as copy of oifs from <*, G>/<*, *, RP>
  minus the interface on which source is present.

  - Ravi Shekhar.

---

From: "Shekhar, Ravi" <[email-masked]>
Date: Wed, 1 Dec 1999 14:54:06 -0500

Whoops, sorry. My mistake. I take it back.
The previous statement does say that the packets coming from
RP should be discarded. I got confused by the other mails 
on the topic.

- Ravi Shekhar.

  - Ravi Shekhar.

---

From: [email-masked] (Billy Ng)
Date: Wed, 1 Dec 1999 23:26:22 -0500

so my question is the same, why are we re-thinking to have this new
text in the pim-sm draft?  It's already spelled out quite clearly
in the original draft.

----- Begin Included Message -----

>From [email-masked] Wed Dec  1 18:20:25 1999

At the first look, I overlooked the "via RP tree" key word in the
statement, hence I posted my question.

Here is how I understand it now:

Lets consider that the interface which contains the source, had a
receiver for the same group before the source became active, thus the
(*,G) oif-list included that interface.

When the source S comes-up, the multicast router starts sending
encapsulated unicast registers towards the RP, and the same traffic
starts to flow down back to the sourcing interface by the shared tree.
Now since there were no preexisting (S,G) entries, it can be assumed
that all the interfaces on that router were being fed over the shared
tree.

Now the options are :

1. We can treat this router as one who has become a part of the SPT. So
its going to copy the oif-list from the (*,G)/(*,*,RP) excluding the
sourcing iif. And its going to send a (S,G)RPT prune towards the RP
stopping it from sending any source specific traffic towards it.

OR
2. We can leave the things as it is (all interfaces being part of the
shared tree) and just stop the traffic within the router from going back
to the sourcing iif by creating a (S,G) entry with null oif-list. Later
on if it gets a (S,G) join from some other interface, it can add that
interface to the (S,G) oif-list.

In option 1, we have to consider that this router is never going to hear
any periodic (S,G) join/prune from any body, because everybody is/was
happy with the (*,G) state, so somehow (S,G) states has to be
maintained.

In option 2, the traffic comes back via shared tree, so things are not
optimal, but SPT and RPT are cleanly separated.

RFC 2362, 3.3.1, depicts option 1, I dont know how/why we are rethinking
it.

Please point out if I am missing something, its end of the day for me so
couldn't give it full cpu :).

-Parantap

----- Original Message -----
From: Billy Ng <[email-masked]>
To: <[email-masked]>; <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Wednesday, December 01, 1999 4:58 PM
Subject: Re: WG Last Call?

> From [email-masked] Wed Dec  1 14:58:48 1999
>
> Misunderstood the initial point, cleared it up with Liming. Thanks
> Liming
>
> -Parantap

would you mind sharing what this initial point is?  Looks like some
of us are still not clear.  I understand that the traffic coming back
from the RP if you have a (*,G) should be discarded, but I still do
not understand why the (S,G) created contains no outgoing interfaces
from the (*,G).

thanks,

--Billy

>
> ----- Original Message -----
> From: Parantap Lahiri <[email-masked]>
> To: Ardas Cilingiroglu <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>;
> <[email-masked]>
> Sent: Wednesday, December 01, 1999 1:10 PM
> Subject: Re: WG Last Call?
>
>
> Shouldn't the packet get stopped from getting forwarded in the first
> place because it didn't arrive on the designated incoming interface
i.e
> the RPF interface towards the RP.
>
> If, the RPF interface towards RP and S somehow happens to be same,
that
> interface wont be in the oif list of the (*,G) entry.
>
> Sorry, I may be missing something here.
>
> Thanks
>
> -Parantap
>
> ----- Original Message -----
> From: Ardas Cilingiroglu <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>;
> <[email-masked]>
> Sent: Wednesday, December 01, 1999 10:51 AM
> Subject: Re: WG Last Call?
>
>
>
>
> Liming Wei wrote:
>
> >  o  New text to deal with source's first hop router receiving
packets
> when
> >     there is no (S,G) state.
> >
> >            5 If a packet is received from S on the RPF interface to
S,
> and
> I think there are two problems with the above statement:
>
> - (S,G) state should not be created with a NULL oif-list, but
> its oif-list should be copied from the parent (*,G) oif-list
> (excluding the iif for (S,G) of course).
>
> - Condition "there is existing (*,G) but no (S,G) state"
> should be "there is existing (*,G) or (*,*,RP) but no (S,G) state".
>
> >

----- End Included Message -----

----- Begin Included Message -----

---

From: Liming Wei <[email-masked]>
Date: Tue, 30 Nov 1999 19:19:32 -0800 (PST)

> From: Tom Pusateri <[email-masked]>
> 
> >Yes this should happen. Except we still have an "applicability statement"
> >document to be produced. Dave Meyer and Tom P both volunteered before,
> >but I don't know what the status is at the moment. Tom and Dave, can you
> >folks comment ?
> >
> >-Liming
> 
> I figure we'll need a seperate AS for dense mode and sparse mode.
> However, an AS is NOT needed for proposed standard so this should
> not hold us up. The AS is a requirement for draft standard.
> 

 Thanks,
-Liming

----- End Included Message -----