Subject: RE: BSR convergency time

From: Mathur Sonum-CSM109 <[email-masked]>
Date: Sun, 25 Feb 2001 16:50:26 -0600

Isn't it a good idea to have rule (4) for the cases when the new C-RP being added is for a group prefix which is not being served by any other C-RP. In this case, the information  about this new C-RP should be communicated immediately by the BSR. If not, some of the  joins for that group prefix may be dropped till the periodic Bootstrap message arrives, which may be in the order of 60 seconds. 

--
Sonum

> >1. A Cand-RP router is booted-up (or rebooted).
> >2. The DR will send immediately to this Cand-RP router the Bootstrap
> >    message.
> >3. The Cand-RP router will send immediately a Cand-RP message to
> >   the BSR it has just learned about.
> >4. The BSR will add the new Cand-RP to the Bootstrap set, and
> >   if the Group->RP mapping has changed, it will immediately
> >   send-out a Bootstrap message with the new Cand-RP included.

>I agree that there are less compelling reasons for adding rule (4).
>The BSR itself may be in a position to know better when to send-out
>the Bootstrap message (e.g. if the RP-set was empty), hence rule (4)
>should be something like:

>"If the BSR receives a new Cand-RP message that adds a new Cand-RP
>to the RP-Set, it MAY send-out the Bootstrap message before the BS
>Timer expires".

>However, because of the existing danger of trashing the RP-set, then
>I'm fine if we don't have even the above rule.

---

From: Mark Handley <[email-masked]>
Date: Mon, 26 Feb 2001 23:07:36 -0800

>
>Isn't it a good idea to have rule (4) for the cases when the new C-RP being ad
>ded is for a group prefix which is not being served by any other C-RP. In this
> case, the information  about this new C-RP should be communicated immediately
> by the BSR. If not, some of the  joins for that group prefix may be dropped t
>ill the periodic Bootstrap message arrives, which may be in the order of 60 se
>conds. 
>
>--
>Sonum
>