Subject: RE: compiling pimd 2.1.0-alpha28

From: "Terrelle Shaw" <[email-masked]>
Date: Wed, 21 Feb 2001 09:33:49 -0800

Great!
	Can someone send me a network diagram ( visio or ascii). of how their using
pimd in a mixed environment along with Cisco equipment?
I want to do this ( for testing purposes):
	I have a Cisco 3640 (with multicasting on) connected to a T1. I have an OPENBSD
firewall behind that forwarding 1723 and GRE to an internal VPN server ( Linux
poptop). I Want to use pimd on this Linux VPN server so when we do internal
multicast tests, a user at home ( DSL or cable) connected to the VPN server can
take part in the testing.
	Am I WAY OFF in thinking this is a possibility?

Thanks for your comments..

Terrelle

-----Original Message-----
From: PROUST Christophe FTRD/DMI/CAE
[mailto:[email-masked]]
Sent: Wednesday, February 21, 2001 9:23 AM
To: 'Pavlin Ivanov Radoslavov'; [email-masked]
Cc: [email-masked]; JACQUENET Christian FTRD/DMI/CAE
Subject: RE: compiling pimd 2.1.0-alpha28

	Hello,

	Just to give you some ferdback about my configuration under linux.
	I just have set up pimd on a Linux Red Hat 7.0 and it seems
	to work correctly, that is, it interoperates with Cisco routers.
	I compiled pimd using release 2.1.0-alpha28 of the tar file.
	Futhermore, I updated some RPM packages of the Red Hat 7.0 linux
	distribution as far as it is recommended from their web site.

	Christophe

> -----Message d'origine-----
> De : Pavlin Ivanov Radoslavov [mailto:[email-masked]]
> Envoye : mercredi 21 fevrier 2001 16:27
> A : [email-masked]
> Cc : [email-masked]
> Objet : Re: compiling pimd 2.1.0-alpha28
>
>
> > Hello all,
> > 	Wondering if anyone got pimd compiled and working on
> Linux. I'm using slackware
> > 7.1 and finding a few 'snafus'. One is a conflicting types
> for 'sys_errlist'.
> >
> > Anyone seen this?
>
> I think that you just need to uncomment the Linux CFLAGS line in the
> Makefile. At least, sys_errlist is one of the reasons the compilation
> fails for me on RedHat-7.0 with kernel 2.2.16-22 if I don't
> uncomment the right CFLAGS.
> Sigh, Autoconf/Automake should be used to take care of this...
>
> Pavlin
>
> P.S. You may want to try the more recent
> pimd/tmp/pimd-2.1.0-alpha29.4.NEWKERNEL.tar.gz
> which fixes a number of bugs instead of alpha28 (don't be distracted
> by the NEWKERNEL label because it doesn't apply to Linux :)
>

---

From: PROUST Christophe FTRD/DMI/CAE <[email-masked]>
Date: Wed, 21 Feb 2001 18:23:11 +0100

Hello,

	Christophe