Subject: compiling pimd 2.1.0-alpha28

From: "Terrelle Shaw" <[email-masked]>
Date: Tue, 20 Feb 2001 09:20:57 -0800

Hello all,
	Wondering if anyone got pimd compiled and working on Linux. I'm using slackware
7.1 and finding a few 'snafus'. One is a conflicting types for 'sys_errlist'.

Anyone seen this?

Terrelle Shaw
Digital Fountain
[email-masked]
Direct: 415.401.2135
Fax: 415.401.2199
2way: [email-masked]

---

From: Pavlin Ivanov Radoslavov <[email-masked]>
Date: Wed, 21 Feb 2001 07:26:51 -0800

> 7.1 and finding a few 'snafus'. One is a conflicting types for 'sys_errlist'.

I think that you just need to uncomment the Linux CFLAGS line in the
Makefile. At least, sys_errlist is one of the reasons the compilation
fails for me on RedHat-7.0 with kernel 2.2.16-22 if I don't
uncomment the right CFLAGS.
Sigh, Autoconf/Automake should be used to take care of this...

Pavlin

P.S. You may want to try the more recent
pimd/tmp/pimd-2.1.0-alpha29.4.NEWKERNEL.tar.gz
which fixes a number of bugs instead of alpha28 (don't be distracted
by the NEWKERNEL label because it doesn't apply to Linux :)