Subject: RE: Who implements PIM-SM v2 BSR?

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Tue, 20 Feb 2001 17:20:10 -0600

Does this open up the possibility of the existing BSR functionality not being supported at all in future? 

Thanks,
Vidya

> -----Original Message-----
> From: Mark Handley [mailto:[email-masked]]
> Sent: Tuesday, February 20, 2001 2:55 PM
> To: Tom Pusateri
> Cc: [email-masked]
> Subject: Re: Who implements PIM-SM v2 BSR? 
> 
> 
> 
> >Juniper implements BSR. I only know of one customer using it
> >(although there may be more I don't know of) compared with
> >most using static or auto-rp. I wouldn't let this stand in your way
> >from our perspective.
> >
> >I think it is ok to forge ahead without maintaining backward
> >compatibility in the scoped address case. I'd rather keep it
> >simple. ;-)
> 
> That's my feeling too.
> 
> >Can the difference be controlled by a knob?
> 
> The problem is that the old spec only expects there to be one BSR.
> The revised mechanism expects there to be one BSR per admin scope zone
> (although one router may handle multiple scope zones).  An old router
> would ignore the RP-Sets except from whichever BSR has the highest
> priority, so that any joins passing through the router would be
> dropped for all the RP-Sets that were ignored.
> 
> The simplest knob I can think of is one that controls the ability to
> accept admin-scoped BSR messages.  
> 
> - If the knob is off, the router will accept only one BSR for global
>   scope.
> 
> - If the knob is on, the router will accept multiple BSRs (one per
>   scope), and also expect each of its peers to signal this in a Hello
>   option.  If the Hello option is missing, it will report an error and
>   refuse to PIM-peer with the neighbor.
> 
> This enforces the consistency we need and makes misconfigurations very
> obvious.  A single old router in a new cloud, or a single
> (misconfigured) new router in an old cloud, would simply be isolated
> from everyone else, and so wouldn't blackhole Join messages.
> 
> Does this sound reasonable?
> 
> Cheers,
> 	Mark
>

---

From: Mark Handley <[email-masked]>
Date: Tue, 20 Feb 2001 15:57:28 -0800

>supported at all in future? 

The existing BSR functionality is exactly the same as the proposed
extended BSR functionality in the case where there are no admin scope
zones that are relevant.  

So a router that implements BSR according to RFC2362 will be fine, so
long as it's in an environment where the network administrator does
not want to enable an admin scope zone.

If there is an admin scope zone, the RFC2362 behaviour simply breaks
already as the RP may be outside the scope zone. The new BSR
functionality would make this an explicit configuration error, and the
peering between old and new routers would rejected.

 - Mark

---

From: Beau Williamson <[email-masked]>
Date: Wed, 21 Feb 2001 09:23:16 -0800

>peering between old and new routers would rejected.

Sounds good so far.  Are you going to post the new BSR draft spec soon?

Beau