Subject: RE: compiling pimd 2.1.0-alpha28

From: PROUST Christophe FTRD/DMI/CAE <[email-masked]>
Date: Wed, 21 Feb 2001 19:10:59 +0100

Re-,

	The way I am using the multicast enabled Linux router is as
	a firewall.
	A simple diagram of my configuration is as below :

	(public)	PIM		pimd	      	    PIM	 (private)

	outside ----Cisco-------Linux----------------Cisco-----inside
			router	firewall/router      router

	Christophe

> -----Message d'origine-----
> De : Terrelle Shaw [mailto:[email-masked]]
> Envoyé : mercredi 21 février 2001 18:34
> À : PROUST Christophe FTRD/DMI/CAE; 'Pavlin Ivanov Radoslavov'
> Cc : [email-masked]; JACQUENET Christian FTRD/DMI/CAE
> Objet : RE: compiling pimd 2.1.0-alpha28 
> 
> 
> Great!
> 	Can someone send me a network diagram ( visio or 
> ascii). of how their using
> pimd in a mixed environment along with Cisco equipment?
> I want to do this ( for testing purposes):
> 	I have a Cisco 3640 (with multicasting on) connected to 
> a T1. I have an OPENBSD
> firewall behind that forwarding 1723 and GRE to an internal 
> VPN server ( Linux
> poptop). I Want to use pimd on this Linux VPN server so when 
> we do internal
> multicast tests, a user at home ( DSL or cable) connected to 
> the VPN server can
> take part in the testing.
> 	Am I WAY OFF in thinking this is a possibility?
> 
> Thanks for your comments..
> 
> Terrelle
> 
> 
> -----Original Message-----
> From: PROUST Christophe FTRD/DMI/CAE
> [mailto:[email-masked]]
> Sent: Wednesday, February 21, 2001 9:23 AM
> To: 'Pavlin Ivanov Radoslavov'; [email-masked]
> Cc: [email-masked]; JACQUENET Christian FTRD/DMI/CAE
> Subject: RE: compiling pimd 2.1.0-alpha28
> 
> 
> 
> 	Hello,
> 
> 	Just to give you some ferdback about my configuration 
> under linux.
> 	I just have set up pimd on a Linux Red Hat 7.0 and it seems
> 	to work correctly, that is, it interoperates with Cisco routers.
> 	I compiled pimd using release 2.1.0-alpha28 of the tar file.
> 	Futhermore, I updated some RPM packages of the Red Hat 7.0 linux
> 	distribution as far as it is recommended from their web site.
> 
> 	Christophe
> 
> 
> > -----Message d'origine-----
> > De : Pavlin Ivanov Radoslavov [mailto:[email-masked]]
> > Envoye : mercredi 21 fevrier 2001 16:27
> > A : [email-masked]
> > Cc : [email-masked]
> > Objet : Re: compiling pimd 2.1.0-alpha28
> >
> >
> > > Hello all,
> > > 	Wondering if anyone got pimd compiled and working on
> > Linux. I'm using slackware
> > > 7.1 and finding a few 'snafus'. One is a conflicting types
> > for 'sys_errlist'.
> > >
> > > Anyone seen this?
> >
> > I think that you just need to uncomment the Linux CFLAGS line in the
> > Makefile. At least, sys_errlist is one of the reasons the 
> compilation
> > fails for me on RedHat-7.0 with kernel 2.2.16-22 if I don't
> > uncomment the right CFLAGS.
> > Sigh, Autoconf/Automake should be used to take care of this...
> >
> > Pavlin
> >
> > P.S. You may want to try the more recent
> > pimd/tmp/pimd-2.1.0-alpha29.4.NEWKERNEL.tar.gz
> > which fixes a number of bugs instead of alpha28 (don't be distracted
> > by the NEWKERNEL label because it doesn't apply to Linux :)
> >
>

---

From: "Jonathan Day" <[email-masked]>
Date: Thu, 22 Feb 2001 07:40:59 -0800

Hi,

   Just to let list folks know that I've compiled pimd-2.1.0-alpha28 on a Linux 2.4.0-ac4 box (glibc 2.1.3, pgcc 2.95.2), and it compiles cleanly. (There are a few minor warnings, but nothing that is likely to cause problems.) The problems I was having were, I suspect, glitches cropping up from using experimental kernels with experimental compilers during a full moon.

   I don't see why this wouldn't work with other Linux kernels, provided they have multicasting, multicast routing, and PIM-2 enabled.

   If anyone would find it useful, I've rolled an RPM of the binary plus config file and placed it at: ftp://208.53.250.138/pub

   Turning pimd into something that'll use automake, autoconf and libtool is proving interesting. There's lots of documentation, but it's proving tough to translate into a dialect of English I recognise.

   One question is nagging at me, though. Presumably there is common code between pimd, pimdd and even mrouted. Would it make any sense to seperate the protocol-specific parts off into loadable modules, and then have the common code be able to dynamically fetch the module for the type of multicast routing you're interested in?

   (I'm ambivalent on this. On the one hand, it'd simplify snagging code from each other, and allow people to experiment with a variety of multicast routing protocols in a simple way. On the other hand, you'd lose the elegence of specialised solutions to specific problems, and dynamic on-the-fly loading isn't exactly universal.)

Jonathan Day

------------------------------------------------------------
--== Sent via Deja.com ==--
http://www.deja.com/