Subject: BSR convergency time

From: Pavlin Ivanov Radoslavov <[email-masked]>
Date: Thu, 22 Feb 2001 06:36:10 -0800

In another email Tom Pusateri <[email-masked]> wrote:
> Also, there is not wide deployment of BSR because of convergence
> concerns. I was one of the ones who supported removing RP

During the IETF in San Diego I heard a number of times the argument
that we want to keep the MSDP around (as a long-term solution?) even
within a single PIM domain because of slow BSR convergency issues (?).

I'd like to propose a simple (IMHO :) solution/enhancement that can
be applied to the BSR mechanism (backward compatible), so it can
improve significantly the BSR convergency after network
partitioning.

Before describing this solution, could someone enlighten me
what exactly is the problem with the BSR convergency time.
E.g, how slow it is in practice, is it slow because of configuration
issues, or simply because the way it works, or both.
Also, how exactly MSDP helps here in the picture.

Thanks,
Pavlin

---

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Mon, 26 Feb 2001 11:19:07 -0600

Yes, the following is the sequence I was suggesting. 

> 
> I am not sure I completely understand the above paragraph. Are you
> suggesting something like the following sequence of events should
> happen:
> 
> 1. A Cand-RP router is booted-up (or rebooted).
> 2. The DR will send immediately to this Cand-RP router the Bootstrap
>     message.
> 3. The Cand-RP router will send immediately a Cand-RP message to
>    the BSR it has just learned about.
> 4. The BSR will add the new Cand-RP to the Bootstrap set, and
>    if the Group->RP mapping has changed, it will immediately
>    send-out a Bootstrap message with the new Cand-RP included.
> 
> Rule (2) is already in the spec, rule (4) was mentioned above, so
> rule (3) is needed as well to complete the picture.
> 
> Regards,
> Pavlin
>