Subject: debug results of my test.

From: "Terrelle Shaw" <[email-masked]>
Date: Wed, 21 Feb 2001 15:09:58 -0800

Hello all,
	Just wanted to forward my debug info. Thanks to all who responded regarding my
issue of compilation of the daemon. I got pimd-2.1.0alpha29.4 and it compiled
fine.
This is my setup:
	Slackware 7.1 (2.2.18)
	POPTOP VPN daemon
	Kernel is configured as:
		router
		ip multicasting turned on
		ip tunneling
		ip gre over ip
		ip broadcast gre over ip
		ip multicast routing
		ip pim-sm ver1 support
		ip pim-sm v2 support
Added:
	pimd-2.1.0alpha29.4

This is what I get in debug mode.
bash-2.04# pimd -d all
debug level 0xffffffff
(dvmrp_detail,dvmrp_prunes,dvmrp_mrt,dvmrp_neighbors,dvmrp_timers,igmp_proto,igm
p_timers,igmp_members,trace,timeout,pkt,interfaces,kernel,cache,rsrr,pim_detail,
pim_hello,pim_register,pim_join_prune,pim_bootstrap,pim_asserts,pim_cand_rp,pim_
routes,pim_timers,pim_rpf)
15:52:38.113 pimd version 2.1.0-alpha29.4 starting
15:52:38.137 Got 262144 byte buffer size in 0 iterations
15:52:38.138 Got 262144 byte buffer size in 0 iterations
15:52:38.138 netlink socket: Address family not supported by protocol

The config is the default with the phyint line commented out, and both of the
default_source*
lines uncommented.

Thanks..

Terrelle Shaw

---

From: "Terrelle Shaw" <[email-masked]>
Date: Wed, 21 Feb 2001 19:09:33 -0800

Here is the debug info after doing some tests.
This is information taken when I have a pptpd running and I have 1 client
connected to the pptp tunnel on the box (it uses interface ppp0). I have noticed
that when I disconnect the client from the pptp VPN tunnel, I can again run
pimd. As long as I have pimd running before I have a client connected I'm fine.
Not sure if its forwarding multicast packets though. Here is the debug info...

bash-2.04# pimd -d
debug level 0xffffffff
(dvmrp_detail,dvmrp_prunes,dvmrp_mrt,dvmrp_neighbors,dvmrp_timers,igmp_proto,igm
p_timers,igmp_members,trace,timeout,pkt,interfaces,kernel,cache,rsrr,pim_detail,
pim_hello,pim_register,pim_join_prune,pim_bootstrap,pim_asserts,pim_cand_rp,pim_
routes,pim_timers,pim_rpf)
20:01:59.322 pimd version 2.1.0-alpha29.4 starting
20:01:59.324 Got 262144 byte buffer size in 0 iterations
20:01:59.325 Got 262144 byte buffer size in 0 iterations
20:01:59.325 Getting vifs from kernel
20:01:59.325 installing eth0 (192.168.0.98 on subnet 192.168) as vif #0-3 -
rate=0
20:01:59.325 installing ppp0 (192.168.0.98 on subnet 192.168.0.98/32) as vif
#1-15 - rate=0
20:01:59.326 Getting vifs from /etc/pimd.conf
20:01:59.326 default_source_preference is 101
20:01:59.326 default_source_metric is 1024
20:01:59.326 Local Cand-RP address is 192.168.0.98
20:01:59.326 Local Cand-RP priority is 20
20:01:59.326 Local Cand-RP advertisement period is 30 sec.
20:01:59.326 Local Cand-BSR address is 192.168.0.98
20:01:59.327 Local Cand-BSR priority is 5
20:01:59.327 Adding prefix 224.0.0.0/4
20:01:59.327 data_rate_limit is 50000 (bits/s)
20:01:59.327 data_rate_interval is 20 (seconds)
20:01:59.327 reg_rate_limit is 50000 (bits/s)
20:01:59.327 reg_rate_interval is 20 (seconds)
20:01:59.328 eth0 comes up; vif #0 now in service
20:01:59.328 SENT IGMP Membership Query     from 192.168.0.98    to 224.0.0.1
20:01:59.328 SENT PIM v2 Hello              from 192.168.0.98    to 224.0.0.13
20:01:59.328 setsockopt MRT_ADD_VIF on vif 1: Address already in use

Hope this helps someone..

Terrelle