Subject: PIM WG Mineapolis

From: Liming Wei <[email-masked]>
Date: Thu, 15 Feb 2001 14:17:15 -0800 (PST)

We have a 2 hour slot in Mineapolis. Please forward agenda items to me
or Tom.

 Thanks,
-Liming & Tom

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 26 Feb 2001 11:22:06 -0800

>We have a 2 hour slot in Mineapolis. Please forward agenda items to me

I haven't seen any agenda items.

Here is what I supposed is on the list:

1. sparse mode spec update
2. bsr convengency issues - anyone want to lead this discussion
3. draft-ietf-pim-bsr-00.txt
4. charter
5. RP redundancy (v4 - MSDP, v6 - ?) pusateri

Thanks,
Tom

---

From: Liming Wei <[email-masked]>
Date: Mon, 26 Feb 2001 13:18:28 -0800 (PST)

> From: Tom Pusateri <[email-masked]>
> 

Neither have I. Your list sounds good to me. It will be good if the
folks working on the various drafts can give at least a status report
(presentations of the issues being worked on will be better and needed).

 Thanks,
-Liming

--------

---

From: Isidor Kouvelas <[email-masked]>
Date: Mon, 26 Feb 2001 15:12:46 -0800

>1. sparse mode spec update

Right. There should be a new version of the SM spec out within the
week and we plan to make a presentation on the mods.

Also I plan to make some very minor mods to the Bidir spec which can
be covered in a 3 min update.

thanks
I

---

From: Mark Handley <[email-masked]>
Date: Mon, 26 Feb 2001 15:45:12 -0800

>3. draft-ietf-pim-bsr-00.txt

Yes, I can present both of these.  I guess ~40 minutes for
the two of them.  Probably best to do (3) before (2).

Cheers,
	Mark

---

From: Hitoshi Asaeda <[email-masked]>
Date: Tue, 27 Feb 2001 11:02:04 +0900

> week and we plan to make a presentation on the mods.

I have comments for pim-sm spec.

New I-D, actually even RFC2362, says;
	 C-RPs should normally send C-RP-Adv messages with the
	 `Priority' field set to `0'.
and
	The BSR may override the prefix indicated in a C-RP-Adv unless
	the `Priority' field from the C-RP-Adv is not zero.

Why should C-RPs send C-RP-Advs with the highest priority value?
If operator wants to indicate one PIM router which should be selected
as an RP in the domain, how to make it to meet his needs?
(He maybe cannot guess the hash function value. He only can control
its priority value.)
Especially, when he uses anycast RP and ayncast RP itself would
advertise its address within the C-RP-Advs (i.e., whithout setting the
address statically), it should be selected by each non-RP router, if
it works fine.

(In fact, pimd doesn't set priority to '0' as its default.)

Also, why priority field may be override by BSR if the priority is the
highest value? BSR can be changed operator's policy? Some intelligent
method may be needed to aggregate RP set, so, on the contrary,
	The BSR may override the prefix indicated in a C-RP-Adv unless
	the `Priority' field from the C-RP-Adv *is* zero.
is better to understand.

Regards.
--
Hitoshi Asaeda

---

From: Mark Handley <[email-masked]>
Date: Mon, 26 Feb 2001 20:16:37 -0800

>	the `Priority' field from the C-RP-Adv is not zero.

I agree that both of these are bad choices.  If you check the new BSR
spec we submitted last week, all these defaults changed - given that
we were introducing other incompatibilities I took the liberty of
making more sensible defaults.  But the new spec is only a draft - it
hasn't yet undergone any widespread review - if you have feedback on
the new suggestions, we'd love to hear it.

Cheers,
	Mark