Subject: Sir/Madam, Please Read this Comment

From: "O.L.N.Rao" <[email-masked]>
Date: Thu, 30 Aug 2001 22:34:11 -0700 (PDT)

Respected Sir/Madam,

   Ref: PIM-SM draft
   Sub:	Comment and request for doubt clarification.
   
         ----
  
   I am a project leader in Samsung India Software 
   Operations.  I am undertaking a project which 
   implements PIM-SM draft 2. Ofcourse, draft 3
   released which expires on Jan,2002.  

   In PIM-SM draft. I noted down the following
  
   1) When a data packet arrives on SPT, 
       set SPT bit to 1.
   2) In ASSERT state machine also PIM behaviour
       changes with data packet arrival.
   
   So, i concluded that every data packet arrival 
   should be informed to PIM by underlying layers.

   If it is so, so much of performance overhead comes.

   I want to know whether data packet arrival should 
   be notified to PIM or not.  If it is to be 
   notified, how peformance degrades gracefully but 
   not badly.

   Awaiting for your positive reply.

Thanking You Sir/Madam,
	
				Yours faithfully,
				   O.L.N.Rao

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger
http://im.yahoo.com

---

From: John Zwiebel <[email-masked]>
Date: Fri, 31 Aug 2001 08:58:38 -0700

FWIW: its packets that arrive on other than the incoming interface
	that PIM has to know about.  

	In the case of an (S,G) entry that hasn't set the SPT bit yet, 
	the "current" IIF is the (*,G). In other words, when the packet 
	arrives on the (S,G) IIF, it isn't the (*,G) IIF which is the one
	being used to forward packets.

	How you perform this feat is up to you.  :-)
	Good Luck

	Not trying to sound facetious, you might want to look at 
	your project needs and think about whether or not Source
	Specific Multicast and Bi-dir PIM might "better" meet your
	needs.  SSM especially eases the "pain" you are feeling.

	IMHO, PIM-SM will "disappear" when folks finally figure out
	how much easier SSM is to implement, manage, and deploy.  And
	how much more reliable it will be.  But this is a marketing
	decision.  I shouldn't be giving away "secrets" like this. :^)

"O.L.N.Rao" wrote:
> _______________________________________________
> Pim-external mailing list
> [email-masked]
> http://mailist.procket.com/mailman/listinfo/pim-external