Subject: multicast data packet forwarding

From: Chris Hall <[email-masked]>
Date: Mon, 20 Aug 2001 10:03:17 -0700

Hi all-

	In the multicast data forwarding section, RFC 2362 states:
"

           5 If the packet does not match to any entry, and it is not a
             local host or the router is not the DR, drop the packet.
"
	In the subsequent drafts, that statement was dropped.  Instead,
draft-ietf-pim-v2-sm-01.txt states:
"
           5 If a packet is received from S on the RPF interface to S, and
             there is existing (*,G) but no (S,G) state, the implementation
             MUST guarantee that packets from this source are not forwarded
             via the RP Tree onto the source subnet. In the absence of
             other efficient mechanisms to enforce this, an implementation
	     in this situation MAY create (S,G) state with an outgoing
             interface list of null, and discard the packet.
"
draft-ietf-pim-sm-v2-new-02.txt seems a not to address my situation (I can't
see where it addresses non-DR interfaces).

	I have a case in which the router is not a DR but receives a valid
packet.  

	|-----------|     |-----------|           |-----------|
	|  B        |-----|  A        |Non-DR     |Host       |
	|           |     |           |---------- |           |
	|-----------|     |-----------|   Directly|-----------|
                                         connected

In the case above, if A receives a NEW data packet from Host, and has *,g
join state with B, should A forward the packet?  My interpretation of the
RFC and the subsequent drafts is that the A should just drop the packet.  

thanks

Chris

---

From: John Zwiebel <[email-masked]>
Date: Mon, 20 Aug 2001 13:05:31 -0700

Chris:

Where is the RP in your diagram?  The point the old specs
were trying to make were that you don't want the router to
take in a packet and then forward it back out the interface 
it came in on.

If A has (*,G) with the interface pointing to B in the olist
then, yes it should forward it.  The question is, is A a
DR on the interface to router B?  Some implementations would
not create (*,G) state on router A if that interface was not
a DR.  If B was the DR on that subnet, then it would be responsible
for setting up the shared-tree which may or may not go through
A.

Chris Hall wrote:
> _______________________________________________
> Pim-external mailing list
> [email-masked]
> http://mailist.procket.com/mailman/listinfo/pim-external