Subject: Urgent

From: tapabrata <[email-masked]>
Date: Mon, 06 Aug 2001 17:07:06 +0400

hi all,
I desparately need some help. I am working with pim-sm 2.1.0-alpha28 in
my machine.
 I have downloaded it from the ftp site
  ftp ://catarina.usc.edu/pub/pim/pimd  and followed the procedures
given README
 to compile it I am working in linux.  I have compilled the linux kernel
enabling Multicasting
  routing option . I have also enabled PIM-SM-V2 option.
   I am working in Linux
   Now I have simulated the following topology

                        ________
                        |                 |
                        |    ANVL|
                         ------
                               |  DIface-1
                               |
                        ------
                        |                  |
                        |     DUT   |
                        |                  |
                         ----
                                 |
                                 |   DIface-2
                          _________
                          |                     |
                          |    ANVL    |
                          |_________|

I  have simulated  ANVL in the two interfaces . From DIface-2 we are
sending IGMP-V2
 report message for a particular group. DUT is sending  (*,G) join
message on
DIface-1 almost immediately.  But then we are sending a multicast data
packet
from DIface-1 .It is not  forwarded on DIface-2.  In the log of pimd  I
found olist  is calculated
correctly But data packet is not forwarded .
          Will i send pimd.conf ?
           Is the data packet forwarding not implemented in this alpha
product?

---

From: Pavlin Ivanov Radoslavov <[email-masked]>
Date: Mon, 06 Aug 2001 06:18:04 -0700

>    Now I have simulated the following topology

Packet forwarding is done by the kernel, not the daemon (with the
exception of the encapsulated PIM Registers).
You may want to get the latest alpha29.* from the 'tmp' directory
and read the mini-FAQ in README there re. some of the LINUX kernel
options you need to enable in your kernel for Linux (add to those
options CONFIG_IP_MROUTE as well). Also, make sure that the right
MFC entry is in the kernel (/proc/net/ip_mr_cache). And finally,
make sure that the TTL of the mcast packets are more than 1 :)

Pavlin