Subject: Re: sending null register msgs in register State machine

From: "Sundeep Singatwaria" <[email-masked]>
Date: Sun, 5 Aug 2001 10:05:31 -0700

-----Original Message-----
From: [email-masked] <[email-masked]>
To: Singatwaria, Sundeep [SC7:370-M:EXCH] <[email-masked]>; pim
<[email-masked]>
Date: Wednesday, August 01, 2001 9:38 PM
Subject: RE: sending null register msgs in register State machine

>Hi Sundeep,
>           The NULL register message is sent only after timeout for
>REGISTER_SUPPRESSION_TIME
>and then the RST is restarted for PROBE_INTERVAL. The register NULL message
>should be sent before
>(REGISTER_SUPPRESSION_TIME +  PROBE_INTERVAL)
>     regards
>              Ramamurthy

ram - it is sent before RST expires else we will have data encapsulation
when it is not desired. check out the timer values section of the draft -
Register Stop Timer.

sundeep

>
>
>
>
>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of Sundeep
>Singatwaria
>Sent: Thursday, August 02, 2001 2:42 AM
>To: pim
>Subject: sending null register msgs in register State machine
>
>
>The null register msg is sent before the RST expires.
>However interpreting from the state m/c and the tabular form - the null
>register is sent at the expiry of the RST timer - which doesn't sound
right.
>Could we add one more state 'NULL register state' to describe it.
>
>Pls. let me know if I missed something.
>
>Sundeep
>
>
>

---

From: "K.P.Ramamurthy" <[email-masked]>
Date: Mon, 6 Aug 2001 09:24:22 +0530

Hi Sandeep,
          Once register stop message (RSM) is received from RP for a
perticular (S,G),
the register encapsulation at the DR is SUPPRESSED for a period
REGISTER_SUPPRESSION_TIME (60s)
( or REGISTER_SUPPRESSION_TIME - PROBE_TIME ).This is period during which DR
stops sending Register-encapsulated data to the RP after receiving a RSM ).
     after "REGISTER_SUPPRESSION_TIME" the RST expires, that's when the DR
sends a NULL register
message to the RP, just to confirm if register encapsulation is to be
restarted. If the RP
responds with a RSM again, within PROBE_TIME (i.e 5 sec), the timer is
restarted for
REGISTER_SUPPRESSION_TIME.
     Data encapsulation will happen only when the RP does not respond with a
register stop message
withing PROBE_TIME, and so there is never a situation when encapsulation is
restored undesired.
Register null message is just a probing mechanism, to start encapsulation of
data.
    bye
              Ram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Sundeep Singatwaria
Sent: Sunday, August 05, 2001 10:36 PM
To: ramamurthy.pani; pim
Subject: Re: sending null register msgs in register State machine

-----Original Message-----
From: [email-masked] <[email-masked]>
To: Singatwaria, Sundeep [SC7:370-M:EXCH] <[email-masked]>; pim
<[email-masked]>

sundeep

right.