Subject: RE: [pim] Cisco Assert behavior

From: "Ramalingam, Swaminathan" <[email-masked]>
Date: Thu, 7 Mar 2002 23:30:10 -0500

Though it is not the right forum to discuss Cisco specific implementations,
I should say that CISCO IOS doesn't support new draft for PIM-SM. (Do I
remember correctly ?)
It supports only RFC 2362.I guess, even it is true for IOS 12.2

Thanks,
Swami

-----Original Message-----
From: Matt Almgren [mailto:[email-masked]]
Sent: Friday, March 08, 2002 2:00 AM
To: [email-masked]'
Subject: [pim] Cisco Assert behavior

After running several tests with Cisco and other routers, and by following
the draft v3, I have noticed a few things that Cisco is not doing correctly.
I am curious if this is the correct behavior, or if Cisco is just not
following the draft, or if a newer release of IOS will correct these issues:

1. Cisco does not send an assert cancel message when he receives a Prune
(S,G) or (*,G) for the group to which he is Assert Winner for.

2. When Cisco is assert winner, he does not sent an Assert message every 177
seconds.  

According to the draft, the first one I believe must be done.  However, the
second one is optional...the word "should" is used to explain the expire
timer.  

I am currently testing this with:
IOS (tm) C2600 Software (C2600-IS-M), Version 12.1(6), RELEASE SOFTWARE
(fc1)

Any feedback on Cisco behavior would be appreciated.

Thanks - Matt

                  \\\|///
                 \\ - - //
                  ( @ @ )
  /------------oOOo-(_)-oOOo------------\
  |            Matt Almgren             |
  |            PLURIS, INC.             |
  |            [email-masked]      |
  |            (408) 861-4216           |
  \------------------------Oooo---------/
           oooO            (   )
          (   )             ) /
           \ (             (_/
            \_)

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Yiqun Cai <[email-masked]>
Date: Fri, 15 Mar 2002 18:29:28 -0800 (PST)

Folks,

It is really important to continue discussing interoperability and
backward compatibility issues on this mailing list, particularly
related to the fine points of the difference between RFC2362 and the
latest drafts.  But I would suggest that we move Cisco IOS specific
discussion to [email-masked].

Thanks.

-- 
Yiqun