Subject: [pim] Switching from SPT to shared tree

From: Sumanth Kanchireddy <[email-masked]>
Date: Wed, 30 Oct 2002 11:20:44 -0500

I am new to Pim-Sm and have been reading RFC2362. Is it possible to switch
from SPT to shared tree when the data rate falls below some level at the
last hop router. Does the RFC2362 have any provisions for it. How about in
the new draft. I didnot see any issue for this item in
http://www.icir.org/fenner/mcast/pim/sm/issues.html

Sincerely,
Sumanth

Sumanth Kanchireddy
Software Engineer
LVL7 Systems,
13000 Weston Parkway, Suite 105,
Cary, NC 27513
Ph : (919) 865-2911
Fax: (919) 865-2703
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 30 Oct 2002 12:17:58 -0500

This is up to the implementation, and I believe is technically allowed. Cisco allows
you to do the reverse (shift over to the SPT when traffic gets above a certain level).

HOWEVER, standard practice is to _always_ shift to the SPT immediately and stay there.
(There may be some cases where _never_ shifting would make sense, but I do not know of
any major use of this.)

Changing tree's dynamically back and forth is probably not a good idea.
Besides the additional work on the routers,
I would worry about thrashing.

Regards
Marshall Eubanks

> 13000 Weston Parkway, Suite 105,

T.M. Eubanks
Multicast Technologies, Inc
10301 Democracy Lane, Suite 410
Fairfax, Virginia 22030
Phone : 703-293-9624       Fax     : 703-293-9609
e-mail : [email-masked]
http://www.multicasttech.com

Test your network for multicast :
http://www.multicasttech.com/mt/
  Status of Multicast on the Web  :
  http://www.multicasttech.com/status/index.html

---

From: John Zwiebel <[email-masked]>
Date: Wed, 30 Oct 2002 09:23:52 -0800

> http://www.icir.org/fenner/mcast/pim/sm/issues.html

It is possible.  It has not been implemented well and to work well 
would require
some way of providing some kind of hysteresis for bursty sources, which 
then
requires lots of code to make it work.  It can lead to a lot of 
churning in the network
as the last hop tries to figure out which source being forwarded on the 
(*,G) is
the one using up all the BW.

Experience has shown it to not be very useful.

I'd recommend you work on SSM and IGMPv3 rather than worry about this
feature.