Subject: Re: [pim] doubt regarding BS Timeout in the BSR draft.

From: "Prashant Jhingran" <[email-masked]>
Date: 4 Oct 2002 13:26:27 -0000

Hi All,
Its like rehabilitation work after a powerful hurricane...:))...
Actually speaking its a very good point, it would be nice if the 
authors can increase the BSTimeout for a non-candidate BSR 
router.

regards,
Prashant
On Thu, 03 Oct 2002 [email-masked] wrote :
>  Hi,
>In the BSR draft draft-ietf-pim-sm-bsr-02.XXX. The BS timer 
>description is like this
>(1) The BS Timer in an elected BSR is started for BS Period (60 
>secs).
>(2) In a router not configured as BSR it is BS Time out (130 
>secs).
>(3) In a router configured as BSR also it is BS Time out (130 
>secs).
>
>If the BS timer in (2) and (3) expire at the same time, what 
>should be done to the RP Set list in case (2). Should it be 
>deleted? If the RP set list is deleted what should happen to the 
>entry states.
>
>In another rand_override another BSR (if present in the n/w) 
>might become elected and the RP set list might be 
>reestablished.
>
>Keeping the above point in mind if the RP set list is not deleted 
>what should happen if no other BSR is configured?
>
>So i think it is appropriate if the BSTimer in case (2) be 
>started for maximum possible rand_override (5secs) + BSTimeout. 
>In case (3)  the value can be reatained.
>
>Please correct me IF iam wrong.
>thanks
>rajesh.
>
>
>
>
>
>------------------------------------------------
>Changed your e-mail?  Keep your contacts!  Use this free e-mail 
>change of address service from Return Path.  Register now!

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 12 Oct 2002 01:32:01 -0400 (EDT)

Hi,
Thanx pavlin.
I think the draft needs to be updated to be explictly clear about
some important points :)
Iam really curious about seeing the updated draft.
regards
rajesh.

 --- On Fri 10/11, Pavlin Radoslavov  wrote:
From: Pavlin Radoslavov [mailto: [email-masked]]
To: [email-masked]
     Cc: [email-masked]
Date: Fri, 11 Oct 2002 15:11:38 -0700
Subject: Re: [pim] doubt regarding BS Timeout in the BSR draft. 

> > >> (1) The BS Timer in an elected BSR is started for BS Period
> (60 secs).
> > >> (3) In a router configured as BSR also it is BS Time out
> (130 secs).
> > >> 
> should be done 
> > >to the RP Set list in case (2). Should it be deleted? If the RP
> set list is de
> > >leted what should happen to the entry states.
> > >
> > >If the BS timer expires, and the state about the current BSR is
> > >deleted, the RP-set should not be deleted. In all routers, the
> state
> > >about each Cand-RP is expired based on that Cand-RP's Holdtime.
> > >
> > >Indeed, the spec does not say that explicitly, but it is
> > >implied. Otherwise, if the RP-set is expired when the BSR
> timeout,
> > >all multicast traffic via the RPs will stop until a new BSR is
> > >elected.
> > >
> > >Nevertheless, to avoid such confusions, I think the spec
> > >should be explicit about that >> spec_authors
> > 
> > I think there is a third option you do not mention. Only expire CRPs
> > when not contained in the relevant BSR message fragment.
> 
> Yes, CRPs can be deleted when they are not included in retransmitted
> BSR message fragments. Though, there are a number of details you
> may need to be careful about (e.g., the very first Bootstrap message
> from a newly elected BSR is probably empty, so it should not
> flush-out all CRPs from the previous BSR).
> FYI, I just talked with one of the authors, and the bottom line was
> that the spec needs to be updated to clarify those details. Stay
> tuned :)
> 
> Regards,
> Pavlin
> 
> > With this a non-CBSR will continue to use the last provided RP set
> > until a new one is provided.

------------------------------------------------
Join Excite! - http://www.excite.com
The most personalized portal on the Web!