Subject: [pim] Hash function for RP selection

From: "" <[email-masked]>
Date: Fri, 2 Apr 2004 08:52:03 -0500 (EST)

Hi all,

I would like to have a clarfication regarding RP selection.

For example if I have the following RP SET list:

239.1.1.0/24
10.10.1.3 (PRIORITY = 5)
10.10.1.2 (PRIORITY = 4)
10.10.1.1 (PRIORITY = 3)

239.1.0.0/16
10.10.1.2 (PRIORITY = 10)
10.10.1.3 (PRIORITY = 10)

For the group 239.1.1.1 the longest match would be 239.1.1.0
and for group 239.1.2.1 it would match 239.1.0.0.

According to rfc 2362:

   From the RPs with the highest priority (i.e.  lowest
  `Priority' value), the candidate with the highest resulting
   value is then chosen as the RP for that group, and its identity
   and hash value are stored with the entry created.

   Now for 239.1.1.1 10.10.1.1 should be selected as RP simply because
   it has the lowest priority, so the rfc statement doesn`t make sense
   to me. We have found an RP with the lowest priority so why is the 
   second step required.I thought hash value is required only if   
   priorities are same (to resolve the tie).

   To summarize:

   From the C-RP set list of the corresponding group prefix
   choose the C-RP with lowest Priority.
   
   If priority is same compute hash value and the RP is chosen based 
   on the highest hash value.

   If both priority and hash values are equal, the C-RP with highest
   IP address becomes the RP.

   Please let me know if I am missing something.

Thanks,
Arut

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Pavlin Radoslavov <[email-masked]>
Date: Fri, 02 Apr 2004 12:01:09 -0800

> For example if I have the following RP SET list:

Please read Section 4.8.1. "Group-to-RP Mapping"
in the lastest I-D draft-ietf-pim-sm-v2-new-09.txt

It explains the process in more details. Also, please pay attention
to the "Implementation note" at the end of that section.

Pavlin

---

From: Stig Venaas <[email-masked]>
Date: Fri, 2 Apr 2004 21:49:32 +0200

> For example if I have the following RP SET list:

The second step is to pick one of the RPs with highest priority, i.e.
if there are several RPs with highest (they all have the same and
highest) priority, you use the hash function and use the one with
highest resulting value. Note that it says "resulting value". It's
the result from the hash function, not the priority value.

Stig

---

From: Pavlin Radoslavov <[email-masked]>
Date: Fri, 02 Apr 2004 12:01:09 -0800

Pavlin

---

From: Stig Venaas <[email-masked]>
Date: Fri, 2 Apr 2004 21:49:32 +0200

Stig