Subject: Re: Re: [pim] some questions/comments to PIM-SM draft-10

From: "edrt"<[email-masked]>
Date: Sat, 18 Sep 2004 20:34:06 +0800

>Regards,
>
>- Mark.
>
>P.S.: Just to sum up our discussion here and to make shure that I 
>haven't misunderstood you, you propose something like the following as 
>the new data forwarding rule:
>
>if ( DirectlyConnected(S) == TRUE )
>         set KeepaliveTimer(S,G) to Keepalive_Period
>}
>Update_SPTbit(S,G,iif)
>oiflist = inherited_olist(S,G,rpt)
>if ( SPTbit(S,G) == TRUE ) {
>         # Note: start KAT only on nodes that have downstream RPT state
>         if ( oiflist != NULL ) {
>                 set KeepaliveTimer(S,G) to KeepalivePeriod
>         }
>         # Note: set oiflist to inherited_olist(S,G)
>         oiflist = oiflist (+) immediate_olist(S,G)
>         if ( iif == RPF_interface(S) ) {
>                 forward packet to oiflist (-) iif
>         } else if ( iif in oiflist ) {
>                 send Assert(S,G) on iif
>         }
>} else {
>         if ( iif == RPF_interface(RP(G) ) {
>                 # Note: Checking KAT is optional
>                 if ( KeepaliveTimer is not running ) {
>                         CheckSwitchToSpt(S,G)
>                 }
>                 forward packet to oiflist (-) iif
>         } else if ( iif in oiflist ) {
>                 send Assert(*,G) on iif
>         }
>}
>
>void
>Update_SPTbit(S,G,iif) {
>         # unchanged
>}
>
>void
>CheckSwitchToSpt(S,G) {
>         if ( pim_include(*,G) (-) pim_exclude(S,G) != NULL
>              AND SwitchToSptDesired(S,G) == TRUE ) {
>                 set KeepaliveTimer(S,G) to KeepalivePeriod
>}
>

Yes Mark, except line 1-3 should remain as
"
 if( DirectlyConnected(S) == TRUE AND iif == RPF_interface(S) ) {        
 	set KeepaliveTimer(S,G) to Keepalive_Period
 } 
"

Regards,
Yi Zhao

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Mark Doll <[email-masked]>
Date: Sat, 18 Sep 2004 14:59:33 +0200

>>        set KeepaliveTimer(S,G) to Keepalive_Period
[...]
>  	set KeepaliveTimer(S,G) to Keepalive_Period

ACK. Sorry for my inattention.

- Mark.