Subject: [pim] ethernet multicast over a router-to-router link

From: Ron Lee <[email-masked]>
Date: Fri, 21 Jan 2005 01:50:01 +0000 (GMT)

Hello,

I am wondering if ethernet multicast is used when a router forwards a multicast
IP packet to two or more routers sharing an ethernet segment.

In other words, does a router have to listen to multicast ethernet addresses
(corresponding to dynamic IP multicast group the router has states of) as well
as its unicast ethernet address?

Is it the common case, or is there an exception in the commodity (multicast-enabled)
router market?

The original specification of mapping class D IP address to ethernet multicast
address was in the RFC titled 'Host extention to IP multicast', so it seems
to me that the mapping is only used between hosts and a router(, not between
routers). Am I wrong?

Thanks in advance.

Best regards,

Ron

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Mohamed Riyaz" <[email-masked]>
Date: Fri, 21 Jan 2005 08:48:29 +0530

Samsung Enterprise Portal mySingleRon,

Isn't it the end station (host) that is needed to listen to multicast ethernet address ?. Routers needn't listen to them, I feel.

Regards
-Riyaz
  ----- Original Message ----- 
  From: Ron Lee 
  To: [email-masked] 
  Sent: Friday, January 21, 2005 7:20 AM
  Subject: [pim] ethernet multicast over a router-to-router link

   Hello,

  I am wondering if ethernet multicast is used when a router forwards a multicast IP packet to two or more routers sharing an ethernet segment.

  In other words, does a router have to listen to multicast ethernet addresses (corresponding to dynamic IP multicast group the router has states of) as well as its unicast ethernet address? 

  Is it the common case, or is there an exception in the commodity (multicast-enabled) router market?

  The original specification of mapping class D IP address to ethernet multicast address was in the RFC titled 'Host extention to IP multicast', so it seems to me that the mapping is only used between hosts and a router(, not between routers). Am I wrong?

  Thanks in advance.

  Best regards,

  Ron

------------------------------------------------------------------------------

---

From: Beau Williamson <[email-masked]>
Date: Thu, 20 Jan 2005 23:51:50 -0600

At 1/20/2005 07:50 PM, Ron Lee wrote:
>Content-return: prohibited
>Content-type: text/html; charset=windows-1252
>Content-transfer-encoding: 7BIT
>Content-Transfer-Encoding: 7BIT
>
>  Hello,
>
>
>
>I am wondering if ethernet multicast is used when a router forwards a 
>multicast IP packet to two or more routers sharing an ethernet segment.
>
>
>
>In other words, does a router have to listen to multicast ethernet 
>addresses (corresponding to dynamic IP multicast group the router has 
>states of) as well as its unicast ethernet address?

Yes.  RFC 1112 states that the router must promiscuously receive all 
multicast traffic.  This is primarily to learn of new directly connected 
sources.  However, it is also used to listen to multicast traffic forwarded 
router to router.  (Bottom line: All IPv4 multicast packets are mapped to 
the 0x01005exxxxxx Multicast MAC address.)

>(multicast-enabled) router market?

If a commodity router doesn't follow the "common case" then it is called a 
"broken" router when it comes to multicast.

>
>
>The original specification of mapping class D IP address to ethernet 
>multicast address was in the RFC titled 'Host extention to IP multicast', 
>so it seems to me that the mapping is only used between hosts and a 
>router(, not between routers). Am I wrong?

Yes, sorry but you're wrong.  It's used between routers as well.

Beau Williamson

---

From: Prashant Jhingran <[email-masked]>
Date: Fri, 21 Jan 2005 16:58:03 +0800

Hi Ron,

Yes its very much required!.

The usage of  ethernet multicast  addresses is required "corresponding
to dynamic IP multicast group the router has states of"
because for sending/receiving multicast  packets "mapping class D IP
address to ethernet multicast address" is the only way out.

The mapping of "class D IP address to ethernet multicast address" can be
applied for both the Host and the intermediate Routers.

regards,
Prashant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ron Lee
Sent: Friday, January 21, 2005 9:50 AM
To: [email-masked]
Subject: [pim] ethernet multicast over a router-to-router link

 Hello,

In other words, does a router have to listen to multicast ethernet
addresses (corresponding to dynamic IP multicast group the router has
states of) as well as its unicast ethernet address? 
Is it the common case, or is there an exception in the commodity
(multicast-enabled) router market?

The original specification of mapping class D IP address to ethernet
multicast address was in the RFC titled 'Host extention to IP
multicast', so it seems to me that the mapping is only used between
hosts and a router(, not between routers). Am I wrong?

Thanks in advance.
Best regards,
Ron