Subject: RE: [pim] Question regarding the PIM Register source address

From: "James Lingard" <[email-masked]>
Date: Tue, 25 Jan 2005 11:42:30 -0000

Pavlin,

I don't believe the text you quote is attempting to specify exactly which of the DR's addresses to use as the source addresses for Register messages.  Section 9 (PIM Packet Formats) of the spec says:

"The source address used for unicast messages is a
domain-wide reachable address;"

Therefore, in IPv6 you _can't_ use any primary IP address as the source address of the Register message, since IPv6 primary addresses are link-local.

My interpretation is that for Register messages (and all other unicast PIM messages) any domain-wide reachable IP source address may be used; for IPv4 this may happen to be one of the primary IP addresses, or it may not, for example it may be an address configured on a loopback interface.

Note that some implementations allow the source address of Register messages to be manually configured; for example, Cisco provide the "ip pim register-source" command, described at:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/iprmc_r/ip3_i2g.htm#wp1069761

Regards,
James.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 25 January 2005 02:16
To: [email-masked]
Subject: [pim] Question regarding the PIM Register source address

Section 4.9.3 (Register Message Format) of the lastest PIM-SM spec
(draft-ietf-pim-sm-v2-new-11.{txt,ps}) says:

"A Register message is sent by the DR or a PMBR to the RP when a
multicast packet needs to be transmitted on the RP-tree.  The IP source
address is set to the address of the DR, the destination address to the
RP's address."

My interpretation of the above is that "the address of the DR" is
the primary IP address of the interface toward S.

Such interpretation may create some operational issues in case of
PMBR (e.g., if the PIM Register messages have the IP address of the
"external" interface, and that address does not belong to the
address range of the domain with the RP).

Do other people have different interpretations of what the Register
message source address should be set to?
E.g., do some implementations use, say, the primary IP address of
the interface toward the RP (or just the IP address of any PIM-SM
enabled interface on the router).

Thanks,
Pavlin

-- 
James Lingard
Data Connection Ltd (DCL)
http://www.dataconnection.com/

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Pavlin Radoslavov <[email-masked]>
Date: Tue, 25 Jan 2005 16:50:13 -0800

> Therefore, in IPv6 you _can't_ use any primary IP address as the source address of the Register message, since IPv6 primary addresses are link-local.

Thanks for the reminder, you are right. I should have said
"domain-wide address" instead of "primary address".

> http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/iprmc_r/ip3_i2g.htm#wp1069761

Thanks for the pointer; the text there also describes very clearly
what the source address would be if it is not set explicitly.
Now I know how (at least) one router vendor interpretates the spec's
text :)

Regards,
Pavlin