Subject: [pim] PIM-SM Nit

From: "Nicholas, Jonathan" <[email-masked]>
Date: Tue, 4 Jan 2005 11:14:14 -0500

Hello,

I have been going over the PIM-SM spec in some detail, and I noticed that in section 4.5.4 no action is taken in the Prune-Pending state when a Prune(S,G,rpt) is recieved.

I believe in this case the Expiry Timer should be restarted in behaviour identical to that in the Prune state.

Jonathan Nicholas
Network Systems Engineer
ITT Aerospace/Communications Division

************************************
This e-mail and any files transmitted with it are proprietary and intended solely for the use of the individual or entity to whom they are addressed. If you have received this e-mail in error please notify the sender. Please note that any views or opinions presented in this e-mail are solely those of the author and do not necessarily represent those of ITT Industries, Inc. The recipient should check this e-mail and any attachments for the presence of viruses. ITT Industries accepts no liability for any damage caused by any virus transmitted by this e-mail.
************************************

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Joe Scholefield <[email-masked]>
Date: Tue, 04 Jan 2005 12:47:31 -0500

Jonathan,

When in the Prune Pending state no action should be taken upon reception
of another Prune. Once the first Prune has been received it is
attempting to Prune the group. The router is only concerned about
whether or not the Prune will be overridden. 

-------
Joseph Scholefield
IPv4 Consortium
UNH InterOperability Laboratory
http://www.iol.unh.edu
+1-603-862-3941
-------