Subject: [pim] PIM-DM: Keepalive timer for (S,G) state

From: "Paresh Khatri" <[email-masked]>
Date: Mon, 6 Mar 2006 21:44:39 +1100

Hi,

RFC3973 states that PIM-DM does not maintain a keepalive timer associated with each (S,G) route and also that all state info associated with each (S,G) route is maintained with each route as long as any timer associated with it is active.  I'm curious to understand how this actually works.  When do the other timers become inactive ?  For example, one of the relevant timers I see is the Prune Timer.  Won't this timer be always active ?

Appreciate if someone could clarify this for me.

Paresh

This communication, including any attachments, is confidential. If you are not the intended recipient, you should not read it - please contact me immediately, destroy it, and do not copy or use any part of this communication or disclose anything about it.

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Nicholas, Jonathan - ACD " <[email-masked]>
Date: Mon, 6 Mar 2006 13:15:18 -0500

All timers become inactive when they expire (unless they are restarted).
All state machines are written such that if no timer is running, the
state machine must be in a 'default' state such as No Info.  

Actual implementations may wish to have a keepalive timer to maintain
state for active message flows, but this is an internal implementation
issue.  The external behaviour is indistinguishable.

Jonathan Nicholas 

> -----Original Message-----
> From: Paresh Khatri [mailto:[email-masked]] 
> Sent: Monday, March 06, 2006 5:45 AM
> To: [email-masked]
> Subject: [pim] PIM-DM: Keepalive timer for (S,G) state
> 
> Hi,
> 
> RFC3973 states that PIM-DM does not maintain a keepalive 
> timer associated with each (S,G) route and also that all 
> state info associated with each (S,G) route is maintained 
> with each route as long as any timer associated with it is 
> active.  I'm curious to understand how this actually works.  
> When do the other timers become inactive ?  For example, one 
> of the relevant timers I see is the Prune Timer.  Won't this 
> timer be always active ?
> 
> This communication, including any attachments, is 
> confidential. If you are not the intended recipient, you 
> should not read it - please contact me immediately, destroy 
> it, and do not copy or use any part of this communication or 
> disclose anything about it.
> 
> 
> 
************************************
This e-mail and any files transmitted with it are proprietary and intended solely for the use of the individual or entity to whom they are addressed. If you have received this e-mail in error please notify the sender. Please note that any views or opinions presented in this e-mail are solely those of the author and do not necessarily represent those of ITT Industries, Inc. The recipient should check this e-mail and any attachments for the presence of viruses. ITT Industries accepts no liability for any damage caused by any virus transmitted by this e-mail.
************************************