Subject: [pim] SPTbit clear

From: 황선영 <[email-masked]>
Date: Thu, 23 Mar 2006 09:58:57 +0900

Hello, all

I have a question about SPTbit clear.

If SPT bit is set to TRUE and then upstream interface is changed,
then SPTbit should be cleared ?

I think do that, but I cannot find the behavior in draft-ietf-pim-sm-v2-new-12.

U1, U2, R1, D1 is all PIM routers.

U1                   U2
|                     |
|                     |
+-------- R1 ---------+
          |
          |
          D1

First, SPT for (S,G) is built as U1->R1->D1.
And then R1's unicast route has been changed to U2.
Then R1's (S,G) upstream should be changed.
How about the SPTbit ?

Please let me know which chapter I can refer.

Thanks and regards,
Sunyoung, Hwang
_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: JGSPrasad <[email-masked]>
Date: Thu, 23 Mar 2006 11:46:04 +0530

Dear Hwang,

SPT bit would not be reset with route change unless this would
lead to change in joindesired (S,G).

SPT bit would be cleared only if JoinDesired(S,G) becomes false.

As per the draft

JoinDesired(S,G) = immediate_olist(S,G) != NULL

OR ( KeepaliveTimer(S,G) is running  AND
inherited_olist(S,G) != NULL )

So once SPT bit is set and
source is active, then SPT bit would be reset only if inherited_olist(S,G) becomes NULL.

I hope I could clarify..

Regards,

Prasad

SharadaPrasad
JG

Senior
Software Engineer, Embedded
Business Unit

Huawei
Technologies India Private Ltd,

Bangalore - 560008

Ph:+918041781770
Extn:1738

This
e-mail and attachments contain confidential information from HUAWEI,
which is
intended only for the person or entity whose address is listed above.
Any use
of the information contained herein in any way (including, but not
limited to,
total or partial disclosure, reproduction, or dissemination) by persons
other
than the intended recipient's) is prohibited. If you receive this
e-mail in
error, please notify the sender by phone or email immediately and
delete it!

황선영 wrote:

Hello, all

If SPT bit is set to TRUE and then
upstream interface is changed,

I think do that, but I cannot find
the behavior in draft-ietf-pim-sm-v2-new-12.

U1                   U2

|                     |

|                     |

+-------- R1 ---------+

|

|

D1

First, SPT for (S,G) is built as
U1->R1->D1.

And then R1's unicast route has been
changed to U2.

Then R1's (S,G) upstream should be
changed.

How about the SPTbit ?

Please let me know which chapter I
can refer.

Thanks and regards,

Sunyoung, Hwang