Subject: [pim] PIM-DM: Asserts on p2p interfaces

From: "Paresh Khatri" <[email-masked]>
Date: Mon, 6 Mar 2006 21:44:17 +1100

Hi,

In PIM-DM, does the Assert mechanism also operate over point-to-point interfaces ?  Given a situation where 2 routers are connected by a p2p link, and neither router's interface to that link is the RPF interface, is it correct that one of the interfaces will have an Assert Winner State of 'I won Assert' and a Prune State of 'Pruned' and the other router's interface will have an Assert Winner State of 'I lost Assert'.

A related question is: is the 'Prune State' relevant when an interface has an 'Assert Winner State' that is non 'NoInfo' ?

Appreciate if someone could clarify this for me.

Paresh

This communication, including any attachments, is confidential. If you are not the intended recipient, you should not read it - please contact me immediately, destroy it, and do not copy or use any part of this communication or disclose anything about it.

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Nicholas, Jonathan - ACD " <[email-masked]>
Date: Mon, 6 Mar 2006 13:10:57 -0500

Yes, the Assert mechanism operates over point to point interfaces.
Otherwise, multicast messages may needlessly consume bandwidth on the
point to point interface.

A Prune state is highly relevant for Assert Winners since that is how
they know whether or not to forward to the interface.

Jonathan Nicholas 

> -----Original Message-----
> From: Paresh Khatri [mailto:[email-masked]] 
> Sent: Monday, March 06, 2006 5:44 AM
> To: [email-masked]
> Subject: [pim] PIM-DM: Asserts on p2p interfaces
> 
> Hi,
> 
> In PIM-DM, does the Assert mechanism also operate over 
> point-to-point interfaces ?  Given a situation where 2 
> routers are connected by a p2p link, and neither router's 
> interface to that link is the RPF interface, is it correct 
> that one of the interfaces will have an Assert Winner State 
> of 'I won Assert' and a Prune State of 'Pruned' and the other 
> router's interface will have an Assert Winner State of 'I 
> lost Assert'.
> 
> A related question is: is the 'Prune State' relevant when an 
> interface has an 'Assert Winner State' that is non 'NoInfo' ?
> 
> This communication, including any attachments, is 
> confidential. If you are not the intended recipient, you 
> should not read it - please contact me immediately, destroy 
> it, and do not copy or use any part of this communication or 
> disclose anything about it.
> 
> 
> 
************************************
This e-mail and any files transmitted with it are proprietary and intended solely for the use of the individual or entity to whom they are addressed. If you have received this e-mail in error please notify the sender. Please note that any views or opinions presented in this e-mail are solely those of the author and do not necessarily represent those of ITT Industries, Inc. The recipient should check this e-mail and any attachments for the presence of viruses. ITT Industries accepts no liability for any damage caused by any virus transmitted by this e-mail.
************************************