Subject: [pim] PIM SM - PruneDesired(S, G, rpt)

From: Kannan K S <[email-masked]>
Date: Wed, 11 Oct 2006 12:13:26 +0800

Hi all,

    As per RFC4601; 

        bool PruneDesired(S,G,rpt) {

   return ( RPTJoinDesired(G) AND

( inherited_olist(S,G,rpt) == NULL

  OR (SPTbit(S,G)==TRUE

AND (RPF'(*,G) != RPF'(S,G)) )))

    }

    The scenario is RFP_Interface (S) == RPF_Interface (RP(G)) and RPF' (*,
G) == RPF' (S, G) but RPF'(*, G) and RPF' (S, G) = NULL. 

    Now the router received a (S, G) Assert on RPF_Interface (S) so SPTbit
is TRUE and RPF' (S, G) = AssertWinner 

    This makes the PrunedDesired (S, G, rpt) TRUE. 

    But the RPT should not be pruned since RPT is SPT. 

    I think one check should be added like this (given below)

        bool PruneDesired(S,G,rpt) {

   return ( RPTJoinDesired(G) AND

( inherited_olist(S,G,rpt) == NULL

  OR (SPTbit(S,G)==TRUE

AND ((RPF'(*,G) != RPF'(S,G)) AND (RPF' (*, G) != NULL )))))

    }

    that prevents from making PrunedDesired (S, G, rpt) TRUE. 

Kannan.

 

 

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Venu Hemige" <[email-masked]>
Date: Tue, 10 Oct 2006 22:52:51 -0700

Kannan,

I think the argument is flawed. If RPF(S,G) is NULL, then RPF_Interface(S)
has to be NULL too. 

-Venu

-----Original Message-----
From: Kannan K S [mailto:[email-masked]] 
Sent: Tuesday, October 10, 2006 9:13 PM
To: [email-masked]
Subject: [pim] PIM SM - PruneDesired(S, G, rpt)

Hi all,

    As per RFC4601; 

  OR (SPTbit(S,G)==TRUE

    }

  OR (SPTbit(S,G)==TRUE

    }

 

Kannan.

---

From: Kannan K S <[email-masked]>
Date: Wed, 11 Oct 2006 14:21:12 +0800

Hi Venu,

No, in case of IPv6 this will happen. 

You got the RPF_Interface but you couldn't able to find the RPF' Neighbor
Address (Upstream Neighbor Address) then RPF' (S, G) = NULL. 

Kannan

  _____  

From: Venu Hemige [mailto:[email-masked]] 
Sent: 2006-10-11 1:53 PM
To: 'Kannan K S'; [email-masked]
Subject: RE: [pim] PIM SM - PruneDesired(S, G, rpt)

Kannan,

-Venu

-----Original Message-----
From: Kannan K S [mailto:[email-masked]] 
Sent: Tuesday, October 10, 2006 9:13 PM
To: [email-masked]
Subject: [pim] PIM SM - PruneDesired(S, G, rpt)

Hi all,

    As per RFC4601; 

  OR (SPTbit(S,G)==TRUE

    }

  OR (SPTbit(S,G)==TRUE

    }

 

Kannan.