Subject: [pim] MRIB and multiple RP's

From: "Bandar Al Turaif" <[email-masked]>
Date: Thu, 9 Nov 2006 19:21:29 -0600

Hi,

It is me again. I am a P.h.D candidate at SMU and working with Dr. Suku Nair
on IPTV project using PIM-SM.
We are exploring the possibility of having multiple RPs for a single group.
As you know the RP has no knowledge about the exact structure of the tree.
We need for the RP to know the tree structure to calculate the tree cost.

Here is where my question comes, Is it possible for the RP to know the path
and cost to all DR's and then use that to find its tree cost? and if so, is
this path picked different for Unicast or Multicast since we know that PIM
uses RPF to set up the path to the RP?

Its all related to the MRIB and how it chooses the path and I really did not
find any information for that.

Thank you kindly for your assistance.

-- 
With my best regards

Bandar Al-Turaif
_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "David McWalter" <[email-masked]>
Date: Mon, 13 Nov 2006 19:59:36 -0000

Hi Bander.
 
John is correct that this would be hard to do using PIM-SM protocol flows.
 
However, it may be that your research doesn't require protocol changes.  Once forwarding state is set up, it may be possible for you to look at MRIB entries using the MIBs or some other means, and use this to trace all DRs and add up the link weights in the RPT.  Depending on what access you have, this may solve some inter-domain issues also.
 
So you might be able to tackle this optimization problem within the management plane, without touching the PIM-SM flows in the control plane.
 
David McW.
 
-----Original Message-----
From: John Zwiebel [mailto:[email-masked]]
Sent: 13 November 2006 09:55
To: Bandar Al-Turaif
Cc: [email-masked]; 'Nanda Kishore Salem'
Subject: Re: [pim] MRIB and multiple RP's

On Nov 11, 2006, at 6:48 PM, Bandar Al-Turaif wrote:

I know that the RP at it current state does not know any details about DR’s. My question is, is it possible to modify PIM-SM and make it learn.

Our research is about relocating the RP depending on the shared tree cost, so it is very important for us to know the total cost of tree (link cost metric, or delay metric).

With my best regards.

Bandar Al-Turaif

2 cents: 

Of course it is possible.  However you should consider that a bidir RP does not require a physical
system to be used, its just any arbitrary point in the network.  This is both good and bad for what you
want.  Good, because it makes RP relocation simple: there's no need to physically reconfigure a router.
Bad because there's no central place to collect the information you are interested in.

Of course, you are really interested in just Sparse-mode and not bidir.  IMHO what you want is
a "two-stage" effort.  The source and/or receiver DR registers with a "RP-allocation server" (ie something that
does the calculation to determine the best location of the RP) and then a redistribution of RP
information for the specific multicast group.  (ie a /32)

FWIW, the bootstrap router protocol could quickly redistribute the /32 RP map within an enterprise.
However, doing this across PIM domains would be problematic.

So, you have a potentially good idea, but it depends on the continued deployment of sparse-mode
(ie some, like me, feel sparse-mode is no longer useful and should be replaced by SSM procedures)
and you need to define a protocol that is going to be rather complex, especially if it is used interdomain.

At this point, I do not feel you'll get any vendor to implement it.  Just an opinion.
_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim
_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Thomas Li <[email-masked]>
Date: Tue, 14 Nov 2006 10:12:28 -0800

RFC 4610 describes how anycast-RP works using PIM, without MSDP.
 
regards,

-----Original Message-----
From: Marc Simmons [mailto:[email-masked]]
Sent: Tuesday, November 14, 2006 9:57 AM
To: Nanda Kishore Salem; Bandar Al Turaif; [email-masked]
Subject: RE: [pim] MRIB and multiple RP's

How can you have anycast without MSDP? What will keep all of the RP's
synchronised.
 
Regards
 
Marc Simmons

  _____  

From: Nanda Kishore Salem [mailto:[email-masked]] 
Sent: 10 November 2006 06:09
To: Bandar Al Turaif; [email-masked]
Subject: RE: [pim] MRIB and multiple RP's

Hi Bandar,

            You must be looking for anycast RP. There are many ways how one
group can have

multiple RP's like

1.       anycast rp with msdp

2.       anycast rp without msdp

3.       scoped multicast addressing

There is no way for Rp to know any details about DR's. 

Regards,

Nanda Kishore

  _____  

From: Bandar Al Turaif [mailto:[email-masked]] 
Sent: Friday, November 10, 2006 6:51 AM
To: [email-masked]
Subject: [pim] MRIB and multiple RP's

Hi,

-- 
With my best regards

Bandar Al-Turaif 

http://www.bbc.co.uk <http://www.bbc.co.uk> 
This e-mail (and any attachments) is confidential and may contain personal
views which are not the views of the BBC unless specifically stated.
If you have received it in error, please delete it from your system.
Do not use, copy or disclose the information in any way nor act in reliance
on it and notify the sender immediately.
Please note that the BBC monitors e-mails sent or received.
Further communication will signify your consent to this.