Subject: FW: [pim] ABOUT Update_SPTbit(S,G,iif)

From: "CTO YAO Chunyan" <[email-masked]>
Date: Tue, 28 Nov 2006 09:48:53 +0800

Dear Rishabh and Natarajia,

          Thanks a lot for your quickly and detailed reply!

          The following is a small editing matter:

                 How do you think we add a Number "5" before the second paragraph on page 29 of RFC4601? The paragraph will be changed into :

                5. In the case where the RPF interface is the same for the RP and for S, but RPF'(S,G) and RPF'(*,G) differ, we wait for an Assert(S,G), which
   indicates that the upstream router with (S,G) state believes the SPT   has been completed.However, item (3) above is needed because there
   may not be any (*,G) state to trigger an Assert(S,G) to happen.

                 Because I think that this paragraph is explaining the condition "I_Am_Assert_Loser(S,G,iif)" ,and it should be placed side by side with the explaination for the former four conditions listed befor the paragraph we discussed above. 

                With regards!

                                       Chunyan

-----Original Message-----
From: Rishabh Parekh [mailto:[email-masked]] 
Sent: 2006年11月28日 1:26
To: [email-masked]
Cc: CTO YAO Chunyan
Subject: Re: [pim] ABOUT Update_SPTbit(S,G,iif)

Chunyan,
Consider the following:

		R1			R2
		|			|
		|			|
	--------------------------------------
		|			|
		|			|
		R3			R4

Assume that R3 has JoinDesired(*,G) == TRUE and RPF'(*,G) = R1 and that 
traffic from source S is arriving on the RPT. Now, R3 receives a (S,G) join 
from downstream and so JoinDesired(S,G) == TRUE. Assume that RPF'(S,G) = R2. 
In this case since RPF_Interface(S) == RPF_Interface(RP(G)) AND RPF'(S,G) != 
RPF'(*,G), there is no way determine when the traffic from S starts arriving 
on the SPT (i.e. from R2). Therefore, to set the SPT bit R3 can only depend 
on R2 winning the (S,G) Assert and by implication R3 losing the Assert i.e 
I_Am_Assert_Loser (S,G,iif).

Regards,
Rishabh.
 
On Monday 27 November 2006 03:13, CTO YAO Chunyan wrote:
> Dear all, SPTbit is updated as follows:
>
>      void
>      Update_SPTbit(S,G,iif) {
>        if ( iif == RPF_interface(S)
>              AND JoinDesired(S,G) == TRUE
>              AND ( DirectlyConnected(S) == TRUE
>                    OR RPF_interface(S) != RPF_interface(RP(G))
>                    OR inherited_olist(S,G,rpt) == NULL
>                    OR ( ( RPF'(S,G) == RPF'(*,G) ) AND
>                         ( RPF'(S,G) != NULL ) )
>                    OR ( I_Am_Assert_Loser(S,G,iif) ) {
>           Set SPTbit(S,G) to TRUE
>        }
>      }
>
>
> I don't understand HOW the last one condition "
> I_Am_Assert_Loser(S,G,iif)" along with "iif == RPF_interface(S)AND
> JoinDesired(S,G) == TRUE" can show that source-specific-tree is OK?
>
> Could you tell me what the condition "
> I_Am_Assert_Loser(S,G,iif)"mean?
>
>
> Thanks a lot in advance!
>
>                        Chunyan

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "CTO YAO Chunyan" <[email-masked]>
Date: Tue, 28 Nov 2006 10:40:45 +0800

-----Original Message-----
From: 
Sent: 2006年11月28日 9:50
To: [email-masked]'; 'Nataraja, Rajesh (Rajesh)'; [email-masked]'
Subject: FW: [pim] ABOUT Update_SPTbit(S,G,iif)

                With regards!

                                       Chunyan

-----Original Message-----
From: Rishabh Parekh [mailto:[email-masked]] 
Sent: 2006年11月28日 1:26
To: [email-masked]
Cc: CTO YAO Chunyan
Subject: Re: [pim] ABOUT Update_SPTbit(S,G,iif)

Chunyan,
Consider the following:

		R1			R2
		|			|
		|			|

Regards,
Rishabh.