Subject: [pim] ABOUT Update_SPTbit(S,G,iif)

From: "CTO YAO Chunyan" <[email-masked]>
Date: Mon, 27 Nov 2006 19:13:03 +0800

Dear all, SPTbit is updated as follows:

     void
     Update_SPTbit(S,G,iif) {
       if ( iif == RPF_interface(S)
             AND JoinDesired(S,G) == TRUE
             AND ( DirectlyConnected(S) == TRUE
                   OR RPF_interface(S) != RPF_interface(RP(G))
                   OR inherited_olist(S,G,rpt) == NULL
                   OR ( ( RPF'(S,G) == RPF'(*,G) ) AND
                        ( RPF'(S,G) != NULL ) )
                   OR ( I_Am_Assert_Loser(S,G,iif) ) {
          Set SPTbit(S,G) to TRUE
       }
     }

I don't understand HOW the last one condition "
I_Am_Assert_Loser(S,G,iif)" along with "iif == RPF_interface(S)AND
JoinDesired(S,G) == TRUE" can show that source-specific-tree is OK?
 
Could you tell me what the condition " I_Am_Assert_Loser(S,G,iif)"mean?

Thanks a lot in advance!
 
                       Chunyan   
_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Nataraja, Rajesh \(Rajesh\)" <[email-masked]>
Date: Mon, 27 Nov 2006 16:58:29 +0530

Hi  chunyan,

This check is necessary for the case where the router which has to
trigger SG RPT prune, has the IIF towards the RP and the IIF towards the
Source to be the same. But the RPF neighbors towards them are different.

In this case there is no way the router can tell if the packets are
arriving on the SPT or RPT. Only the Assert from the SPT-neighboring
router which wins against the RPT-neighboring router can explain if the
SPT switch has happened.

Thanks

Rajesh.

________________________________

From: CTO YAO Chunyan [mailto:[email-masked]] 
Sent: Monday, November 27, 2006 4:43 PM
To: [email-masked]
Subject: [pim] ABOUT Update_SPTbit(S,G,iif)

	     void
	     Update_SPTbit(S,G,iif) {

	Could you tell me what the condition "
I_Am_Assert_Loser(S,G,iif)"mean?

	Thanks a lot in advance!

	                       Chunyan

---

From: Rishabh Parekh <[email-masked]>
Date: Mon, 27 Nov 2006 09:25:35 -0800

Chunyan,
Consider the following:

		R1			R2
		|			|
		|			|
	--------------------------------------
		|			|
		|			|
		R3			R4

Assume that R3 has JoinDesired(*,G) == TRUE and RPF'(*,G) = R1 and that 
traffic from source S is arriving on the RPT. Now, R3 receives a (S,G) join 
from downstream and so JoinDesired(S,G) == TRUE. Assume that RPF'(S,G) = R2. 
In this case since RPF_Interface(S) == RPF_Interface(RP(G)) AND RPF'(S,G) != 
RPF'(*,G), there is no way determine when the traffic from S starts arriving 
on the SPT (i.e. from R2). Therefore, to set the SPT bit R3 can only depend 
on R2 winning the (S,G) Assert and by implication R3 losing the Assert i.e 
I_Am_Assert_Loser (S,G,iif).

Regards,
Rishabh.