Subject: RE: [pim] pim-sm router transitions from DR to non-DR

From: "Satyanarayana Dillikar" <[email-masked]>
Date: Sun, 22 Apr 2007 18:42:50 +0530

Hi Binu,

 See inline

________________________________

From: Binu TN [mailto:[email-masked]] 
Sent: Saturday, April 21, 2007 9:38 PM
To: [email-masked]
Subject: [pim] pim-sm router transitions from DR to non-DR

Hi,

  I have a basic doubt in the pim-sm router transition from DR to
non-DR. Let's assume a scenario where a sm router (e.g., RT1) is DR in a
LAN and it has multicast route entry and it is trigerring Join messages
to RP (it is in some other network) as it has some interesting hosts. If
another sm router (e.g.RT2) with higher IP address comes into the LAN of
RT1, as per my understanding RT2 will become DR and RT1 will become
non-DR to that LAN. My doubts are,

1) whether the multicast route entries that are present in RT1 before
entry of  RT2 will be removed?

[dsatya] Not necessarily, those entries will changed based on the
unicast route change to RP. (due to insertion of RT2)

2) Will RT1 stops trigerring Join messages to RP? Or RT1 will be
trigerring Join messages for existing entries and RT2 will be trigerring
for any new entries?

[dsatya] RT1 should not trigger Join Msgs to RP and RT2 should take up
the job.

Thanks

Satya

Please clear my doubts.
Thank you in advance.

Regards,
Binu.

________________________________

Ahhh...imagining that irresistible "new car" smell?
Check out new cars at Yahoo! Autos.
<http://us.rd.yahoo.com/evt=48245/*http:/autos.yahoo.com/new_cars.html;_
ylc=X3oDMTE1YW1jcXJ2BF9TAzk3MTA3MDc2BHNlYwNtYWlsdGFncwRzbGsDbmV3LWNhcnM-

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Rajesh Nataraja" <[email-masked]>
Date: Thu, 26 Apr 2007 12:09:55 -0700

Hello,

I think the better way to do is to not care about being a DR or not, and
just  handle it based on what would happen if someone asserts, are there
compatability issues here? What do authors say?

Thanks
Rajesh.

On 4/22/07, Satyanarayana Dillikar <[email-masked]> wrote:
>
>  Hi Binu,
>
>  See inline
>
>
>  ------------------------------
>
> *From:* Binu TN [mailto:[email-masked]]
> *Sent:* Saturday, April 21, 2007 9:38 PM
> *To:* [email-masked]
> *Subject:* [pim] pim-sm router transitions from DR to non-DR
>
>
>
> Hi,
>
>   I have a basic doubt in the pim-sm router transition from DR to non-DR.
> Let's assume a scenario where a sm router (e.g., RT1) is DR in a LAN and
> it has multicast route entry and it is trigerring Join messages to RP (it is
> in some other network) as it has some interesting hosts. If another sm
> router (e.g.RT2) with higher IP address comes into the LAN of RT1, as per
> my understanding RT2 will become DR and RT1 will become non-DR to that LAN.
> My doubts are,
>
> *[dsatya] Not necessarily, those entries will changed based on the unicast
> route change to RP. (due to insertion of RT2)*
>
>
> trigerring Join messages for existing entries and RT2 will be trigerring for
> any new entries?
>
> *[dsatya] RT1 should not trigger Join Msgs to RP and RT2 should take up
> the job.*
>
> *Thanks*
>
> *Satya*
>
>
> Please clear my doubts.
> Thank you in advance.
>
> Regards,
> Binu.
>
>
>  ------------------------------
>
> Check out new cars at Yahoo! Autos.<http://us.rd.yahoo.com/evt=48245/*http:/autos.yahoo.com/new_cars.html;_ylc=X3oDMTE1YW1jcXJ2BF9TAzk3MTA3MDc2BHNlYwNtYWlsdGFncwRzbGsDbmV3LWNhcnM->
>