Subject: [pim] Re: pim Digest, Vol 36, Issue 2

From: "Neeraj Prasad" <[email-masked]>
Date: Tue, 24 Apr 2007 02:19:52 +0530

1. Interesting host information is stored in all routers whether DR or
non-DR. So at any if a router becomes DR it will send the Join Information
towards RP and the tree will be maintained. So packets will come to host
irrespective who the DR is.

2. It may retain the information or delete it, that is implementation
dependent. The router up the tree will timeout the state, if they do not
receive any JOIN information without taking any action.

Regards,
Neeraj.

On 4/22/07, [email-masked] <[email-masked]> wrote:
>
> Send pim mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www1.ietf.org/mailman/listinfo/pim
> or, via email, send a message with subject or body 'help' to
>        [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of pim digest..."
>
>
> Today's Topics:
>
>    1. pim-sm router transitions from DR to non-DR (Binu TN)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Sat, 21 Apr 2007 09:07:46 -0700 (PDT)
> From: Binu TN <[email-masked]>
> Subject: [pim] pim-sm router transitions from DR to non-DR
> To: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="iso-8859-1"
>
> Hi,
>
>   I have a basic doubt in the pim-sm router transition from DR to non-DR.
> Let's assume a scenario where a sm router (e.g., RT1) is DR in a LAN and
> it has multicast route entry and it is trigerring Join messages to RP (it is
> in some other network) as it has some interesting hosts. If another sm
> router (e.g.RT2) with higher IP address comes into the LAN of RT1, as per
> my understanding RT2 will become DR and RT1 will become non-DR to that LAN.
> My doubts are,
>
> 1) whether the multicast route entries that are present in RT1 before
> entry of  RT2 will be removed?
>
> 2) Will RT1 stops trigerring Join messages to RP? Or RT1 will be
> trigerring Join messages for existing entries and RT2 will be trigerring for
> any new entries?
>
> Please clear my doubts.
> Thank you in advance.
>
> Regards,
> Binu.
>
>
> ---------------------------------
> Ahhh...imagining that irresistible "new car" smell?
> Check outnew cars at Yahoo! Autos.
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL:
> http://www1.ietf.org/pipermail/pim/attachments/20070421/39ab31a5/attachment.html
>
> ------------------------------
>
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pim
>
>
> End of pim Digest, Vol 36, Issue 2
> **********************************
>

-- 
Thanks and Regards,
Neeraj Prasad
_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Su Haiyang <[email-masked]>
Date: Tue, 24 Apr 2007 19:18:03 +0800

Dear All,

   I strongly recommend that there should be some transition mechanism
between old DR and new DR.

The reason is that even though the lately booted DR keep the GMP join group
membership and already learned source,

The new DR still need time to reestablish SPT or RPT tree depending whether
the group is SM or SSM. Considering generally deployed PIM scenario, there
will be two last-hop routers connecting the clouds of hosts or layer2
switches. If the link between DR and backup DR is unstable, there will be
data loss and vibration of PIM state maintained on all the routers.

You may say that static group join may be configured at last-hop DR. But it
take some time for new DR to updated all the downstreams if there are more
than 10K level of groups.

So I strongly recommend that transition mechanism should be considered on
the new PIM draft.

One of my suggestions is that, a new timer DR switch delay timer should be
introduced. Before this timer expires,

Old DR won't give up the DR responsibility. To avoid the duplicated data, a
unique forwarder is elected between Old DR and New DR

by using assert mechanism.

Request for your comments

Best regards

Su Haiyang

  _____  

From: Neeraj Prasad [mailto:[email-masked]] 
Sent: Tuesday, April 24, 2007 4:50 AM
To: [email-masked]
Subject: [pim] Re: pim Digest, Vol 36, Issue 2

Regards, 
Neeraj.

On 4/22/07, [email-masked] <[email-masked] > wrote:

Send pim mailing list submissions to
         <mailto:[email-masked]>  [email-masked]

Today's Topics:

Message: 1

Hi,

  I have a basic doubt in the pim-sm router transition from DR to non-DR.
Let's assume a scenario where a sm router (e.g., RT1) is DR in a LAN and it
has multicast route entry and it is trigerring Join messages to RP (it is in
some other network) as it has some interesting hosts. If another sm router (
e.g.RT2) with higher IP address comes into the LAN of RT1, as per my
understanding RT2 will become DR and RT1 will become non-DR to that LAN. My
doubts are,

1) whether the multicast route entries that are present in RT1 before entry
of  RT2 will be removed? 

2) Will RT1 stops trigerring Join messages to RP? Or RT1 will be trigerring
Join messages for existing entries and RT2 will be trigerring for any new
entries?

Please clear my doubts.
Thank you in advance. 

Regards,
Binu.

-------------- next part --------------
An HTML attachment was scrubbed...
URL:
http://www1.ietf.org/pipermail/pim/attachments/20070421/39ab31a5/attachment.
html

-- 
Thanks and Regards,
Neeraj Prasad