Subject: [pim] Query about BSR election

From: Subinoy Das <[email-masked]>
Date: Wed, 16 May 2007 05:30:03 -0700 (PDT)

Hi,

I have some confusion about BSR election in draft "draft-ietf-pim-sm-bsr-09".
In Section 3.2 page 17 it says
"When a new BSR is elected, the C-RP MUST send one to three C-RP-Adv
messages, waiting a small randomized period C_RP_Adv_Backoff before
sending each message."
But how C-RPs comes to know that BSR election is done and now it can prepare to send three C-RP-Adv messages?

Please reply me if anyone knows the answer.

Thanks and Regards,
Subinoy

____________________________________________________________________________________Get the Yahoo! toolbar and be alerted to new email wherever you're surfing.
http://new.toolbar.yahoo.com/toolbar/features/mail/index.php

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: sumanta seal <[email-masked]>
Date: Wed, 16 May 2007 14:50:41 +0100 (BST)

Hi Subinoy,

The elected BSR's BSM informs all other routers in the domain that it is the elected BSR.

A C-RP can fall into two category -
1. Candidate-BSR
2. Non-Candidate-BSR

Now, in the first case, where the C-RP is configured as a Candidate-BSR, the elected BSR is identified following the Candidate-BSR State machine (specified section 3.1.1 in draft "draft-ietf-pim-sm-bsr-09"). The C-RP functionality of the Candidate-BSR router use this information to determine the elected BSR. Whenever a elected BSR changes, each Candidate-BSR router knows this from Candidate-BSR State machine, hence the C-RP functionality also get informed about the change and sends one-to-three C-RP-Adv messages.

In the second case, on receiving a BSM (preferred or non-preferred), a router always moves to Accept Preferred state in Per-Scope-Zone state machine for Non-Candidate BSR (section 3.1.2 in draft "draft-ietf-pim-sm-bsr-09"), irrespective of whether it is in NoInfo or Accept Any state. Since in Accept Preferred state, the router knows the identity of the elected BSR, hence the C-RP functionality. The BSR change event is also get informed by the Per-Scope-Zone state machine and on such event the C-RP sends one-to three C-RP-Adv messages.

Rgds,
Sumanta

Subinoy Das <[email-masked]> wrote: Hi,

  
 Thanks and Regards,
 Subinoy

---------------------------------
Be a better Globetrotter. Get better travel answers from someone who knows.
Yahoo! Answers - Check it out.  _______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

Thanks & Regards, 
************************************************** 
Sumanta Seal
Salt Lake City, Kolkata
West Bengal
**************************************************

---------------------------------
 Office firewalls, cyber cafes, college labs, don't allow you to download CHAT? Here's a solution!