Subject: [pim] Need help in Rfc 2362, thanks

From: "z204126" <[email-masked]>
Date: Mon, 18 Feb 2008 09:45:17 +0800

In Rfc 2362,   3.2.1 Sending Join/Prune Messages,  "Periodic Join/Prune Messages:", 

      1 Each router determines the RP for a (*,G) entry by using
        the hash function described. The RP address (with RPT and WC
        bits set) is included in the join list of a periodic Join/Prune
        message under the following conditions:

           1 The Join/Prune message is being sent to the RPF
             neighbor toward the RP for an active (*,G) or (*,*,RP)
             entry, and

           2 The outgoing interface list in the (*,G) or (*,*,RP)
             entry is non-NULL, or the router is the DR on the same
             interface as the RPF neighbor.

what the mean "or the router is the DR on the same  interface as the RPF neighbor."? I don't think out the condition, who can help me, and give me a conditon about this? thanks.

zhang

z204126
2008-02-18
_______________________________________________
pim mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/pim

---

From: Christopher Thomas Brown <[email-masked]>
Date: Sun, 17 Feb 2008 21:23:22 -0800

> what the mean "or the router is the DR on the same  interface as the RPF neighbor."? I don't think out the condition, who can help me, and give me a conditon about this? thanks.

RPF 2362 is obsolete. It has been updated by RFC 4601 which is much better
for understanding how PIM-SM should work.

In the particular question you are asking, the DR is responsible for
joining the RP tree if there is local group membership on the link.
However, if the link is also the DR's RPF interface towards the RP
then its outgoing interface list in the (*,G) entry will be NULL
(because you remove the incomming interface from it). This specific
condition still has the router send the (*,G) join.

Chris