Subject: [pim] Regarding Forwarding

From: "sandeep kumar" <[email-masked]>
Date: Fri, 3 Oct 2008 11:48:19 +0530

Hi all,

Is there any specific reason for not putting he below condition in
forwarding rules

if (received interface of SRM is not state refresh capable)
{
    discard the packet;
}
_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: "Nicholas, Jonathan - CS" <[email-masked]>
Date: Mon, 6 Oct 2008 07:48:27 -0400

Yes.  For reasons related to backwards compatibility with previous drafts of PIM-DM, it is necessary to deliver multicast packets to ALL downstream interfaces (subject to Prune and Assert states) regardless of State Refresh capability.  Without this action, members of multicast groups downstream of a router that is not State Refresh capable will not be able to get their multicast messages.

If the resulting Flood & Prune cycle is deemed too large of a burden on network resources, administrative actions (e.g. replace the old router) are the recommended solution.

Jonathan Nicholas

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of sandeep kumar
Sent: Friday, October 03, 2008 2:18 AM
To: [email-masked]
Subject: [pim] Regarding Forwarding

Hi all,

Is there any specific reason for not putting he below condition in forwarding rules

________________________________
This e-mail and any files transmitted with it may be proprietary and are intended solely for the use of the individual or entity to whom they are addressed. If you have received this e-mail in error please notify the sender.
Please note that any views or opinions presented in this e-mail are solely those of the author and do not necessarily represent those of ITT Corporation. The recipient should check this e-mail and any attachments for the presence of viruses. ITT accepts no liability for any damage caused by any virus transmitted by this e-mail.
_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim