Subject: [pim] draft-xu-pim-drpriority-auto-adjustment

From: Stig Venaas <[email-masked]>
Date: Thu, 03 Dec 2009 01:18:55 -0800

At the PIM wg meeting we had discussions on several new documents
where we didn't get enough time in the meeting. It would be good
to continue the discussions on the list.

One of the drafts is
draft-xu-pim-drpriority-auto-adjustment-01

Here are some of my thoughts on this (hopefully this may start
some discussion). Most of these were also brought up in the
meeting I think.

1. Loss of upstream connectivity

    Is it clear what this means? If you have a single upstream
    link and that breaks, fine. But what if you have multiple
    upstream links and say just one breaks? What if you just
    lose some of your upstream routes (maybe there is a failure
    further upstream only affecting one of the candidate DRs)?

2. Resetting/raising priorities

    When you reduce your DR priority due to a failure, when do
    you raise it again (or reset it back to normal)? Can this
    cause some interruption? If you don't, what if you later
    have a failure for the other router?

3. Are there other approaches?

3a. Static routing etc

    The failed DR may use the link shared with the other
    router to have upstream connectivity. I agree that with
    many deployments you don't want to run dynamic routing on
    that link. I agree that static routing can be bad, as
    discussed in the draft. I'm wondering if there still may be
    ways of achieving this though.

3b. Virtual router

    There are some standard mechanisms for how you can have a
    "virtual" IP address shared by the two routers, where the
    IP address can be moved to the other router. This is a
    more heavy weight solution, but there may be other reasons.
    E.g. it's not unusual that hosts just have a static default
    unicast route to one IP address.

Any thoughts on this?

Stig

---

From: Xu Xiaohu <[email-masked]>
Date: Thu, 03 Dec 2009 18:04:14 +0800

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Stig
Venaas
> 发送时间: 2009年12月3日 17:19
> 收件人: [email-masked]
> 主题: [pim] draft-xu-pim-drpriority-auto-adjustment
> 

Hi Stig,

Thanks for starting this discussion.

>     further upstream only affecting one of the candidate DRs)?

The following text quoted from the draft addressed your concern. 

   "In most cases, two last-hop routers each with an upstream link are
   enough for redundancy purpose. In case there are more than one
   upstream links on a PIM router, all of these interfaces should be
   tracked for the DR priority adjustment. As long as there is a route
   to the outside network, it is not necessary for the DR switchover to
   take place. However,if the number of uplink interfaces is large, the
   network administrator can actually choose part of uplinks which are
   to be tracked for the DR priority adjustment."

In a word, it's up to the operator to determine which upstream links should
be tracked. In fact, the upstream link tracking mechanism for VRRP will face
the same scenario.

>     have a failure for the other router?

There is some consideration in the draft about the scenario you mentioned.
See the following text:

   "Once the failed upstream link on R1 recovers (from down to up), its
   DR priority can be either recovered or not according to the pre-
   configured preemption policy. For example, if preemption is not
   allowed, its DR priority will remain unchanged so as to avoid DR
   switchover. As a result, the transient multicast forwarding
   interruption due to multicast forwarding tree rebuilding will not  
   occur. Once the current DR fails or its DR priority changes, the
   non-DR should start using its actual DR value to compete for a new
   round of DR election provided it has got route to the uplinks."

>     unicast route to one IP address.

IGMP and PIM has nothing to do with the "virtual IP address", (e.g., in the
case of VRRP). I'm not sure I understood your question. Can you say more in
detail?

Any comment is welcomed.

Xiaohu

> Any thoughts on this?
> 
> Stig
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim

---

From: "Prashant Jhingran (pjhingra)" <[email-masked]>
Date: Tue, 8 Dec 2009 19:38:25 +0530

Hi Stig,

As pointed out by Xiaohu, we have tried to address  scenario 1st & 2nd in the draft. Kindly let us know your comments, we would try to address those.

For scenario 3b viz. Virtual router , I guess you are pointing to VRRP based solution. Perhaps that's a workaround for this scenario, but this may be a simpler/low-cost PIM protocol based solution. 

Regards,
Prashant Jhingran
www.cisco.com
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Xu Xiaohu
Sent: Thursday, December 03, 2009 3:34 PM
To: 'Stig Venaas'; [email-masked]
Subject: Re: [pim] draft-xu-pim-drpriority-auto-adjustment

Venaas
> where we didn't get enough time in the meeting. It would be good to 
> continue the discussions on the list.

Hi Stig,

> Here are some of my thoughts on this (hopefully this may start some 
> discussion). Most of these were also brought up in the meeting I 
> think.
> 

In a word, it's up to the operator to determine which upstream links should be tracked. In fact, the upstream link tracking mechanism for VRRP will face the same scenario.

>     unicast route to one IP address.

IGMP and PIM has nothing to do with the "virtual IP address", (e.g., in the case of VRRP). I'm not sure I understood your question. Can you say more in detail?

Any comment is welcomed.

Xiaohu

---

From: Xu Xiaohu <[email-masked]>
Date: Wed, 09 Dec 2009 12:24:27 +0800

> -----邮件原件-----
> 发件人: Prashant Jhingran (pjhingra) [mailto:[email-masked]]
> 发送时间: 2009年12月8日 22:08
> 收件人: Xu Xiaohu; Stig Venaas; [email-masked]
> 主题: RE: [pim] draft-xu-pim-drpriority-auto-adjustment
> 
> Hi Stig,
> 
> As pointed out by Xiaohu, we have tried to address  scenario 1st & 2nd in
the
> draft. Kindly let us know your comments, we would try to address those.
> 
> For scenario 3b viz. Virtual router , I guess you are pointing to VRRP
based
> solution. Perhaps that's a workaround for this scenario, but this may be a
> simpler/low-cost PIM protocol based solution.

Aha, do you (stig and Prashant) mean the VRRP master and the PIM DR should
be always on the same router? That's to say, once the VRRP master is shifted
from one router to another, the PIM DR should also be shifted
correspondingly by reducing DR priority of the old DR automatically. This
approach can work. Although this approach couples the DR switchover to VRRP
(or HSRP) too closely, I could add it as another option into the draft.

Any other comment?

Xiaohu

---

From: Stig Venaas <[email-masked]>
Date: Tue, 08 Dec 2009 23:29:07 -0800

Xu Xiaohu wrote:
[...]
> (or HSRP) too closely, I could add it as another option into the draft.

I'm not sure whether it makes sense and it is a bit different. Main
point is really that there may be various mechanisms or triggers for
adjusting the DR priority.

> Any other comment?

I was hoping other people would have comments too. The more high level
questions I have are:

Is this useful?

Is this a good approach, are there other alternatives?

Should this be documented as an RFC (Informational I guess)?

It is a bit early to ask the last question though. It depends
on the answers to the others.

I hope some wg members have thoughts on this... It's way too quiet
on the list.

Stig