Subject: Re: [pim] draft-xu-pim-drpriority-auto-adjustment

From: Xu Xiaohu <[email-masked]>
Date: Fri, 26 Feb 2010 12:25:31 +0800

Hi all,

I have submitted an updated version which includes an approach of coupling
PIM and VRRP to reuse the uplink tracking mechanism of VRRP. The idea of
this approach is basically from Stig's comments.

The URL is here:
http://tools.ietf.org/html/draft-xu-pim-drpriority-auto-adjustment-02.

Any further comment is welcomed.

Best wishes,
Xiaohu

> -----邮件原件-----
> 发件人: Stig Venaas [mailto:[email-masked]]
> 发送时间: 2009年12月9日 15:29
> 收件人: Xu Xiaohu
> 抄送: 'Prashant Jhingran (pjhingra)'; [email-masked]
> 主题: Re: [pim] draft-xu-pim-drpriority-auto-adjustment
> 
> Xu Xiaohu wrote:
> [...]
> > Aha, do you (stig and Prashant) mean the VRRP master and the PIM DR
should
> > be always on the same router? That's to say, once the VRRP master is
shifted
> > from one router to another, the PIM DR should also be shifted
> > correspondingly by reducing DR priority of the old DR automatically.
This
> > approach can work. Although this approach couples the DR switchover to
VRRP
> > (or HSRP) too closely, I could add it as another option into the draft.
> 
> I'm not sure whether it makes sense and it is a bit different. Main
> point is really that there may be various mechanisms or triggers for
> adjusting the DR priority.
> 
> > Any other comment?
> 
> I was hoping other people would have comments too. The more high level
> questions I have are:
> 
> Is this useful?
> 
> Is this a good approach, are there other alternatives?
> 
> Should this be documented as an RFC (Informational I guess)?
> 
> It is a bit early to ask the last question though. It depends
> on the answers to the others.
> 
> I hope some wg members have thoughts on this... It's way too quiet
> on the list.
> 
> Stig
> 
> > Xiaohu

---

From: Xu Xiaohu <[email-masked]>
Date: Fri, 26 Feb 2010 13:37:54 +0800

Hi all,

If I understand the PIM specification correctly, there is no mechanism for
avoiding DR preemption. For example, assuming a rebooted PIM router finds
there is already a PIM DR on the LAN to which it is connected and its own DR
priority is higher than that of the current DR, to avoid DR preemption, it
could automatically sets its priority to a value smaller than that of the
current DR. In this way, the unnecessary DR switchover can be avoided.

Any comment?

Xiaohu

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Xu Xiaohu
> 发送时间: 2010年2月26日 12:26
> 收件人: 'Stig Venaas'
> 抄送: [email-masked]
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim