Subject: [pim] wglc for draft-ietf-pim-registry-00

From: "Mike McBride (mmcbride)" <[email-masked]>
Date: Tue, 8 Jun 2010 10:28:50 -0700

Today begins a two week wglc for draft-ietf-pim-registry-00. Please
respond with your opinion on whether this draft is ready to be sent to
the IESG. A experimental pim message type was not added due to no wg
response.

http://www.ietf.org/id/draft-ietf-pim-registry-00.txt

thanks,
mike

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Stig Venaas
> Sent: Wednesday, May 26, 2010 11:04 AM
> To: [email-masked]
> Subject: Re: [pim] Reserving a PIM message type for experimental use?
> 
> Stig Venaas wrote:
> > Hi
> >
> > In Anaheim there appeared to be consensus for taking
> > draft-ietf-pim-registry-00.txt to wglc.
> 
> It would have been nice to get some input on this. Can
> you please let me know whether you think the draft is
> ready for wglc?
> 
> Or, should we reserve a type for experimental use, or
> any other changes?
> 
> Stig
> 
> > However, we also discussed whether there should be a
> > reserved PIM message type for experimental use. This is
> > not in the current draft, but could be added if the wg
> > wants.
> >
> > I think before moving on with the draft, we should see
> > if there is consensus one way or the other for reserving
> > an experimental type.
> >
> > So please comment whether you think it's a good idea.
> >
> > Before you comment, please see BCP82/RFC3692:
> > "Assigning Experimental and Testing Numbers Considered Useful"
> > http://tools.ietf.org/html/rfc3692
> >
> > and consider whether this is useful for PIM. Note that as it
> > says, even a single experimental value may have some uses.
> >
> > Stig
> > _______________________________________________
> > pim mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/pim
> 
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim

---

From: Stig Venaas <[email-masked]>
Date: Tue, 08 Jun 2010 10:46:40 -0700

> http://www.ietf.org/id/draft-ietf-pim-registry-00.txt

I really hope to get some input on this simple document. It takes <5
minutes to read.

If it's good to go, please say so. If you want an experimental message
type added, then say so.

And of course if you have any issues, that is very welcome as well.

Stig

---

From: Bharat Joshi <[email-masked]>
Date: Wed, 9 Jun 2010 11:37:34 +0530

Hi Stig,

     I think its good to do to next level. 

     I have couple of small questions:

1. Do we have a size fixed for the type field? Is it a 8 bits/16 bits etc? Should we mention the same somewhere in the document?

2. Would it be good if we keep the reserved message type to the largest possible value of the message type? For example: If its a 8 bit value, we can propose it to be 255. This way at least things won't get mixed up if we end up allocating message types more than 15.

Regards,
Bharat
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Mike McBride (mmcbride) [[email-masked]]
Sent: Tuesday, June 08, 2010 10:58 PM
To: [email-masked]
Subject: [pim] wglc for draft-ietf-pim-registry-00

thanks,
mike

---

From: Stig Venaas <[email-masked]>
Date: Wed, 09 Jun 2010 00:05:48 -0700

> 1. Do we have a size fixed for the type field? Is it a 8 bits/16 bits etc? Should we mention the same somewhere in the document?

I guess this should be pointed out in the document. But if you check say
4601 you will see that it's 4 bits.
> 2. Would it be good if we keep the reserved message type to the largest possible value of the message type? For example: If its a 8 bit value, we can propose it to be 255. This way at least things…

Exactly, that's why the document reserves type 15 :)

Stig

---

From: Bharat Joshi <[email-masked]>
Date: Wed, 9 Jun 2010 13:19:18 +0530

Ok. Good.

Thanks,
Bharat
________________________________________
From: Stig Venaas [[email-masked]]
Sent: Wednesday, June 09, 2010 12:35 PM
To: Bharat Joshi
Cc: Mike McBride (mmcbride); [email-masked]
Subject: Re: [pim] wglc for draft-ietf-pim-registry-00

Stig

---

From: Stig Venaas <[email-masked]>
Date: Wed, 09 Jun 2010 13:36:59 -0700

> Ok. Good.

I will add text saying what the size is. I seem to remember getting a
comment on that before as well.

I'll do an updated version based on the wglc input, this is one of the
fix I'll include then.

Stig