Subject: [pim] problem related with flat network

From: Akhil Nair <[email-masked]>
Date: Wed, 06 Mar 2013 13:41:10 +0530

Dear All,
I am currently working with pimd.
I have a flat network(all the routers in the same network),connected
linearly.

                 h1-------t2-------t3-------u2------h2

Where h1 and h2 are leaf node which is acting as server and client in
this case.I mean we are running a c program which will send the "Hello
world" message over a multicasted network (Sender ip address:225.0.0.37
as programmed in c program) and other machine will receive those
messages.On t2,t3 and u2 we are running pimd and t3 act as rendezvous
point.

In normal network the scenario is working(All the routers are in
different network), but for the flat network(All the routers in the same
network),the above configuration is not working i.e. we are not able to
receive the "hello world" message.

I am getting some messages like 
"cache miss,src 10.0.0.8 dest 225.0.0.37 ,Iif 0"
The 10.0.0.8 is the ip address of h2 when h2 is acting as sender and h1
acting as receiver.

I want to also know whether pimd wouldn't for flat network(All the
routers in same network)

Please help me in this scenario as I am stuck from a long time. 
Thanks in advance

Regards
Akhil Nair

=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

---

From: Indranil Bhattacharya <[email-masked]>
Date: Thu, 7 Mar 2013 11:33:56 +0530

Hi,

   Yes PIM works on flat network. You will have the same router working as
both LHR and FHR.

    The cache miss event is generated when there is no mroute for the
incoming traffic.Are these linux boxes? if so then compare the o/p of
/proc/net/ip_mr_cache, /proc/net/ip_mr_vif and /proc_net/ip_mr_rp with that
of the working config.

Thanks,
Indranil

On Wed, Mar 6, 2013 at 1:41 PM, Akhil Nair <[email-masked]> wrote:

> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim
>

---

From: Indranil Bhattacharya <[email-masked]>
Date: Thu, 7 Mar 2013 20:50:58 +0530

Hi Akhil,

           Can you configure all the devices in same vlan? That way you can
select same device as FHR and LHR. What else did you mean by flat network?
I though you are trying some sort of datacentre scenario.

           Can you check the o/p of the tables in normal networks? Also
check the dmesg o/p. Is the FHR starting pim encapsulation?

Thanks,
Indranil

On Thu, Mar 7, 2013 at 1:25 PM, Akhil Nair <[email-masked]> wrote:

> Hi Indranil,
> Thank you for helping me and reading my concerns and really appreciate
> it.
> On Thu, 2013-03-07 at 11:33 +0530, Indranil Bhattacharya wrote:
> > Hi,
> >
> >    Yes PIM works on flat network. You will have the same router
> > working as both LHR and FHR.
> In my working scenario I am having LHR as t2 and FHR as u2 and some a
> times its vice versa depends on who is acting as server and who is
> client ( for eg h2 act as sender sometimes and receiver sometimes same
> as with u2 ).So what you said that LHR and FHR should be same router is
> thus failed in my case.So can you suggest me some topology then in which
> LHR and FHR can be same.
> > incoming traffic.Are these linux boxes?
> Yes I am using Linux boxes.I am using qemu virtual machines.
> > if so then compare the o/p
> > of /proc/net/ip_mr_cache, /proc/net/ip_mr_vif and /proc_net/ip_mr_rp
> > with that of the working config.
>
> The following are the output of the files you mentioned above.The
> scenario is h1 acting as sender and h2 acting as receiver.
>
> In /proc/net/ip_mr_cache
>         Group   origin  Iif     pkts    Bytes   Wrong Oifs
> u2      25000E1 0080000A -1     0       0       0
> t3      -       -       -       -       -       -
> t2      -       -       -       -       -       -
>
> In /proc/net/ip_mr_vif
> For t2 :-
> Interface  BytesIn   PktsIn   BytesOut  Flags    Local     Remote
> 0 eth0     0        0        0          00000    020000A   00000000
> 1 eth1     0        0        0          00000    030000A   00000000
> 2 pimreg   0        0        0          00004    020000A   00000000
>
> For t3
> Interface  BytesIn   PktsIn   BytesOut  Flags    Local     Remote
> 0 eth0     0         0        0         00000    040000A   00000000
> 1 eth1     0         0        0         00000    050000A   00000000
> 2 pimreg   0         0        0         00004    040000A   00000000
>
> For u2
> Interface  BytesIn   PktsIn   BytesOut  Flags    Local     Remote
> 0 eth0     0         0         0        00000    060000A   00000000
> 1 eth1     0         0         0        00000    070000A   00000000
> 2 pimreg   0         0         0        00004    060000A   00000000
>
> I didn't found any file named /proc/net/ip_mr_rp in all the three
> machines.
>
> >From /proc/net/ip_mr_cache we can predict that packets still are coming
> in from eth1, but because nobody wishes to receive them on other
> interfaces, they are dropped. When packets are dropped this way, a new
> entry is stored in a special queue of unresolved addresses. To indicate
> this is an unresolved address, the input interface is set to -1 and no
> output interfaces are listed.
> May be I am right in this case and please let me know if I am wrong.And
> if I am right please tell me what can be reason that packets are getting
> dropped and why no other interface is not willing to take input packets.
>
> I think this mail can give you a scenario what I am doing.Please let me
> know what else you want.
>
> Thanks again
> Akhil Nair
> >
> > Thanks,
> > Indranil
> >

---

From: Akhil Nair <[email-masked]>
Date: Thu, 07 Mar 2013 13:25:46 +0530

Hi Indranil,

In /proc/net/ip_mr_cache 

In /proc/net/ip_mr_vif 
For t2 :-

For t3

For u2

Thanks again
Akhil Nair

---

From: Akhil Nair <[email-masked]>
Date: Mon, 11 Mar 2013 15:05:32 +0530

Dear Indranil,
On Thu, 2013-03-07 at 20:50 +0530, Indranil Bhattacharya wrote:
> Hi Akhil,
> 
>            Can you configure all the devices in same vlan? That way
> you can select same device as FHR and LHR. What else did you mean by
> flat network? I though you are trying some sort of datacentre
> scenario. 
I am doing it on linux machine via qemu-virtual machine.In this scenario
I am using 10.0.0.0/0 network and every machine is on same network.

   mcast_sender					 mcast_receiver		
       |                                              |
       h1<-------->t2<-------->t3<------->u2<-------->h2

As you can see h1 is acting as multicast sender(FHR) and h2 is acting as
multicast receiver(LHR).

t2,t3 and t4 is acting as multicasted router on which pimd is
running.This setup is running as flat network i.e. all connected in same
network.

--------------------------------------
machine	| Interface name | Ip Address |
--------------------------------------
h1	| eth0 		 | 10.7.1.2   |
	| eth1		 | 10.0.0.1   |
--------------------------------------
t2	| eth0 		 | 10.0.0.2   |
	| eth1		 | 10.0.0.3   |
--------------------------------------
t3	| eth0  	 | 10.0.0.4   |
	| eth1   	 | 10.0.0.5   |
--------------------------------------
u2 	| eth0		 | 10.0.0.6   |
	| eth1  	 | 10.0.0.7   |
--------------------------------------
h2	| eth0 		 | 10.0.0.8   |
	| eth1 		 | 10.0.0.9   |
---------------------------------------

>            Can you check the o/p of the tables in normal networks?
> Also check the dmesg o/p. Is the FHR starting pim encapsulation?
I will check everything on normal network and let you know.And I didn't
get what is PIM encapsulation 
>         >         Where h1 and h2 are leaf node which is acting as
>         server and
>         >         client in
>         >         this case.I mean we are running a c program which
>         will send
>         >         the "Hello
>         >         as programmed in c program) and other machine will
>         receive
>         >         those
>         >         messages.On t2,t3 and u2 we are running pimd and t3
>         act as
>         >         rendezvous
>         >         point.
>         >
>         >         In normal network the scenario is working(All the
>         routers are
>         >         in
>         >         different network), but for the flat network(All the
>         routers
>         >         in the same
>         >         network),the above configuration is not working i.e.
>         we are
>         >         not able to
>         >         The 10.0.0.8 is the ip address of h2 when h2 is
>         acting as
>         >         sender and h1
>         >         acting as receiver.
>         >
>         >         I want to also know whether pimd wouldn't for flat
>         network(All
>         >         the
>         >         routers in same network)
>         >
>         >         Please help me in this scenario as I am stuck from a
>         long
>         >         time.
>         >         Thanks in advance
>         >
>         >         Regards
>         >         Akhil Nair
>         >

---

From: Indranil Bhattacharya <[email-masked]>
Date: Thu, 14 Mar 2013 12:54:40 +0530

Hi Akhil,

           It is strange that in ip_mr_cache you do not have any (*,G)
entry. Are you learning igmp group? You can check this via /proc/net/igmp.
FHR sends encapsulated pim packets to RP. That should be working in this
case because ip_mr_vif shows that you have created pimreg tunnel. But I see
that all the three routers have created pimreg tunnel. Since they are all
in the same network so only one of them should create this pimreg tunnel.
If your sender is also in 10.x.x.x network then same router should be both
FHR and LHR.

Thanks,
Indranil

---

From: Akhil Nair <[email-masked]>
Date: Fri, 15 Mar 2013 11:41:26 +0530

Dear Indranil,

On Thu, 2013-03-14 at 12:54 +0530, Indranil Bhattacharya wrote:
> entry. 
Thank you replying.The findings recognized by you was helpful for me.Yes
we are not having any entries in ip_mr_cache and the value of Iif is set
to -1(i.e. nobody there to accept the packets),Can you suggest some
remedy to this condition.
> Are you learning igmp group? You can check this via /proc/net/igmp.
> FHR sends encapsulated pim packets to RP. That should be working in
> this case because ip_mr_vif shows that you have created pimreg tunnel.
>  But I see that all the three routers have created pimreg tunnel.
> Since they are all in the same network so only one of them should
> create this pimreg tunnel.
Yes pimreg is been created in all the three machines.The interface
details is been attached to the mail.What I have seen is there is no
transmission or receive of packets via this interface.
>  If your sender is also in 10.x.x.x network then same router should be
> both FHR and LHR.
You mean to say in my case h1 can be act as both FHR and LHR.
> Indranil
Thanks, 
Akhil
>         >         Thank you for helping me and reading my concerns and
>         really
>         >         appreciate
>         >         it.
>         >         On Thu, 2013-03-07 at 11:33 +0530, Indranil
>         Bhattacharya
>         >         wrote:
>         >         > Hi,
>         >         >
>         >         >    Yes PIM works on flat network. You will have
>         the same
>         >         router
>         >         In my working scenario I am having LHR as t2 and FHR
>         as u2 and
>         >         some a
>         >         times its vice versa depends on who is acting as
>         server and
>         >         who is
>         >         client ( for eg h2 act as sender sometimes and
>         receiver
>         >         sometimes same
>         >         as with u2 ).So what you said that LHR and FHR
>         should be same
>         >         router is
>         >         thus failed in my case.So can you suggest me some
>         topology
>         >         then in which
>         >         LHR and FHR can be same.
>         >         >     The cache miss event is generated when there
>         is no
>         >         mroute for the
>         >         The following are the output of the files you
>         mentioned
>         >         above.The
>         >         Interface  BytesIn   PktsIn   BytesOut  Flags
>          Local
>         >         Remote
>         >         0 eth0     0        0        0          00000
>          020000A
>         >         00000000
>         >         1 eth1     0        0        0          00000
>          030000A
>         >         00000000
>         >         2 pimreg   0        0        0          00004
>          020000A
>         >         00000000
>         >
>         >         For t3
>         >         Interface  BytesIn   PktsIn   BytesOut  Flags
>          Local
>         >         Remote
>         >         0 eth0     0         0        0         00000
>          040000A
>         >         00000000
>         >         1 eth1     0         0        0         00000
>          050000A
>         >         00000000
>         >         2 pimreg   0         0        0         00004
>          040000A
>         >         00000000
>         >
>         >         For u2
>         >         Interface  BytesIn   PktsIn   BytesOut  Flags
>          Local
>         >         Remote
>         >         0 eth0     0         0         0        00000
>          060000A
>         >         00000000
>         >         1 eth1     0         0         0        00000
>          070000A
>         >         00000000
>         >         2 pimreg   0         0         0        00004
>          060000A
>         >         00000000
>         >
>         >         I didn't found any file named /proc/net/ip_mr_rp in
>         all the
>         >         three
>         >         machines.
>         >
>         >         >From /proc/net/ip_mr_cache we can predict that
>         packets still
>         >         are coming
>         >         in from eth1, but because nobody wishes to receive
>         them on
>         >         other
>         >         interfaces, they are dropped. When packets are
>         dropped this
>         >         way, a new
>         >         entry is stored in a special queue of unresolved
>         addresses. To
>         >         indicate
>         >         this is an unresolved address, the input interface
>         is set to
>         >         -1 and no
>         >         May be I am right in this case and please let me
>         know if I am
>         >         wrong.And
>         >         if I am right please tell me what can be reason that
>         packets
>         >         are getting
>         >         dropped and why no other interface is not willing to
>         take
>         >         input packets.
>         >
>         >         >         I have a flat network(all the routers in
>         the same
>         >         >         network),connected
>         >         >         linearly.
>         >         >
>         >         >
>         >         >         world" message over a multicasted network
>         (Sender ip
>         >         >         address:225.0.0.37