Subject: Re: [pim] draft-ietf-pim-explicit-tracking-10 wglc

From: Hitoshi Asaeda <[email-masked]>
Date: Mon, 2 Feb 2015 11:23:49 +0900

Dear all,

We already got consensus to support the IGMP/MLD explicit tracking
function in previous meetings and this mailing list, yet the WG
wants response again for the revised document, because of the
following reasons.

Firstly we needed to clarify the intended status; proposed standard.
Various reasons were advanced, but we consider the most important
one to be that the document describes function that is important for
the scalability of multicast networks, already widely implemented,
and which could seriously break IGMP/MLD if not implemented
correctly. In this respect, we see this work as similar to RFC4605
(IGMP/MLD proxy) which was also published as Standards Track.

There are many ways to implement this function (and, indeed, there
are many different existing implementations), we believe that there
is a core statement of what must and must not be done in order to
avoid breaking interoperability. That is, although there is no
description of on-wire behavior that must be implemented to achieve
interoperability, this document describes things that must be done
if this function is used and interoperability is to be retained.

We think that the revised document gives clearer sense about that.
In particular, we described;
- the description of the problem
- the objective and overview of the function
- statements about what implementations must/should do
- an example set of procedures that an implementation could follow
  if it wants to be sure of being safe.

This clarification work doesn't result in substantial changes to the
text from the previous version, but means some changes to the
sections, and a few clarifying sentences.
We hope that the revised document now is ready for the publication.

Sorry for asking again, but would you mind to respond your thoughts?

Regards,
--
Hitoshi Asaeda

2015/01/31 2:56, Stig Venaas <[email-masked]> wrote:

> I see I forgot to put a deadline! The last call ends in one
> week. That is, Friday February 6th.
> 
> No responses so far. If you believe this document should be
> published, please respond. No responses may indicate that
> no one cares about the document, is that the case?
> 
> If you don't want it published, or believe changes are needed,
> then also please respond.
> 
> Stig
> 
> On 1/23/2015 10:04 AM, Stig Venaas wrote:
>> This is a WGLC for draft-ietf-pim-explicit-tracking-10.
>> Available at
>> https://tools.ietf.org/html/draft-ietf-pim-explicit-tracking-10
>> 
>> We did a WGLC of revision 7 a long time ago. Based on that the draft was
>> revised and revision 8 was submitted to the IESG. There were however
>> several discusses and the changes were sufficiently big that it was
>> decided to return the document to the pim WG. Revision 10 hopefully
>> addresses the discusses.
>> 
>> To see the changes that were made you might see the diff here:
>> http://tools.ietf.org/rfcdiff?url1=draft-ietf-pim-explicit-tracking-08.txt&url2=draft-ietf-pim-explicit-tracking-10.txt
>> 
>> 
>> Please state whether you want this revision to be submitted to the IESG,
>> if you would like additional changes, or if you have any other concerns.
>> 
>> Stig
>> 
>> _______________________________________________
>> pim mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/pim
> 
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Sun, 8 Feb 2015 17:57:05 +0000

I support the publication of this document and its intended status of standard.

Best regards

Luis

-----Mensaje original-----
De: pim [mailto:[email-masked]] En nombre de Hitoshi Asaeda
Enviado el: lunes, 02 de febrero de 2015 3:24
Para: Stig Venaas
CC: [email-masked]
Asunto: Re: [pim] draft-ietf-pim-explicit-tracking-10 wglc

Dear all,

We already got consensus to support the IGMP/MLD explicit tracking function in previous meetings and this mailing list, yet the WG wants response again for the revised document, because of the following reasons.

Firstly we needed to clarify the intended status; proposed standard.
Various reasons were advanced, but we consider the most important one to be that the document describes function that is important for the scalability of multicast networks, already widely implemented, and which could seriously break IGMP/MLD if not implemented correctly. In this respect, we see this work as similar to RFC4605 (IGMP/MLD proxy) which was also published as Standards Track.

There are many ways to implement this function (and, indeed, there are many different existing implementations), we believe that there is a core statement of what must and must not be done in order to avoid breaking interoperability. That is, although there is no description of on-wire behavior that must be implemented to achieve interoperability, this document describes things that must be done if this function is used and interoperability is to be retained.

This clarification work doesn't result in substantial changes to the text from the previous version, but means some changes to the sections, and a few clarifying sentences.
We hope that the revised document now is ready for the publication.

Regards,
--
Hitoshi Asaeda

2015/01/31 2:56, Stig Venaas <[email-masked]> wrote:

> I see I forgot to put a deadline! The last call ends in one week. That
> is, Friday February 6th.
>
> No responses so far. If you believe this document should be published,
> please respond. No responses may indicate that no one cares about the
> document, is that the case?
>
> If you don't want it published, or believe changes are needed, then
> also please respond.
>
> Stig
>
>> We did a WGLC of revision 7 a long time ago. Based on that the draft
>> was revised and revision 8 was submitted to the IESG. There were
>> however several discusses and the changes were sufficiently big that
>> it was decided to return the document to the pim WG. Revision 10
>> hopefully addresses the discusses.
>>
>> http://tools.ietf.org/rfcdiff?url1=draft-ietf-pim-explicit-tracking-0
>> 8.txt&url2=draft-ietf-pim-explicit-tracking-10.txt
>>
>>
>> Please state whether you want this revision to be submitted to the
>> IESG, if you would like additional changes, or if you have any other concerns.
>>
>> Stig
>>

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Stig Venaas <[email-masked]>
Date: Thu, 26 Feb 2015 12:42:15 -0800

Hi

There was only one response to this WGLC and it supported publication.
I wish we got more engagement from you guys, but given that it passed
WGLC before and had good support in the past and that the draft should
now be in a better state, Mike and I think we should still request
publication. I'll take care of that now. If anyone has concerns, please
speak up.

Stig