Subject: [pim] RE： draft-ietf-pim-null-register-packing wglc

From: Yisong Liu<[email-masked]>
Date: 06 Feb 2020 10:21:17 +0800

I support the WGLC, and I think it should be moved forward.

Thanks

Yisong

发件人: Michael McBride

时间: 2020/01/31(星期五)08:40

收件人: pim;

主题: [pim] draft-ietf-pim-null-register-packing wglc 

We are going to start a new wglc for  https://www.ietf.org/id/draft-ietf-pim-null-register-packing-04.txt which was updated based upon comments during the first wglc (please see below). Since we received only one comment, and really no one showing wglc support, we are issuing a new wglc.  

Sometime over the next two weeks please let the wg know if it’s ready to be sent to the iesg for publication. 

thanks, 

mike 

From: pim <[email-masked]> On Behalf Of  Ramakrishnan Chokkanathapuram (ramaksun)
 Sent: Tuesday, October 15, 2019 11:37 AM
 To: Anish Peter <[email-masked]>; Mike McBride <[email-masked]>
 Cc: [email-masked]
 Subject: Re: [pim] draft-ietf-pim-null-register-packing wglc   

Hello Anish, 

Thanks for the comments.. I have my responses inline.. 

Thanks, 

Ramki 

From: pim <[email-masked]> on behalf of Anish Peter <[email-masked]>
 Date: Wednesday, September 4, 2019 at 7:20 AM
 To: Mike McBride <[email-masked]>
 Cc: "[email-masked]" <[email-masked]>
 Subject: Re: [pim] draft-ietf-pim-null-register-packing wglc  

Hi all,  

 Read through the draft. Have a few comments.   

  Section 2: The P bit can be taken as the LSB on the reserved ones. This would help this get inline with recommendations from PIM draft-ietf-pim-reserved-bits. 

       ##Ramki##  Not sure if using LSB or MSB has an advantage here. I am not sure if the pim-reserved-bits mandates such thing.   

  Instead of taking two new pim message types, the same pim register and register stop messages may be used. if this procedure can be followed.  

##Ramki## It will be good to have a new type. If we overload the same type it could happen that a router receives a message and think its malformed.  

a. RP discovers FHR capable of register bulking from the P bit.   

b. When RP responds to this register, it can set set a P bit in R-S message.   

c. Once FHR knows peer has bulking capability it can register packets with bulking  

d. For bulked register messages, RP can respond with bulked R-S messages.   

e. Packet format. I suggest overloading existing register and R-S packet can be done with out using two new packet formats.   

Register   

    0                   1                   2                   3 

    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 

   |PIM Ver| Type  |   Reserved    |           Checksum            | 

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 

   |B|N|P|                     Reserved2             |  S-g-count  | 

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 

   |                                                               | 

   .                     Multicast data packet                     . 

   |                                                               | 

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 

Register-stop  

    0                   1                   2                   3 

    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 

   |PIM Ver| Type  |  s-g-count  |P|           Checksum            | 

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 

   |             Group Address (Encoded-Group format)              | 

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 

   |            Source Address (Encoded-Unicast format)            | 

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+  

3. Anycast RP  

In my opinion, anycast RP procedures must be defined. Protocols typically should not  

ask for any kind of specific configurations or features on its peers.  

##Ramki## PIM Anycast RP is based on configuration. So not sure if this is a problem. 

4. Restart / feature disable  

An RP/FHR may restart or may have bullking turned on/off. In these scenarios the behavior must be defined.  

##Ramki## Yes. In such scenarios if an RP is downgraded from a version that was supporting packing to one that doesn’t support it, then RP will not respond to the packed registers. In such cases one could send an unpacked  register to RP to check if the RP supports it or fallback to data register and then discover the RP capability. 

Thanks, 

Anish   

 

On Thu, Aug 29, 2019 at 6:58 AM Mike McBride <[email-masked]> wrote:   

PIMers,
 
 Today begins a two week wglc for draft-ietf-pim-null-register-packing
 which was presented at 105 and hasn't changed since April. Please give
 it a read (it's a quick read) and provide feedback to this wg with
 support/no support of it's progressing to iesg.
 
 thanks,
 mike
 
 https://tools.ietf.org/html/draft-ietf-pim-null-register-packing-03
 
 _______________________________________________
 pim mailing list
 [email-masked]
 https://www.ietf.org/mailman/listinfo/pim

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Thu, 6 Feb 2020 02:41:15 +0000

Support moving this document to next step .

Mankamana
________________________________
From: pim <[email-masked]> on behalf of Yisong Liu <[email-masked]>
Sent: Wednesday, February 5, 2020 6:21:17 PM
To: Michael McBride <[email-masked]>
Cc: pim <[email-masked]>
Subject: [pim] RE： draft-ietf-pim-null-register-packing wglc

Thanks
Yisong

发件人: Michael McBride<mailto:[email-masked]>
时间: 2020/01/31(星期五)08:40
收件人: pim<mailto:[email-masked]>;
主题: [pim] draft-ietf-pim-null-register-packing wglc

thanks,

mike

Hello Anish,

Thanks,

Ramki

From: pim <[email-masked]<mailto:[email-masked]>> on behalf of Anish Peter <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, September 4, 2019 at 7:20 AM
To: Mike McBride <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [pim] draft-ietf-pim-null-register-packing wglc

Hi all,

  1.  Section 2: The P bit can be taken as the LSB on the reserved ones. This would help this get inline with recommendations from PIM draft-ietf-pim-reserved-bits.

  1.  Instead of taking two new pim message types, the same pim register and register stop messages may be used. if this procedure can be followed.

##Ramki## It will be good to have a new type.. If we overload the same type it could happen that a router receives a message and think its malformed.

e. Packet format.. I suggest overloading existing register and R-S packet can be done with out using two new packet formats.

Register

    0                   1                   2                   3

   |                                                               |

   |                                                               |

Register-stop

    0                   1                   2                   3

3.. Anycast RP

Thanks,

Anish

On Thu, Aug 29, 2019 at 6:58 AM Mike McBride <[email-masked]<mailto:mmcbride7@gmail..com>> wrote:

PIMers,

thanks,
mike

https://tools.ietf.org/html/draft-ietf-pim-null-register-packing-03<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-pim-null-register-packing-03&data=02%7C01%7Cmichael.mcbride%40futurewei.com%7Cc817a6aa05fd4fc3f50208d7519eb3d6%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637067614378147075&sdata=U4DlCfyCEacllFZQ6Hi8pIqzwhRvy2N2P2OcjYRRX9A%3D&reserved=0>

_______________________________________________
pim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pim<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim&data=02%7C01%7Cmichael.mcbride%40futurewei.com%7Cc817a6aa05fd4fc3f50208d7519eb3d6%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637067614378147075&sdata=NAHGy5MAsL4MB9XT%2Bw2pEfegIgTkOYRm4dFbqtnDpwI%3D&reserved=0>