Subject: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft

From: Michael McBride <[email-masked]>
Date: Tue, 22 Jun 2021 01:11:05 +0000

Hello all,

We are picking back up on this thread and using it as a call for adoption. During IETF 110 we had 9 in favor and 2 against adoption. Please read the draft: https://datatracker.ietf.org/doc/draft-mankamana-pim-bdr/ and indicate if you support adoption. 

If you don't support adoption please indicate whether you would support merging with draft-ietf-pim-dr-improvement or have other suggestions. The minutes are included below to show the options with progressing this draft.

thanks,
mike

draft-mankamana-pim-bdr - Mankamana
Lenny - this concept of priority and preemption is not unique to pim: vrrp, rsvp with backup paths, etc. can we leverage from those? Was it protocol level stuff or vendor implementations, those could be good examples. leave it up to implementations?
Alvaro - what has me confused is talking about two solutions that are basically the same thing. A good argument has been made on how the previous draft isn't needed. It would be nice if all the solutions was considered in one draft. We seem to be circuling around implementations, first resolve if we want single or multiple solutions. And then understand how they interact.
Stig - I agree. We initially only had one sticky DR in other draft, now we have two proposals. Do we actually need two solutions? Are there different use cases where one is better then the other?
Alvaro - I'm not advocating for one or two, the wg to decide. maybe we define multiple use cases. Needs more coordination. 
Stig - if the wg decides we only need one solution that covers all the use cases we probably only want to publish one of them.
Mike - some may want to have a hello option and others may not. And right now we only have one wg document. Let's say we do adopt this draft, should we hold off on progressing both documents until they are both progressed together?
Alvaro - That would be nice. they are not dependent on each other. they don't have to progress together. progressing close would be nice. 
Stig - we shouldn't progress any document until we carefully decide what solution is best or if we want both solutions. Lets compare both options.
Mike - let's poll for adoption. 
Stig - just because we adopt both documents doesn't mean we publish both documents.
Poll - 9 in favor and 2 against. Will take to the list.

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Mankamana Mishra (mankamis)
Sent: Wednesday, January 06, 2021 11:29 AM
To: Alvaro Retana <[email-masked]>; zhang.zheng <[email-masked]>; Stig Venaas <[email-masked]>
Cc: Sridhar Santhanam (sridsant) <[email-masked]>; [email-masked]
Subject: Re: [pim] Sticky PIM DR, should it be added to PIM DR improvements or different draft

Thanks every one for input. So I would update Sticky PIM DR without capability option in draft-mankamana-pim-bdr. Will ask for adoption in coming IETF. 

Mankamana 

On 12/4/20, 9:04 AM, "Alvaro Retana" <[email-masked]> wrote:

    On December 4, 2020 at 11:03:22 AM, Stig Venaas wrote:

    Stig:

    Hi!

    > Thoughts? Do you see this differently?

    I'm ok with whatever the WG decides, as long as the relationship and
    interaction between multiple potential solutions is clear.

    This is what I wrote in my review of draft-ietf-pim-dr-improvement-09:

    ===
    (2) As far as I can see draft-mankamana-pim-bdr has not been adopted yet.
        Assuming that is the plan, how would the two mechanisms interact?  Given
        that draft-mankamana-pim-bdr doesn't add options, and §5 says that if no
        options are received then the routers MUST use rfc7761, how does a router
        implementing this specification tell the difference?

        I realize that some of these questions may be better directed at
        draft-mankamana-pim-bdr, but because the WG agreed that a statement
        relating the two should be included in this document [1], then I'm
        asking now.  I would really like to understand what the WG expects.
    ===

    The WG is already aware of both drafts.  Assuming
    draft-mankamana-pim-bdr is adopted, I would prefer it if both
    solutions are progressed together (one or two documents is ok with
    me).

    Thanks!

    Alvaro.

_______________________________________________
pim mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C1371b163f51b4883950a08d8b279595e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637455581580050390%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=8Se09pvNO1NUcVnU4d6Vr9FzukkThNNRhypGbfu1SUM%3D&amp;reserved=0

---

From: Michael McBride <[email-masked]>
Date: Mon, 28 Jun 2021 22:12:31 +0000

Hello again,

It's been a week with no response to this adoption call. We will give it another week and if still no response we won't adopt at this time.

thanks,
mike

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Michael McBride
Sent: Monday, June 21, 2021 6:11 PM
To: [email-masked]
Subject: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft

Hello all,

We are picking back up on this thread and using it as a call for adoption. During IETF 110 we had 9 in favor and 2 against adoption. Please read the draft: https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-mankamana-pim-bdr%2F&amp;data=04%7C01%7Cmmcbride%40futurewei.com%7C067e47a1b80941d12e0408d9351aa874%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637599210899942214%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=%2BdhjjMXC5bHiaYai9if7HSE0N%2BRlwdEFubLfz%2FlKODo%3D&amp;reserved=0 and indicate if you support adoption. 

thanks,
mike

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Mankamana Mishra (mankamis)
Sent: Wednesday, January 06, 2021 11:29 AM
To: Alvaro Retana <[email-masked]>; zhang.zheng <[email-masked]>; Stig Venaas <[email-masked]>
Cc: Sridhar Santhanam (sridsant) <[email-masked]>; [email-masked]
Subject: Re: [pim] Sticky PIM DR, should it be added to PIM DR improvements or different draft

Mankamana 

    Stig:

    Hi!

    ===

    Thanks!

    Alvaro.

_______________________________________________
pim mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim&amp;data=04%7C01%7Cmmcbride%40futurewei.com%7C067e47a1b80941d12e0408d9351aa874%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637599210899942214%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=XRbjNZlVlm3isR%2F7NYbb7kOrAvy8Cv8%2BkpG7sDrE38I%3D&amp;reserved=0
_______________________________________________
pim mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim&amp;data=04%7C01%7Cmmcbride%40futurewei.com%7C067e47a1b80941d12e0408d9351aa874%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637599210899942214%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=XRbjNZlVlm3isR%2F7NYbb7kOrAvy8Cv8%2BkpG7sDrE38I%3D&amp;reserved=0

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 28 Jun 2021 22:48:02 +0000

Hi Mike, 
I support WG adoption. Although the role of the DR is different, the concept of a BDR to improvement convergence in OSPF has proved to be quite useful. 
Thanks,
Acee

On 6/28/21, 6:18 PM, "pim on behalf of Michael McBride" <[email-masked] on behalf of [email-masked]> wrote:

    Hello again,

    thanks,
    mike

    -----Original Message-----
    From: pim <[email-masked]> On Behalf Of Michael McBride
    Sent: Monday, June 21, 2021 6:11 PM
    To: [email-masked]
    Subject: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft

    Hello all,

    thanks,
    mike

    -----Original Message-----
    From: pim <[email-masked]> On Behalf Of Mankamana Mishra (mankamis)
    Sent: Wednesday, January 06, 2021 11:29 AM
    To: Alvaro Retana <[email-masked]>; zhang.zheng <[email-masked]>; Stig Venaas <[email-masked]>
    Cc: Sridhar Santhanam (sridsant) <[email-masked]>; [email-masked]
    Subject: Re: [pim] Sticky PIM DR, should it be added to PIM DR improvements or different draft

    Mankamana 

        Stig:

        Hi!

        ===

        Thanks!

        Alvaro.

    _______________________________________________
    pim mailing list
    [email-masked]
    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim&amp;data=04%7C01%7Cmmcbride%40futurewei.com%7C067e47a1b80941d12e0408d9351aa874%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637599210899942214%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=XRbjNZlVlm3isR%2F7NYbb7kOrAvy8Cv8%2BkpG7sDrE38I%3D&amp;reserved=0
    _______________________________________________
    pim mailing list
    [email-masked]
    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim&amp;data=04%7C01%7Cmmcbride%40futurewei.com%7C067e47a1b80941d12e0408d9351aa874%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637599210899942214%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=XRbjNZlVlm3isR%2F7NYbb7kOrAvy8Cv8%2BkpG7sDrE38I%3D&amp;reserved=0
    _______________________________________________
    pim mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/pim

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Mon, 28 Jun 2021 23:08:55 +0000

Support the adoption .

From: pim <[email-masked]> on behalf of Michael McBride <[email-masked]>
Date: Monday, June 28, 2021 at 3:18 PM
To: [email-masked] <[email-masked]>
Subject: Re: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft
Hello again,

thanks,
mike

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Michael McBride
Sent: Monday, June 21, 2021 6:11 PM
To: [email-masked]
Subject: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft

Hello all,

thanks,
mike

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Mankamana Mishra (mankamis)
Sent: Wednesday, January 06, 2021 11:29 AM
To: Alvaro Retana <[email-masked]>; zhang.zheng <[email-masked]>; Stig Venaas <[email-masked]>
Cc: Sridhar Santhanam (sridsant) <[email-masked]>; [email-masked]
Subject: Re: [pim] Sticky PIM DR, should it be added to PIM DR improvements or different draft

Mankamana

    Stig:

    Hi!

    ===

    Thanks!

    Alvaro.

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 28 Jun 2021 21:10:01 -0400

Hi Mike

I support WG adoption.  I think this draft as well as the sticky DR draft
have their own merits and use cases to improve DR convergence.  They both
should be advanced as they both can be beneficial to operators.

Kind Regards

Gyan

On Mon, Jun 28, 2021 at 7:09 PM Mankamana Mishra (mankamis) <mankamis=
[email-masked]> wrote:

> Support the adoption .
>
>
>
> *From: *pim <[email-masked]> on behalf of Michael McBride <
> [email-masked]>
> *Date: *Monday, June 28, 2021 at 3:18 PM
> *To: [email-masked] <[email-masked]>
> *Subject: *Re: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM
> DR, should it be added to PIM DR improvements or different draft
>
> Hello again,
>
> It's been a week with no response to this adoption call. We will give it
> another week and if still no response we won't adopt at this time.
>
> thanks,
> mike
>
> Subject: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR,
> should it be added to PIM DR improvements or different draft
>
> Hello all,
>
> We are picking back up on this thread and using it as a call for adoption.
> During IETF 110 we had 9 in favor and 2 against adoption. Please read the
> draft:
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-mankamana-pim-bdr%2F&amp;data=04%7C01%7Cmmcbride%40futurewei.com%7C067e47a1b80941d12e0408d9351aa874%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637599210899942214%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=%2BdhjjMXC5bHiaYai9if7HSE0N%2BRlwdEFubLfz%2FlKODo%3D&amp;reserved=0
> and indicate if you support adoption.
>
> If you don't support adoption please indicate whether you would support
> merging with draft-ietf-pim-dr-improvement or have other suggestions. The
> minutes are included below to show the options with progressing this draft.
>
> thanks,
> mike
>
>
> Lenny - this concept of priority and preemption is not unique to pim:
> vrrp, rsvp with backup paths, etc. can we leverage from those? Was it
> protocol level stuff or vendor implementations, those could be good
> examples. leave it up to implementations?
> Alvaro - what has me confused is talking about two solutions that are
> basically the same thing. A good argument has been made on how the previous
> draft isn't needed. It would be nice if all the solutions was considered in
> one draft. We seem to be circuling around implementations, first resolve if
> we want single or multiple solutions. And then understand how they interact.
> Stig - I agree. We initially only had one sticky DR in other draft, now we
> have two proposals. Do we actually need two solutions? Are there different
> use cases where one is better then the other?
> Alvaro - I'm not advocating for one or two, the wg to decide. maybe we
> define multiple use cases. Needs more coordination.
> Stig - if the wg decides we only need one solution that covers all the use
> cases we probably only want to publish one of them.
> Mike - some may want to have a hello option and others may not. And right
> now we only have one wg document. Let's say we do adopt this draft, should
> we hold off on progressing both documents until they are both progressed
> together?
> Alvaro - That would be nice. they are not dependent on each other. they
> don't have to progress together. progressing close would be nice.
> Stig - we shouldn't progress any document until we carefully decide what
> solution is best or if we want both solutions. Lets compare both options.
> To: Alvaro Retana <[email-masked]>; zhang.zheng <
> [email-masked]>; Stig Venaas <[email-masked]>
> Thanks every one for input. So I would update Sticky PIM DR without
> capability option in draft-mankamana-pim-bdr. Will ask for adoption in
> coming IETF.
>
> Mankamana
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: <[email-masked]>
Date: Tue, 29 Jun 2021 10:12:47 +0800 (CST)

Support the adoption of this draft. 

The co-existence of the function defined in this draft and the function defined in the PIM DR Improvement draft still needs to be discussed. 

But it can be improved in future version.

And as the co-author of the PIM DR Improvements draft, it's OK to merge this draft with the PIM DR Improvement draft or not.

Thanks,

Sandy

原始邮件

发件人：MichaelMcBride
收件人：[email-masked];
日 期 ：2021年06月22日 09:11
主 题 ：[pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft

Hello all,

 
thanks,
mike

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Mankamana Mishra (mankamis)
Sent: Wednesday, January 06, 2021 11:29 AM
To: Alvaro Retana <[email-masked]>; zhang.zheng <[email-masked]>; Stig Venaas <[email-masked]> 
Cc: Sridhar Santhanam (sridsant) <[email-masked]>; [email-masked]
Subject: Re: [pim] Sticky PIM DR, should it be added to PIM DR improvements or different draft

Mankamana  

    Stig:
 
    Hi!

 
 
    ===

 
    Thanks!
 
    Alvaro.

---

From: "Anuj Budhiraja (abudhira)" <[email-masked]>
Date: Tue, 29 Jun 2021 20:32:54 +0000

I support the adoption.

- Anuj

On 6/28/21, 3:18 PM, "pim on behalf of Michael McBride" <[email-masked] on behalf of [email-masked]> wrote:

    Hello again,

    thanks,
    mike

    -----Original Message-----
    From: pim <[email-masked]> On Behalf Of Michael McBride
    Sent: Monday, June 21, 2021 6:11 PM
    To: [email-masked]
    Subject: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft

    Hello all,

    thanks,
    mike

    -----Original Message-----
    From: pim <[email-masked]> On Behalf Of Mankamana Mishra (mankamis)
    Sent: Wednesday, January 06, 2021 11:29 AM
    To: Alvaro Retana <[email-masked]>; zhang.zheng <[email-masked]>; Stig Venaas <[email-masked]>
    Cc: Sridhar Santhanam (sridsant) <[email-masked]>; [email-masked]
    Subject: Re: [pim] Sticky PIM DR, should it be added to PIM DR improvements or different draft

    Mankamana 

        Stig:

        Hi!

        ===

        Thanks!

        Alvaro.