Subject: Re: [pim] comments on draft-ietf-pim-null-register-packing-09

From: Stig Venaas <[email-masked]>
Date: Fri, 10 Sep 2021 13:33:03 -0700

Hi Sandy and authors

Thanks a lot for your input Sandy. I don't think there has been any
follow-up by the authors.

Authors, can you please respond to this? It looks like some changes
may be needed, or do you believe the latest version addresses any
concerns?

My understanding is that packing only applies to null-register, while
it makes sense to use the P-bit also in data registers.

Thanks,
Stig

On Sun, May 23, 2021 at 7:52 PM <[email-masked]> wrote:
>
> Hi authors,
>
> Thank you for the 09 version update! The version makes more clear about the function.
>
> I have some comments for the new 09 version:
>
> 1. In the combinations 1 in section 5, there is
>
> "As specified in [[RFC7761]], the DR sends PIM Null-Register
>
>           messages towards the RP when a new source is detected."
>
> I noticed that the "Register messages" has been changed to "Null-Register messages". The change seems like to be confusion.
>
> Because "when a new source is detected", the DR sends data-register to the RP other than null-register.
>
> After the RP builds the tree to the DR, RP can set the P-bit in the register-stop message sent to the DR, that is the RP can set the P-bit when it starts to send register-stop to the DR.
>
> So IMO in this sentence, the "PIM Null-Register" may go back to "PIM register".
>
> 2. In case the RP enables the packed capability and works well, but the network manager disables the packed capability in the RP. During the switch, there may be two ways:
>
> One is that the RP can still parse the packed null-register messages, but it sends the register-stop message without P-bit set. Then the DR sends the unpacked null-register to the RP.
>
> The other is that the RP stops to parse the packed null-register messages right now, the DR may not receive the register-stop message with P-bit set/clear from the RP, then the DR may send the new un-packed register message after the timer expired and then receives the register-stop message with P-bit clear from the RP.
>
> I am not sure which one is prefer in this draft. IMO it may be better to add some description about the switch issue.
>
> Best regards,
>
> Sandy
>
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim

---

From: "Ananya Gopal (ananygop)" <[email-masked]>
Date: Fri, 10 Sep 2021 20:38:30 +0000

Hi Stig and WG,

I will post the latest version by end of day tomorrow.

Thanks,
Ananya

From: Stig Venaas <[email-masked]>
Date: Friday, September 10, 2021 at 1:33 PM
To: zhang.zheng <[email-masked]>
Cc: [email-masked] <[email-masked]>, Ramakrishnan Chokkanathapuram Sundaram (ramaksun) <[email-masked]>, [email-masked] <[email-masked]>, Ananya Gopal (ananygop) <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [pim] comments on draft-ietf-pim-null-register-packing-09
Hi Sandy and authors

Thanks,
Stig

---

From: <[email-masked]>
Date: Thu, 16 Sep 2021 09:20:09 +0800 (CST)

Hi Stig, authors, 
I read the new version of draft. And my comments in May has been addressed. 
Thanks authors! I support the advancement of this draft. 
Thanks,
Sandy
------------------原始邮件------------------
发件人：StigVenaas
收件人：张征00007940;
抄送人：[email-masked];Ramakrishnan Chokkanathapuram (ramaksun);[email-masked];[email-masked];[email-masked];
日 期 ：2021年09月11日 04:33
主 题 ：Re: [pim] comments on draft-ietf-pim-null-register-packing-09
Hi Sandy and authors
Thanks a lot for your input Sandy. I don't think there has been any
follow-up by the authors.
Authors, can you please respond to this? It looks like some changes
may be needed, or do you believe the latest version addresses any
concerns?
My understanding is that packing only applies to null-register, while
it makes sense to use the P-bit also in data registers.
Thanks,
Stig

---

From: "Ananya Gopal (ananygop)" <[email-masked]>
Date: Fri, 17 Sep 2021 17:36:54 +0000

Hi WG,

Thank you Sandy for your detailed review & comments. I request other members to kindly take a look as well:

https://datatracker.ietf.org/doc/draft-ietf-pim-null-register-packing/10/

Thanks,
Ananya

From: [email-masked] <[email-masked]>
Date: Wednesday, September 15, 2021 at 6:20 PM
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>, Ramakrishnan Chokkanathapuram Sundaram (ramaksun) <[email-masked]>, [email-masked] <[email-masked]>, Ananya Gopal (ananygop) <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re:[pim] comments on draft-ietf-pim-null-register-packing-09
Hi Stig, authors,
I read the new version of draft. And my comments in May has been addressed.
Thanks authors! I support the advancement of this draft.
Thanks,
Sandy
------------------原始邮件------------------
发件人：StigVenaas
收件人：张征00007940;

---

From: Michael McBride <[email-masked]>
Date: Tue, 21 Sep 2021 05:40:55 +0000

Hi Ananya,

Thank you for addressing Sandy’s comments. I’ll request an early rtgdir review, and will review again myself, before sending back to Alvaro.

mike

From: pim <[email-masked]> On Behalf Of Ananya Gopal (ananygop)
Sent: Friday, September 17, 2021 10:37 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [pim] comments on draft-ietf-pim-null-register-packing-10

Hi WG,

https://datatracker.ietf.org/doc/draft-ietf-pim-null-register-packing/10/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-pim-null-register-packing%2F10%2F&data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C04e2cf1704014d552a8908d97a01cb7d%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637674970424370796%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=K9Z1RphPrGylDqhP2Y12izArhjMsf9ni2JFni3%2BJSRY%3D&reserved=0>

Thanks,
Ananya

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, September 15, 2021 at 6:20 PM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Ramakrishnan Chokkanathapuram Sundaram (ramaksun) <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Ananya Gopal (ananygop) <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re:[pim] comments on draft-ietf-pim-null-register-packing-09
Hi Stig, authors,
I read the new version of draft. And my comments in May has been addressed.
Thanks authors! I support the advancement of this draft.
Thanks,
Sandy
------------------原始邮件------------------
发件人：StigVenaas
收件人：张征00007940;
抄送人：[email-masked];Ramakrishnan<mailto:[email-masked];Ramakrishnan> Chokkanathapuram (ramaksun);[email-masked];[email-masked];[email-masked];
日 期 ：2021年09月11日 04:33
主 题 ：Re: [pim] comments on draft-ietf-pim-null-register-packing-09
Hi Sandy and authors
Thanks a lot for your input Sandy. I don't think there has been any
follow-up by the authors.
Authors, can you please respond to this? It looks like some changes
may be needed, or do you believe the latest version addresses any
concerns?
My understanding is that packing only applies to null-register, while
it makes sense to use the P-bit also in data registers.
Thanks,
Stig
On Sun, May 23, 2021 at 7:52 PM <[email-masked]<mailto:[email-masked]>> wrote:
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/pim<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim&data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C04e2cf1704014d552a8908d97a01cb7d%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637674970424380791%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=XJ4j6plmqH6Yqk3OP4GOd91cER%2BtoRIuyPzhyvDgles%3D&reserved=0>