Subject: Re: CRL version field confusion

From: Martin Lindström <[email-masked]>
Date: Tue, 23 Mar 1999 16:14:20 +0100

Regarding the issue with the slightly different approaches of
coding the CRL version field.

"Both sides" have now stated an explanation of why/why not the
CRL version field should be present in a CRL containing only
non-critical extensions.
However, the fact remains that a CA following X.509 may be
imcompatible with a client processing CRLs according to rfc2459.
This is of course not desirable in any way and I'm a bit surprised
that no effort in resolving the ambiguity was made.

Clearly, rfc2459 should be compatible with X.509, or?

Comments?

Regards Martin Lindström

______________________________________
         Entegrity Solutions

  Martin Lindström
  Senior Systems Engineer 

  Finlandsgatan 60 
  S-164 74 Kista, Sweden
  Direct: +46-(0)8-477-7735
  Fax:    +46-(0)8-477-7731
  Cell:   +46-(0)70-483-0024
______________________________________

---

From: Stephen Kent <[email-masked]>
Date: Tue, 23 Mar 1999 16:40:53 -0500

Martin,

>Clearly, rfc2459 should be compatible with X.509, or?

RFC 2459 differs from X.509 in several minor respects already, e.g., in
terms of what extensions are marked critical, etc.  This is another minor
difference.  I do not currently see us changing the RFC, since we had good
reasons for our decision, and I understand the points Hoyt made as well.

steve