Subject: RE: A web of directories

From: "Bob Jueneman" <[email-masked]>
Date: Tue, 02 Mar 1999 09:20:42 -0700

Phillip,

Please pardon my ignorance regarding DNS, but perhaps you could answer some questions:

1.  How widely is the SRV function deployed?  Is it standardized (RFC ?), what vendors support it, etc., etc?

2.  Can the SRV deal with multiple protocols?  If it doesn't already, could it be extended? In particular, for what I am trying to do to implement a web of directories, I would like to supply a DNS name for a directory, and allow the clients to find out and/or negotiate what directory access protocol they use, e.g., LDAP, DAP, NDAP (NDS), HTTP, FTP, or whatever.   Would this work?

Bob

>>> "Phillip M Hallam-Baker" <[email-masked]> 03/01/99 09:08AM >>>
Steve,

	That is exactly what the SRV record that I have been going 
on about for a year now does.

	It was deployed in the Vixie BIND code about 3 years back.

		Phill

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf
> Of Stephen Kent
> Sent: Wednesday, February 24, 1999 12:24 PM
> To: Larry Layten
> Cc: Bob Jueneman; [email-masked] 
> Subject: RE: A web of directories
> 
> 
> Larry,
> 
> >For e-mail certificates, can't you use the domain from
> >the internet e-mail address to point you to a DNS server
> >And can't that in turn point you to the correct LDAP directory.
> 
> One can certainly look up the user's DNS server based on e-mail address,
> but we don't have a record format in the DNS that points to an LDAP
> directory as a result.  One could define such a record type, though.
> 
> Steve
>

---

From: Michael Helm <[email-masked]>
Date: Tue, 02 Mar 1999 10:32:54 -0800

"Bob Jueneman" writes:
> 1.  How widely is the SRV function deployed?  Is it standardized
> (RFC ?), what vendors support it,

> 	It was deployed in the Vixie BIND code about 3 years back.

It's certainly in bind 8.x.
Also, it is essential for NT 5 / Windows 2000 so it must be in
microsoft's DNS.

(from the rfc index)

2052 A DNS RR for specifying the location of services (DNS SRV). A.
     Gulbrandsen, P. Vixie. October 1996. (Format: TXT=19257 bytes)
     (Status: EXPERIMENTAL)

http://www.es.net/pub/rfcs/rfc2052.txt
& the usual places

> 2.  Can the SRV deal with multiple protocols?  If it doesn't
> already, could it be extended? In particular, for what I am trying to
> negotiate what directory access protocol they use, e.g., LDAP, DAP,
> NDAP (NDS), HTTP, FTP, or whatever.  Would this work?  

Absolutely -- at least according to the spec.  See the rfc.
Don't have any practical experience with it.

Some examples from the RFC:

   Here is the format of the SRV RR, whose DNS type code is 33:
 
        Service.Proto.Name TTL Class SRV Priority Weight Port Target

Introductory example
 
   When a SRV-cognizant web-browser wants to retrieve
 
      http://www.asdf.com/
 
   it does a lookup of
 
      http.tcp.www.asdf.com

More complex ones in the RFC itself.   Obviously your client application
would have to handle sorting thru whatever the SRV returned if 
you get multiple hits for a protocol, somewhat like the way MX
records are handled.