Subject: What's the relation between CRT and OCSP ?

From: "Binken, Rens" <[email-masked]>
Date: Thu, 4 Feb 1999 17:11:11 +0100

LS,

I've been reading about Certificate revocation trees (CRT) and Online
Certificate Status Protocol (OCSP). I can see that both mechnism help to get
more timely revocation information. My questions are : What's the relation
between CRTs and OCSP ? 
Do you need the OCSP protocol to check CRTs ? Or are these two totally
different mechnism for checking validity ?

Regards,

L.S. Binken

kpmg TTP-Services
Burgemeester Rijnderslaan 20, 1185 MC Amstelveen
P.O. Box 74555, 1070 DC Amsterdam, the Netherlands
tel:	+31-20-656 83 83
fax:	+31-20-656 83 88
e-mail: [email-masked] 
X400:c=NL;a=CONCERT;p=KPMG;s=Binken;g=Rens;
Visit our solutioncentre:	http://www.solutioncentre.nl/

**********************************************************************
This email and any files transmitted with it are confidential and 
intended solely for the use of the individual or entity to whom they   
are addressed. If you have received this email in error please notify 
the system manager.

This footnote also confirms that this email message has been swept by 
MIMEsweeper for the presence of computer viruses.

www.mimesweeper.com
**********************************************************************

---

From: "Ambarish Malpani" <[email-masked]>
Date: Thu, 4 Feb 1999 09:41:57 -0800

Hi Rens,
    OCSP and CRT are two different protocols to check the status
of a certificate. OCSP is proceeding on the standards track
and (hopefully) will become a standard soon.

CRTs are another mechanism to provide status information on
certificates. It was invented by us (at ValiCert) and we have
some patent applications regarding it. They can either use a
query in a custom format, or an OCSP query.

There are performance and scalabity differences between the
two protocols, which I would be happy to explain if you are
interested (I am not sure the PKIX mailing list would be the
right place to do so).

Hope this helps,
Regards,
Ambarish

---------------------------------------------------------------------
Ambarish Malpani
Architect					         650.567.5457
ValiCert, Inc.				        [email-masked]
1215 Terra Bella Ave.		              http://www.valicert.com
Mountain View, CA 94043-1833

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of Binken, Rens
> Sent: Thursday, February 04, 1999 8:11 AM
> To: [email-masked]
> Subject: What's the relation between CRT and OCSP ?
> 
> 
> LS,
>