Subject: Re: PKIX Path determination/construction/processing and AKIpointer hanging

From: "Peter Williams" <[email-masked]>
Date: Fri, 5 Mar 1999 15:47:24 -0600

>Now, what do you mean by a hanging AKI backpointer?  If a cert contains
>an AKI extension and its parent cert does not contain an SKI extension
>with the same value, then the CA is not in conformance with Section
>4.2.1.x.  That is a serious error on the part of the CA, and calls into
>question the CA's competence and attention to detail.  But if despite
>the bad or missing information in the key identifier extensions, the RP
>is able to find (perhaps by trial and error) an issuer cert which can
>be used to verify the signature on the issued cert, then I agree that
>an otherwise valid path may still be considered valid.
>

Abstracting, the general rule is, then, if a relying party system
detects that a CA is non-conforming with PKIX
in matters of cert format, extension schema, criticality, etc, this fact
is not a basis by PKIX-implementors to designate 
such a certificate as invalid, nor designate
the chain on which it is a member as similarly invalid, 
nor affect  the security protocol event which
is relying on the cert path (such as an SSL connection
handshake, or S/MIME signature verification).

Therefore, noone should code  up their ASN.1 compilers with
ASN.1 value constraints which impose the value conditions
of 2459's text (e.g. rejecting a cert with a  critical
AKI criticality bit, say, during type/value checking).

If anyone doing 2459 detects SKI != AKI, they should not reject
the cert path.

Agreed?

Peter.

NB. I indicated to Bob, one set of PKIX-QC thoughts which
flowed from this issue. The other issue is one
of assumptions: ValiCert is a validation authority (that is, 
one who does authoritative certificate validation, as
defined in the X.509 PDAM). We cannot assume
that PKIX-conforming chains will get sent to us, by
any means. Neither should we, in minimal
PKIX service quality mode, necessarily limit 
our path discovery services to paths produced
using certs from conforming CAs, unless
the relying party customer so designates 
PKIX conformance as part of its risk factor screen.

---

From: Brian Korver <[email-masked]>
Date: Fri, 05 Mar 1999 17:50:30 -0800

Peter Williams wrote:
[snip]
> If anyone doing 2459 detects SKI != AKI, they should not reject

Agreed.