Subject: RE: Usage of CRL Issuing Distribution Point

From: Trevor Freeman <[email-masked]>
Date: Fri, 12 Feb 1999 11:07:05 -0800

When a CA publishes a CRL, the CA should put sufficient information into the
CRL to unambiguous identify its intent. If you CA is only generating one CDP
per signing key, then issuer and key identity is sufficient. The key
identity in AKI is just a hint to enable you to pick the right CRL first for
you signature check. It also helps if you want to cache CRL locally. Issuing
CDP is required once a CA starts to partition the CRL based e.g. on reason
code or subject type. The current RFC does not permit CRL to be partitioned
on the basis other attributes such as serial number. The Issuing CDP of a
CRL tells you by a piece of signed data, that out of all the CRL that are
published by the CA and current what exactly was the intent of the CA when
it created this CRL.  Trusting where you find the CRL to give you this
information is not good practice. Distribution mechanisms such as
directories and url's cannot be trusted.

-----Original Message-----
From: Ambarish Malpani [mailto:[email-masked]]
Sent: Wednesday, February 10, 1999 12:11 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: Usage of CRL Issuing Distribution Point

Hi Pau,
    If your CA is "really" using CRLDP, then you need to be
careful when you say you have "the" CRL. Part of the point of
CRLDP (as opposed to simple CRLs), is, that a CA can now issue
multiple little CRLs, depending on how it decides to partition
revocation data.

For example, it may create one CRLDP for certificates with serial
numbers between 1-100. Another one for certs from 101-200 and so
on.

Also, it may decide to issue multple potential CRLs on which
a particular cert may occur - for example, there may be one CRL
for key compromise (which is updated very, very frequently), another
for lost keys, etc.

So, there isn't necessarily a single CRL you need to look at.

If your CA decides to use CRLDP in its simplest form and just
issue a single CRL that contains all revocation data, you
still need to be careful. A CRL contains 2 times - a thisUpdate
and a nextUpdate, where the thisUpdate is the time at which
the CRL was issued, while the nextUpdate is the time
at or *before* which the next CRL will be issued.

This means that there is *no* guarantee that the CRL you have
from the CA is the latest one it issued. So depending on the
sensitivity of the transaction, you may decide to go check
the CA for a newer CRL, use the cached CRL, or wait till
nextUpdate is in the past, go grab a new CRL from the CA at
that time and verify that the cert is not on that CRL.

Hope this helps,
Regards,
Ambarish

P.S. To figure out which CRLs apply to the certificate you are
trying to check, you normally look for the path to the CRLs in
the certificate. Once you retrieve the CRL, you need to check
that the CRL has the same name as the one you thought you
were retrieving. So the extension you look for in the cert
is the one with OID id-ce-cRLDistributionPoints, while the name
of the CRL can be found in the CRL (if present), with the
OID id-ce-issuingDistributionPoint.

---------------------------------------------------------------------
Ambarish Malpani
Architect					         650.567.5457
ValiCert, Inc.				        [email-masked]
1215 Terra Bella Ave.		              http://www.valicert.com
Mountain View, CA 94043-1833

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of [email-masked]
> Sent: Monday, February 08, 1999 8:55 AM
> To: [email-masked]
> Subject: Usage of CRL Issuing Distribution Point
> 
> 
> Hellow, I am a new comer to PKIX.
> I have a question about the usage of the
> CRL distribution point:
> 
> If I have the CRL, then do I still need to know
> the distribution point ? Is this entension intended
> for furture retrival of CRL's (and of course, to indicate
> why the cert's in the list are revoked.) ?
> 
> If I don't know the distribution point, is there a
> standard/suggested way to learn it without getting the
> CRL ?
> 
> Thanks in advance.
> 
> 
> Regards, Pau-Chen
>

---

From: Alex Deacon <[email-masked]>
Date: Fri, 12 Feb 1999 12:40:23 -0800

Trevor, 

Could you specify what document states that it is not permitted for CRL's to
be partitioned on the basis of other attributes such as serial number?  I
cant recall ever seeing such a statement in either PKIX Part 1 or X.509.

Thanks
Alex

> From: Trevor Freeman [mailto:[email-masked]]
> Sent: Friday, February 12, 1999 11:07 AM
> To: 'Ambarish Malpani'; [email-masked]
> Cc: [email-masked]

---

From: Trevor Freeman <[email-masked]>
Date: Fri, 12 Feb 1999 12:47:05 -0800

What extensions in these documents provide for other attributes to be used
to partition CRLs? 
-----Original Message-----
From: Alex Deacon [mailto:[email-masked]]
Sent: Friday, February 12, 1999 12:40 PM
To: Trevor Freeman
Cc: [email-masked]'
Subject: RE: Usage of CRL Issuing Distribution Point

Trevor, 

Thanks
Alex

---

From: [email-masked]
Date: Fri, 12 Feb 1999 17:47:02 -0500

Is there some confusion here between partitioning CRL's by certificate
attributes, which doesn't seem to be supported, and assigning new
certificates to CRL Distribution Points, which seems to be an internal
function of the CA with few rules except that the ID of the CRL
Distribution Point must go into the appropriate extension?

---

From: Santosh Chokhani <[email-masked]>
Date: Tue, 16 Feb 1999 19:05:57 -0500

Please see the text for CRL processing in Annex M of the September 1998
PDAM to X.509.  It clarifies lots of issues in terms of how to determine
whether a CRL is appropriate, which has been the theme of this thread
for a while now.

I have also suggested that the Annex should be part of the pkix document
series or tied to pkix part 1 somehow.

> From:	Trevor Freeman [SMTP:[email-masked]]
> Sent:	Tuesday, February 16, 1999 6:53 PM
> To:	'Stephen Kent'
> Cc:	[email-masked]'
> As with a lot of threads on the list, there have been some
> miss-interpretations based on some terms having different meaning to
> different people. Let me return to the original point.
> It is important for the client to understand whether it is dealing
> with a
> monolithic CRL or multiple CRL's. In the former case once it finds a
> current
> CRL signed by the CA, it knows it is sufficient. Here the AKI
> extension is a
> useful hint, but the signature check is conclusive proof the client
> has
> found the right CRL. In the latter case there will be multiple CRL's
> all of
> which current, and signed by the same CA. In these instances it is
> dangerous
> for the CA to assume the reliability of the CRL distribution
> mechanism, and
> therefore there is a need to include unambiguous information in the
> Certificate AND CRL to inform the client if the CRL is partitioned, or
> not
> where are these CRL(s) and it needs to know  from the CRL when it has
> found
> them. Our in other words finding a object signed by the right
> authority at
> the end of a URL or in a directory is not enough. 
> 
> From: Stephen Kent [mailto:[email-masked]]
> Sent: Tuesday, February 16, 1999 7:46 AM
> To: Trevor Freeman
> Cc: [email-masked]'
> I am puzzled by your statements. It is true that CRLs have some
> facilities
> to explicitly mark which classes of certs may be contrained in them,
> e.g.,
> only CA certs or only some revocation reason codes.  However, there is
> no
> prohibition
> against round robin assignment of certs to different CRLs through the
> use
> of the CRL distribution point extension.  In fact, that would seem to
> be a
> major feature of this extension.  Perhaps you are raising the question
> of
> how one ought to note, in the CRL itself, that only a subset of certs
> (e.g., partiitioned by serial number) are contained in a given CRL.
> 
> Steve

---

From: "Sikac,John,CNA Insurance" <[email-masked]>
Date: Wed, 17 Feb 1999 11:28:41 -0600

Does anyone have any input to or is anyone aware of any issues 
related to co-residing the Entrust Directory with the LDAP server?

John

---

From: Santosh Chokhani <[email-masked]>
Date: Fri, 19 Feb 1999 15:16:42 -0500

In addition, the relying party must validate the contents of the Issuing
DP (which is within the signed envelope of the CRL) against the contents
of the CDP (which is in the signed envelop of the certificate).  The
specific validation rules (once again at the risk of being redundant)
are listed in the Annex M of the X.509 9/98 PDAM.

> From:	Stephen Kent [SMTP:[email-masked]]
> Sent:	Friday, February 19, 1999 9:56 AM
> To:	Trevor Freeman
> Cc:	[email-masked]'
> Yes, this message thread certainly does seem to have become confused.
> Hopefully we now agree that inclusion of a CDP extension in a cert
> allows a
> relying party to determine whether it has the right CRL for the cert
> in
> question, subject to the usual CRL validation processes.  Note that,
> in
> this case, the relying party does not care whether there are multiple
> CRLs
> or not, since the the CDP extension provided the necessary pointer.
> 
> Steve