Subject: RE: About Diffie-Hellman algorithm and Shamir threshold

From: Carlisle Adams <[email-masked]>
Date: Mon, 12 Apr 1999 12:44:47 -0400

Hi,

Russ is right.  When we were putting in the final edits to turn the Internet
Draft into an RFC, I remembered to update the OID to the correct value, but
forgot to update "DHParameter" to "DomainParameters".

RFC 2459 has the proper parameter to correspond to the OID.  RFC 2510 will
need to be updated whenever the opportunity arises.  Thank you for catching
this!

Some day all the PKIX documents will be perfect...  :-)

Carlisle.

> ----------
> From: 	Russ Housley[SMTP:[email-masked]]
> Sent: 	Monday, April 12, 1999 10:05 AM
> To: 	Xiong Shao Jun
> Cc: 	[email-masked]
> Subject: 	Re: About Diffie-Hellman algorithm and Shamir threshold
> 
> Xiong Shao Jun:
> 
> The definition in RFC 2459 is aligned with the Draft ANSI X9.42
> specification and the Draft IEEE P1363 speciification.
> 
> I think that you uncovered a bug in RFC 2510.
> 
> Russ
> 
> 
> At 01:17 PM 4/11/99 +0800, Xiong Shao Jun wrote:
> >Hi, I have two problems. The first is about Diffie-Hellman algorithm. In
> >PKIX part1, now
> >rfc2459, the algorithm is described as:
> >
> >OID:    1.2.840.10046.2.1
> >DomainParameters ::= SEQUENCE {
> >        p            INTEGER, -- odd prime, p=jq+1
> >        g            INTEGER, -- generator, g
> >        q            INTEGER, -- factor of p-1
> >        j            INTEGER OPTIONAL, -- subgroup factor
> >        validationParms    ValidationParms OPTIONAL }
> >
> >ValidationParms    ::= SEQUENCE {
> >        seed            BIT STRING
> >    pgenCounter   INTEGER }
> >
> >while in certificate management protocol, now rfc2510, the algorithms is
> >described as
> >below:
> >OID:    1.2.840.10046.2.1
> >DHParameter ::= SEQUENCE {
> >        prime INTEGER, -- p
> >        base  INTEGER  -- g
> >}
> >
> >So which is the most up to date description, and which should I
> >implement?
> >
>

---

From: "Xiong Shao Jun" <[email-masked]>
Date: Tue, 13 Apr 1999 08:57:22 +0800

Russ, Carlisle, thank you very much. How about Shamir threshold secret sharing,
the OID,
the parameter representation?

Thanks again,
Xiong Shaojun