Subject: About Diffie-Hellman algorithm and Shamir threshold

From: "Xiong Shao Jun" <[email-masked]>
Date: Sun, 11 Apr 1999 13:17:09 +0800

Hi, I have two problems. The first is about Diffie-Hellman algorithm. In
PKIX part1, now
rfc2459, the algorithm is described as:

OID:    1.2.840.10046.2.1
DomainParameters ::= SEQUENCE {
        p            INTEGER, -- odd prime, p=jq+1
        g            INTEGER, -- generator, g
        q            INTEGER, -- factor of p-1
        j            INTEGER OPTIONAL, -- subgroup factor
        validationParms    ValidationParms OPTIONAL }

ValidationParms    ::= SEQUENCE {
        seed            BIT STRING
    pgenCounter   INTEGER }

while in certificate management protocol, now rfc2510, the algorithms is
described as
below:
OID:    1.2.840.10046.2.1
DHParameter ::= SEQUENCE {
        prime INTEGER, -- p
        base  INTEGER  -- g
}

So which is the most up to date description, and which should I
implement?

---

From: Russ Housley <[email-masked]>
Date: Mon, 12 Apr 1999 10:05:42 -0400

Xiong Shao Jun:

The definition in RFC 2459 is aligned with the Draft ANSI X9.42
specification and the Draft IEEE P1363 speciification.

I think that you uncovered a bug in RFC 2510.

Russ