Subject: Re: AC509prof-00. LACResponseMessage

From: "Michael Zolotarev" <[email-masked]>
Date: Mon, 17 May 1999 19:05:26 +1000

LACResponseMessage is defined as

LACResponseMessage ::= CHOICE {
        ac        [0]  AttributeCertificate,
        errorInfo [1]  ErrorMsgContent -- from [CMP]
   }

1. CHOICE makes it impossible to communicate both the AC and non-critical
errors/warnings. grantedWithMods -do you think it will never be a case with
AC?  Should it be just a SEQUENCE?

2. Using ErrorMsgContent is probably not necessary. PKIStatusInfo [CMP] will
do just fine, and it can communicate both success and failure information.
The application should attempt parsing the AC data only after checking the
PKIStatusInfo ::PKIStatus first.

So, my proposal would be:

LACResponseMessage ::= SEQUENCE {
        errorInfo   PKIStatusInfo -- from [CMP],
        ac          AttributeCertificate OPTIONAL -- may not be present if a
critical error occurred
   }

Michael Zolotarev
Technical Architect, Baltimore Technologies Limited (Australia)

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 17 May 1999 10:46:23 +0100

Hi Michael,

Given that the "L" in LACResponseMessage stands for limited,
and that the protocol is not intended to be yet another
competitor in the CMP/CMC space, I'm not sure that I agree
with supporting "grantedWithMods". For this to make sense
the requestor has to be able to check what the mods were
and whether its happy with the mods.

I'd guess that this makes the requestor as complex as a
CMC/CMP client, so why would it use the limited protocol?
(I assume that CMP and/or CMC will eventually be extended 
to handle ACs.)

Also, remember that LAAP is a strawman, perhaps this mail 
will kick off discussion as to whether such a protocol
is required or not (I believe it is, I know that some others
don't). If the consensus is that LAAP is useful, then we 
can sensibly discuss just how limited it should be.

Regards,
Stephen.

---

From: Denis Pinkas <[email-masked]>
Date: Wed, 19 May 1999 19:21:00 +0200

Michael,

I support your proposal.

Denis