Subject: RE: X.509 ACs vs. SPKI?

From: "Ellison, Carl M" <[email-masked]>
Date: Tue, 25 May 1999 13:03:41 -0700

Steve,

as I've said before, we tend to be in violent agreement :)

Sometime (not on this thread) we can resume our debate about
the meaning of names, but I'm glad we agree that for secure binding,
the hash of the public key is a fine globally unique identifier and an
unanchored text name is wide open to abuse.

If that can be made clear in the spec -- and if the issuer can also be
identified by hash of the public key -- then the AC begins to look
like a certificate I can readily use in an authorization computation. 
[Sometime, I should show you the mechanism we've planned for CDSA that
does authorization computations for all certificate types, not just
SPKI.....]

 - Carl

> -----Original Message-----
> From: Stephen Kent [mailto:[email-masked]]
> Sent: Tuesday, May 25, 1999 11:42 AM
> To: Ellison, Carl M
> Cc: [email-masked]; [email-masked]
> Subject: RE: X.509 ACs vs. SPKI?
> 
> 
> Carl,
> 
> I agree that the only safe way to bind an attribute cert to 
> an identity
> cert is via the public key hash. That's what I always recommend to
my
> clients.
> 
> Look at the draft profile for attribute certs recently 
> published by Stephen
> Farrell and it's easy to locate the key hash as pointer.  The real
> difference here is that X.509 believes that certs with public 
> keys should
> contain a name that is not purely a local matter.
> 
> The hash is the most secure way to bind an attribute (yes, 
> "authorization"
> is a better name) cert to the identity cert, and I'll suggest that
we
> mandate it in our profile as we progress.
> 
> Steve
>

---

From: Ed Gerck <[email-masked]>
Date: Tue, 25 May 1999 16:48:02 -0700

"Ellison, Carl M" wrote:

> ... for secure binding,

I disagree. The hash of the public-key is also open to abuse since it
does not securely include that key's validity date, does not include an
originally secure reference to a valid revocation mechanism linked to
the identity certificate from whence that public-key came and cannot
contain other warranties or insurance by extension from the identity
certificate itself.  Please see  my former e-mail.

However, I agree if  one uses the whole identity certificate hash -- not
the public-key hash. This was also discussed in my former e-mail.

Cheers,

Ed Gerck