Subject: RE: Rename Qualified Certificates?

From: [email-masked]
Date: Fri, 21 May 1999 12:12:05 -0400

I agree with Steve and Hoyt that we certificate policy qualifiers are a good
place for fields qualifying such things as signature authority amounts.  So,
even though RFC 2459 section 4.2.1.5
"strongly recommends that use of qualifiers be limited to those identified in
this section", of which there are only two, which suggests to me that new
extensions are should be used instead, I'd like to submit some proposed generic
qualifier syntaxes for discussion.  These are quite large to reduce the number
of qualifiers people would need to add to their ASN.1 parsers:

PrimitiveField      ::=  SEQUENCE  {
     fieldID        [30] IMPLICIT OBJECT IDENTIFIER OPTIONAL,
     CHOICE    {
     number         NumericString,
     printable PrintableString,
     wideChar  BMPString,
     universal UTF8String,
     hugeChar  UniversalString,
     ascii          IA5String,
     boolean   BOOLEAN,
     int       INTEGER,
     realValue REAL,
     boolArray BIT STRING,
     bitData        [29] IMPLICIT BIT STRING,
     blob      OCTET STRING,
     omitted        NULL,
     id        OBJECT IDENTIFIER,
     time      GeneralizedTime,
     oldTime   UTCTime
     }
}

InternetField  ::=  SEQUENCE  {
     fieldID        [30] IMPLICIT OBJECT IDENTIFIER OPTIONAL,
     CHOICE    {    -- mainly extracted from GeneralName
     generalNames        SEQUENCE OF GeneralName,
     otherName      [0]  INSTANCE OF OTHER-NAME,
     rfc822Name          [1]  IMPLICIT IA5String,
     dNSName        [2]  IMPLICIT IA5String,
     x400Address         [3]  IMPLICIT ORAddress,
     directoryName       [4]  IMPLICIT Name,
     ediPartyName        [5]  IMPLICIT EDIPartyName,
     uniformResourceIdentifier     [6]   IMPLICIT IA5String,
     iPAddress      [7]  IMPLICIT OCTET STRING,
     registeredID        [8]  IMPLICIT OBJECT IDENTIFIER,
     TCPPort        [10] IMPLICIT INTEGER,
     UDPPort        [11] IMPLICIT INTEGER,
     OSIPSAP        [12] IMPLICIT SEQUENCE OF OCTET STRING
     }
}

FinancialAmount     ::=  SEQUENCE
{    fieldID        [30] IMPLICIT OBJECT IDENTIFIER OPTIONAL,
     Currency  PrintableString,               -- e.g. "USD" for U.S. Dollar
     CHOICE    {
          amount         NumericString,
          value          INTEGER         -- no need for floating-point
     }
}

     Tom Gindin

---

From: "Nick Pope" <[email-masked]>
Date: Fri, 21 May 1999 17:51:37 +0100

This seems to be a bit of a Blunderbus approach.  It may well hit a number
of things that wasn't intended and may well miss what we were aiming at.

Nick

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 21 May 1999 17:12
> To: Stephen Kent
> Cc: Nick Pope; [email-masked]; [email-masked]
> Subject: RE: Rename Qualified Certificates?
>
>