Subject: Re: I-D ACTION:draft-ietf-pkix-time-stamp-01.txt

From: [email-masked]
Date: Wed, 12 May 1999 14:24:27 -0400

The object ID of a composite hash algorithm will uniquely determine the
order in which the component hashes are to be placed.  The object ID of such an
algorithm will be an ordinary-looking OID.    A typical example would be roughly
as follows:

SHA1_then_MD5  ::=  OBJECT IDENTFIER     { hash_root  7 }
     -- the value of this hash will consist of 36 octets.  The first 20 octets
consist of the output
     -- of the SHA1 algorithm on the input data, and the last 16 octets consist
of the output of
     -- the MD5 algorithm on the input data.

     There should be no greater problem in interpreting this object ID than that
of any other hash algorithm.  I believe that several such algorithm ID's should
be defined and published in a standard location.  These could be used for many
signature applications, and not just for time stamps.

          Tom Gindin

---

From: "Jose A. Manas" <[email-masked]>
Date: Fri, 14 May 1999 07:52:12 +0200

My concern is that composite hashes do not scale:

1. There are currently about 7 hash algorithms to play with
(md2, md4, md5, sha1, rimemd128, ripemd160, ripemd256).
That implies 7 single oids, plus 7x6 combinations with two of them,
plus 7x6x5 combinations of three, and so on. I feel much more
confortable with 7 oids rather than with such a collection.

2. How are new algorithms introduced?
You need a new bunch of OIDs, plus the knowledge of the size
of each hash value to be widely spread.

3. Under which OID branch are these combinations to exist?
(you mention some hash root, but so far algorithms are under
separate prefixes)

It is so simple to have a sequence of hashes (even for signing)
that it looks unwise to further complicate the already complex
problem of OID over population.

Best,
pp

> signature applications, and not just for time stamps.

-- --------------------------------------------------------
Prof. Jose A. Manas                     <[email-masked]>
Dpt. Telematica                 http://www.dit.upm.es/~pepe
E.T.S.I. Telecomunicacion           tel: [+34] 91 336 73 25
Ciudad Universitaria                gsm: [+34] 607 73 38 94
E-28040 Madrid, SPAIN               fax: [+34] 91 336 73 33