Subject: RE: I-D ACTION:draft-ietf-pkix-scvp-00.txt

From: Paul Hoffman / IMC <[email-masked]>
Date: Mon, 28 Jun 1999 19:45:37 -0700

At 12:27 PM 6/29/1999 +1000, [email-masked] wrote:
>Hardcoded SHA-1:
>Why not to use the X509 AlgorithmIdentifier?

Because there are two syntaxes, one of which is not ASN.1. If folks see a 
need for the additional complexity, we could put in a hash identifier that 
might look like that in the ASN.1 syntax.

But I still don't think it's all that necessary. Why make a simple client 
know two methods of hashing? Is there a real value to that? If there are 
multiple hash algorithms, clients will be expected to know all of them (so 
they can use an arbitrary server), which leads to code bloat. Are we really 
that nervous about SHA-1?

>Request/Response signatures:
>Could the PKCS#7 encapsulation be used for the request and response?

For the ASN.1 syntax, yes; for the tiny syntax, absolutely not. But CMS 
doesn't really add much, and there's no reason to expect clients to be 
CMS-aware.

--Paul Hoffman, Director
--Internet Mail Consortium

---

From: "Ambarish Malpani" <[email-masked]>
Date: Tue, 29 Jun 1999 16:09:26 -0700

I had thought about using CMS for the ASN.1 encoding and the main
reason for avoiding that, was to allow both the tiny and the ASN.1
syntax to match each other closely.

Ambarish

---------------------------------------------------------------------
Ambarish Malpani
Architect					         650.567.5457
ValiCert, Inc.				        [email-masked]
1215 Terra Bella Ave.		              http://www.valicert.com
Mountain View, CA 94043-1833

> -----Original Message-----
> From: Paul Hoffman / IMC [mailto:[email-masked]]
> Sent: Monday, June 28, 1999 7:46 PM
> To: [email-masked]
> Subject: RE: I-D ACTION:draft-ietf-pkix-scvp-00.txt
> 
>