Subject: Re: Lets Standardize Time Representation Formats!!!: WAS Re: New TSTTime definition

From: Peter Sylvester <[email-masked]>
Date: Fri, 6 Aug 1999 11:41:49 +0200 (MET DST)

> >
> > The issue is: why does the TSTTime consist of GeneralizedTime plus
> > more stuff, when that additional stuff merely duplicates in a
> > confusing way what you can already represent with GeneralizedTime?
> 
> Quite simply becuase I have no reason to believe that the timedata in the
> TST is any good.

This seems the wrong answer to a good question, or a answer to 
a question that has not been asked: 

- It seems to me that the model behind GeneralizedTime is to
  have something that corresponds to what human being experience
  all days; calendars and clocks. Furthermore leap seconds don't
  seem to exist in that world. 
  Humans are used to life with that, so be it. 

- Counting model for clocks with arbitrary precision like the NTP
  format or else don't seem to be for end user consumption. 
  Nevertheless I don't see why one should not be able to produce
  time stamps in that format. 

IMHO one should keep these formats separated and not mixed. 

   CHOICE {
	genTime Generalizedtime 
	bintime SEQUENCE  { whatever encodeing of seconds, leqpseconds, fractions
         precision ... }
	}
   }

Peter

---

From: "tog" <[email-masked]>
Date: Fri, 6 Aug 1999 08:11:49 -0700

That works fine for me, but lets add one then -
> bintime SEQUENCE  { whatever encodeing of seconds, leqpseconds, fractions

Pardon my sloppy ASN.1 - but you get the point -

CHOICE {
genTime Generalizedtime
bintime SEQUENCE  { whatever encodeing of seconds, leqpseconds, fractions
                                    precision ... }
SecureTime     SignedGeneralizedtime
}

and

SignedGeneralizedTime {
AuthSig            SEQUENCE { SigBlockLen, signature type, alg, and the
accompanying signature for bintime, resource} OPTIONAL
bintime SEQUENCE  { whatever encodeing of seconds, leqpseconds, fractions
                                    precision ... }
}

Then its just a matter of defining the resource types that are accepted and
maybe building OIDs to support those.

Todd