Subject: Re: TSTTime definition

From: Peter Sylvester <[email-masked]>
Date: Thu, 5 Aug 1999 14:32:30 +0200 (MET DST)

> The current proposal is directly inspired from NTP. This should be
> satisfactory. If not, I would like to see an agreement on an
> alternative proposal written in ASN1 to specify only the time below
> the second.

For example:

TSTTime ::= SEQUENCE {
  genTime GeneralizedTime ,
  subsecond NumericString OPTIONAL
}

GeneralizedTime is used with seconds or milliseconds.
Subsecond is a chain of decimal digits, the leftmost
digit expresses 1/10th of a second, the second 1/100th.
Spaces MUST NOT be inserted.
The number of digits used corresponds to the precision.

I would like to have something like:
If subsecond is not present genTime MAY contain a fractional
part. Applications MUST be prepared to support fractional
parts after 31dec1999.

---

From: [email-masked] (Peter Gutmann)
Date: Fri, 6 Aug 1999 01:39:43 (NZST)

Peter Sylvester <[email-masked]> writes:

>GeneralizedTime is used with seconds or milliseconds.  Subsecond is a 
>chain of decimal digits, the leftmost digit expresses 1/10th of a second, 
>the second 1/100th.

OK, this time I will jump in first... given that GeneralizedTime *already
includes* the subsecond facility in exactly the format described above, why
is it necessary to add a second way to specify it?  Is there some secret
annex to X.680 which says that you're not allowed to use GeneralizedTime to
encode a generalised time which I'm missing?

Peter.

---

From: Peter Sylvester <[email-masked]>
Date: Thu, 5 Aug 1999 16:41:42 +0200 (MET DST)

Good morning. Here it is still yesterday :-)

I fully agree with you. I do not see any benefit to code
anything else than just GeneralizedTime with all its
features. Anyway, I believe if something is missing in
that format the right way is to get that changed.  

Furthermore: Copying just the subseconds of the NTP stuff
and leaving GeneralizedTime may create problems with
leap seconds when you actually want to compare two dates.
(Not that I believe that this is going to happen).

If someone needs such kind of authenticated time, then
one should choose the complete format, and not mixture
of two pieces of different worlds.  

/P