Subject: RE: Possible solution?, was Re: Non-Repudiation, was Re: Common misconceptions, was Re: KISSfor PKIX. (Was: RE:ASN.1vs XML (usedto be RE: I-D ACTION :draft-ietf-pkix-scvp-00.txt))

From: Larry Layten <[email-masked]>
Date: Thu, 12 Aug 1999 08:51:18 -0500

Please excuse me for jumping into the fray here, but from
an applilcation developer's point of view, this thread seems
to have ignored a point that was discussed in this mail list
several months ago -- and my understanding of this was:

If the certificate indicated non-repudiation, then an application
would have to specifically ask for a user's authorization to
use the certificate to create a signature.

I realize that this gets into the policy area rather than the
technical area, but in my mind, the the NR indicator provides
a technical means to support a policy whereby specific user
action is required (versus a digital signature used for authentication).

Larry

-----Original Message-----
From:	Ed Gerck [SMTP:[email-masked]]
Sent:	Wednesday, August 11, 1999 6:43 PM
To:	Alfred Arsenault
Cc:	Stephen Kent; Stephen Kent; [email-masked]'
Subject:	Re: Possible solution?, was Re: Non-Repudiation, was Re: Common 
  misconceptions, was Re: KISSfor   PKIX.   (Was: RE:ASN.1vs   XML     (  
usedto be RE: I-D 	ACTION 	 :draft-ietf-pkix-scvp-00.txt))

[snip]

---

From: "Peter Williams" <[email-masked]>
Date: Thu, 12 Aug 1999 09:41:14 -0700

> use the certificate to create a signature.

No. An electronic signature created using a digital signature
security procedure satisfies writing and signature requirements,
with or without non-repudiation properties, whether it is created
by, or on behalf of, a user. The "on behalf of" clause enables
such as server-agents to perform cryptography on one's behalf
during, for example, its performance of
the automated proof of receipt (with NR) service during
an EDI functional acknowledgement procedure.

On the NR issue, nothing in the NR definition requires there
to be evidence of user intent. User intent is required
in the underlying electronic signature requirement, however.

(Note an "electronic signature" is not restricted to
a digital signature security procedure; an S/MIME envelopedData
message protected by persistent KEA certificates and the
KEA key agreement security procedure does just as well,
as does a MAC exchanged using a notarized symmetric key
issued according to X9.17. Both of these latter procedures
may also satisfy NR requirements, additionally.)

---

From: Ed Gerck <[email-masked]>
Date: Thu, 12 Aug 1999 13:58:54 -0700

> use the certificate to create a signature.

This is IMO both too vague and too restricitve. The user may
need also the supervisor's authorization for example, or the user's
authorization may be supplied over a time period.   This also goes
not only into the policy area but also into the application area,
where PKIX should be neutral.

I also agree with Peter Williams, that nothing in the present NR
definition requires there to be evidence of user intent -- and I doubt
that an infrastructure protocol such as PKIX which deals with
objects being exchanged between applications could provide it.

The topic you mention seems also to fall under my question (2)
of yesterday:

 2. Can a CA use PKIX in order to permit or prohibit a
 particular subscriber certificate from being used in a
 transaction?

And the answer IMO is no, only the CPS can handle it in a consistent
way by policy or legal restrictions since all the CA can do is take good
care of what the CA signs, not what the subscriber signs.  The certificate
itself can be seen as a tamperproof communication channel from CA to
r-p but no assurance can be provided on how the corresponding
subscriber's private-key  is used in a transaction at the subscriber's
platform.

Thus, ignoring in PKIX what the application may do in regard to the
user will allow such matters to be handled in the CPS. Otherwise, this
would be pre-empted in the specs and would very probably be either
too vague or too restrictive in a general case.

Cheers,

Ed Gerck

---

From: Stephen Kent <[email-masked]>
Date: Thu, 12 Aug 1999 17:55:30 -0400

Larry,

I do not recall agreement on this list consistent with your suggestion that
the NR flag would tigger an application to invoke  some form of user alert
re signing.

Steve

---

From: "tog" <[email-masked]>
Date: Fri, 13 Aug 1999 07:55:18 -0700

Then what exactly is the scope of the use-model for the NR bit?

Todd

---

From: Stephen Kent <[email-masked]>
Date: Fri, 13 Aug 1999 11:09:52 -0400

Todd,

>> the NR flag would tigger an application to invoke  some form of user alert

We've discussed the utility of the NR bit, both when asserted and when not
asserted.  I'm not going to spend more time on this thread.

Steve