Subject: R: New TSTTime definition

From: Santoni Adriano <[email-masked]>
Date: Tue, 3 Aug 1999 10:51:08 +0200

> Here is a proposal for a new structure and the text that
> applies to it:
>
> TSTTime ::= SEQUENCE  {
>     genTime                       GeneralizedTime,
>     serialNumber                  INTEGER,
>     precisionFactor               INTEGER       OPTIONAL,
>     fractionOfSecond              BIT STRING    OPTIONAL
> }
>
> [...]
>
> The integer used for the serial number shall be a strictly
> monotonically increasing integer that will guarantee that each token
> is unique. It carries to functions:

I take it that the serialNumber field of the outer TSTInfo structure (see
below excerpt from draft-ietf-pkix-time-stamp-02.txt) is not sufficient to
guarantee uniqueness of each token issued by a certain TSA. Then, what would
be its purpose?

-----BEGIN EXCERPT-----

TSTInfo ::= SEQUENCE  {
     version                      Integer  { v1(0) },
     policy                       PolicyInformation,
     tsa                          [0] GeneralName OPTIONAL,
     tstTime                      TSTTime,
     nonce                        [1] Integer OPTIONAL,
      messageImprint               [2] MessageImprint OPTIONAL,
     serialNumber                 [3] Integer OPTIONAL, --- <<< this one
     tsaFreeData                  [4] OCTET STRING OPTIONAL,
     tdaTokens                    [5] SEQUENCE OF TemporalDataToken OPTIONAL
}

-----END EXCERPT-----

Adriano Santoni
SIA S.p.A.

---

From: Denis Pinkas <[email-masked]>
Date: Tue, 03 Aug 1999 12:07:20 +0200

Santoni,

The serial number in TSTInfo is an absolute optional number, whereas
the other one includes in TSTTIme is a relative mandatory one.

Take a look at the answer I just made on the same topic for other
arguments.

Regards,

Denis