Subject: RE: New draft - NULL Public Key Signatures

From: Michael Myers <[email-masked]>
Date: Thu, 28 Oct 1999 09:07:36 -0700

Ambarish,

Does this proposal require X.509 certificates?  Or is it the case that the
draft, when finalized, will propose a non-X.509 approach to public key
management?

Mike

> -----Original Message-----
> From: Ambarish Malpani [mailto:[email-masked]]
> Sent: Tuesday, October 19, 1999 4:16 PM
> To: [email-masked]
> Subject: New draft - NULL Public Key Signatures
> 
> 
> 
> Hi Guys,
>     Given the traffic on this list, it sounds like this IETF is
> going to be a pretty boring one. :-)
> 
> I have just submitted an individual draft about NULL Public Key
> Signatures, which I hope will be part of this working group soon
> (make things at the PKIX meeting more interesting).
> 
> The main (serious) reason for this draft, is to allow people to
> describe data items that may be signed or unsigned more easily
> in ASN.1.
> 
> Also, having a NULL algorithm is asthetically pleasing.
> 
> So here it is.
> 
> Please send all your flames/comments to this list.
> 
> Thanks,
> Ambarish
> 
> ---------------------------------------------------------------------
> Ambarish Malpani
> Architect                                                650.567.5457
> ValiCert, Inc.                                  [email-masked]
> 1215 Terra Bella Ave.                         http://www.valicert.com
> Mountain View, CA 94043-1833
> 
>

---

From: Ambarish Malpani <[email-masked]>
Date: Thu, 28 Oct 1999 11:19:14 -0700

Hi Mike,
    Good question.

Actually, if you read the draft, you actually might be able to
figure out that it is independent of X.509 or other certificates.
Just as RSA can work fine with any format of certification.

But still, a very good question.

Regards,
Ambarish

> From: Michael Myers [mailto:[email-masked]]
> Sent: Thursday, October 28, 1999 9:08 AM
> To: Ambarish Malpani; [email-masked]
> Subject: RE: New draft - NULL Public Key Signatures
> 
> 
> Ambarish,
> 
> > Architect                                                
> 650.567.5457

---

From: Michael Myers <[email-masked]>
Date: Thu, 28 Oct 1999 14:08:57 -0700

Ambarish,

That's what I'd concluded from reading the draft, but I wanted to ask to be
certain.

Mike

> From: Ambarish Malpani [mailto:[email-masked]]
> Sent: Thursday, October 28, 1999 11:19 AM
> To: Michael Myers; Ambarish Malpani; [email-masked]