Subject: RE: QC certificates and Nationality

From: "Miklos, Sue A." <[email-masked]>
Date: Tue, 2 Nov 1999 09:21:35 -0500

All, 

I would like to request the attribute that represents a subject's
nationality be structured so that dual citizenship is allowed (default
Multivalued, which I believe is supported by countryOfCitizenship and, that
this attribute be populated with the ISO-3166-1 (trigraph) if that is
consistent with the domain using this piece of information.

I have requirements for both.  That is, I have a requirement for an
attribute that can indicate a subject is a citizen of both Country A and
Country B (country of domicile is not relevant at this point) and, that the
citizenship be indicated with a trigraph (USA, CAN, NZL, etc.)

Regards,
Sandi Miklos

-----Original Message-----
From: Petra Barzin (Gloeckner) [mailto:[email-masked]]
Sent: Tuesday, November 02, 1999 4:32 AM
To: Russ Housley
Cc: [email-masked]; 'SEIS-List'; Stefan Santesson
Subject: Re: QC certificates and Nationality

Russ Housley wrote:
> 
> What goes into the QC when a person is a citizen of more than one country?
> 
> Russ

Hello Russ,

very good point! The wording in chapter 3.2.1 doesn't fit to the 
definition of the attribute.

Right now, you have to add the attribute multiple times. I suggest that
we replace the definition by the following:

countryOfCitizenship  ATTRIBUTE ::= {
	WITH SYNTAX   SEQUENCE OF PrintableString(SIZE (2)) 
					-- IS 3166 codes only
	ID            id-at-countryOfCitizenship }

countryOfResidence    ATTRIBUTE ::= {
	WITH SYNTAX   SEQUENCE OF PrintableString(SIZE (2)) 
					-- IS 3166 codes only
	ID            id-at-countryOfResidence }

Best regards - Petra

---

From: "Petra Barzin (Gloeckner)" <[email-masked]>
Date: Tue, 02 Nov 1999 18:54:59 +0100

Hi Sandi,

the definition of our countryOfCitizenship attribute fulfils your first 
requirement. But why would you want to use trigraphs? The two letter 
codes cover all countries, don't they? 
If your application needs the three letter codes, you can easily map 
the two letter codes to the respective three letter codes.

Regards - Petra

> "Miklos, Sue A." wrote:
> Multivalued, which I believe is supported by countryOfCitizenship and,
> that this attribute be populated with the ISO-3166-1 (trigraph) if
> that is consistent with the domain using this piece of information.
> 
> attribute that can indicate a subject is a citizen of both Country A
> and Country B (country of domicile is not relevant at this point) and,
> that the citizenship be indicated with a trigraph (USA, CAN, NZL,
> etc.)
> 
> Regards,
> Sandi Miklos
>