Subject: RE: QC comparisons are DEADLY serious!

From: "Anders Rundgren" <[email-masked]>
Date: Thu, 4 Nov 1999 07:46:24 -0000

Steve,

<snip>

>In version 2 X.509 certs there was a field added for unique subject and
>issuer IDs.  It was a bad idea, designed to address what appear to be some
>of the issues you alluded to above; nobody uses it.

Except for the Swedish and Finnish ID-card programs.  Well, to be honest they have
defined some subject extensions "on their own" to achive this functionality and I suggest
that this gets standardized.  And INTEROPERABILITY is a goal of QC isn't it?

BTW, I think that most employee systems use "emplyee numbers" internally to keep track
of employees.  To become a "new" employeee just because you have been promoted
is IMO an awkward solution.

Actually, I wonder how wide-spread the initial QC attribute-based identity scheme will be.

But Steve, let the MARKET and LEGISLATORS decide.  We provide the options.

<snip>

Anders

---

From: Stephen Kent <[email-masked]>
Date: Mon, 8 Nov 1999 11:11:18 -0500

Anders,

Yes, many organizations do qualify individuals by employee, student,
payroll, or other numeric IDs.  The preferred way to make use of this
qualification is as one element of a two element set for the terminal RDN.
After all, this qualifying number is needed to uniquely identify two
individuals who would otherwise have the same DN, so it belongs in the DN.

As for letting "the market and legislators decide," surely you are joking
about the former.

Steve