Subject: Re: QC certificates and Nationality

From: "Petra Barzin (Gloeckner)" <[email-masked]>
Date: Tue, 02 Nov 1999 10:31:39 +0100

Russ Housley wrote:
> 
> What goes into the QC when a person is a citizen of more than one country?
> 
> Russ

Hello Russ,

very good point! The wording in chapter 3.2.1 doesn't fit to the 
definition of the attribute.

Right now, you have to add the attribute multiple times. I suggest that
we replace the definition by the following:

countryOfCitizenship  ATTRIBUTE ::= {
	WITH SYNTAX   SEQUENCE OF PrintableString(SIZE (2)) 
					-- IS 3166 codes only
	ID            id-at-countryOfCitizenship }

countryOfResidence    ATTRIBUTE ::= {
	WITH SYNTAX   SEQUENCE OF PrintableString(SIZE (2)) 
					-- IS 3166 codes only
	ID            id-at-countryOfResidence }

Best regards - Petra

---

From: "Petra Barzin (Gloeckner)" <[email-masked]>
Date: Tue, 02 Nov 1999 18:45:25 +0100

Sorry, I've to correct my last statement. In the QC we are using the 
Attribute definition (in contrast to the AttributeTypeAndValue 
definition being used in a DName):

	personalDataAttributes	SEQUENCE SIZE (1..MAX) OF Attribute
							  ^^^^^^^^^

I just read the respective part of the X.501 standard where Attribute is 
defined. It is indeed multivalued, i.e. multiple values can be used:

Attribute ::= SEQUENCE {
    type      ATTRIBUTE.&id({SupportedAttributes}),
    values    SET SIZE (1..MAX) OF
ATTRIBUTE.&Type({SupportedAttributes}{@type})}
	      ^^^

If the same attribute would be used in a DName it would be only 
single-valued, i.e. you would have to use the attribute multiple times:

AttributeTypeAndValue ::= SEQUENCE{
    type    ATTRIBUTE.&id({SupportedAttributes}),
    values  ATTRIBUTE.&Type({SupportedAttributes}{@type})}

Sorry for the confusion. 
Best regards - Petra