Subject: Re: NR Signing-Entity vs Certificate-Subject

From: "Aram Perez" <[email-masked]>
Date: Tue, 23 Nov 1999 10:53:14 -0800

Dave Kemp wrote:

> 
>> From: Ed Gerck <[email-masked]>
> 
>> 
>> >   Should we require that whatever definition we come up with for the
>> >   NR bit enable the checking of software applications for conformance
>> >   with the definition?
>>
>> Yes, trivially -- even if the definition cannot enable the checking of
>> software applications for conformance with the definition, as the CPS
>> definition does not allow, because not checking would be part of the
>> definition.
>
> If consensus were reached on this interpretation, then I would agree
> with those who suggest that the bit be deprecated, because the bit has
> no useful meaning if applications cannot be usefully checked for
> conformance.  Requiring that applications ignore the state of the bit,
> or act on the bit only in the context of some external and non-parsable
> information, is not a useful conformance specification.

Well stated Dave. That now makes three of us! Anyone else want to join the
"Deprecate NR or Bust" wagon?

;-)
Aram Perez

---

From: Eric Murray <[email-masked]>
Date: Tue, 23 Nov 1999 11:19:29 -0800

> "Deprecate NR or Bust" wagon?

Yes.  Having watched this debate go around and around and around
and around for the last 6 months or more, it's obvious that there's
not going to be any consensus any time soon.

So, I would suggest deprecating the NR bit and leaving the problem for
another working group who can define a format for describing
(internal to certs and in a and parseable way) what NR means to any
given party to a certificate.

-- 
 Eric Murray www.lne.com/~ericm  ericm at the site lne.com  PGP keyid:E03F65E5

---

From: Irene Gassko <[email-masked]>
Date: Tue, 23 Nov 1999 14:30:47 -0500

Will renaming NR bit into "archival" or "persistent" signature bit (as
opposed to "ephemeral")
make everybody happy? If yes, then we need to state what additional steps
are to be
associated with it.

Irene

>given party to a certificate.

----------------------------------------------------------------------------
-------------------------------------------------------
Irene Gassko			 Bell Laboratories		http://www.lucent.com
Lucent Technologies		Secure Technologies Dept.
1600 Osgood Street			 phone:	(978) 960-5767
Room 30-2-A31			 e-mail: 	[email-masked]
N. Andover, MA 01845		 fax: 	(978) 960-3240