Subject: RE: OCSP and CSL

From: Ambarish Malpani <[email-masked]>
Date: Thu, 27 Jan 2000 11:39:03 -0800

Hi Antonio,
    Comments inline.

Regards,
Ambarish

---------------------------------------------------------------------
Ambarish Malpani
Architect                                                650.567.5457
ValiCert, Inc.                                  [email-masked]
1215 Terra Bella Ave.                         http://www.valicert.com
Mountain View, CA 94043-1833

> -----Original Message-----
> From: Antonio Lioy [mailto:[email-masked]]
> Sent: Thursday, January 27, 2000 9:32 AM
> To: [email-masked]
> Cc: 'Massimiliano Pala'
> Subject: Re: OCSP and CSL
> 
> 
> I think that CSL is a real need in several cases and that it
> cannot be easily substituted with CRL or OCSP.
> 
> First of all OCSP is out of question is it is not a trust
> source but rather a delivery channel for fast trust
> information. For non-repudiation service, it needs to be
> backed up by long-term data such as those of a CRL.

I hope not! OCSP responses are signed and can very much be used for
non-repudiation.

The benefit of a CRL over OCSP, is that you have all the revoked certs
in a single list, which is better for storage, IF YOU ARE INTERESTED
IN THE STATUS OF ALL THE CERTS. However, it isn't any more non-repudiable
than an OCSP response.

> 
> CRL is not good either due to revokation costs, that are
> among the highest ones in the PKI world. So I would like to
> minimize the number of revokations, especially if followed
> by a re-issue of the same certificate with a different key
> pair (especially difficult to work with those remote friends
> that have stored remotely my cert to send me encrypted
> e-mail while off-line)
> 
> Finally, I'd like to give my users the autonomous ability to
> suspend and then re-activate their certificates. Let's
> imagine the following scenario:
> - I don't want to take my smart-card with me and I leave it
> at the office (or I use a software PSE installed on my PC at
> work)
> - as I don't trust the company in charge of cleaning up the
> office (or may be my co-workers), I'd like to suspend the
> cert validity during week-ends, vacation, or even during
> night hours
> - I'd like to do this by just clicking on a button on a
> secure Web page (with client authentication) or sending a
> signed S/MIME message to an automatic responder
> - the responder (or the Web server) could in turn provide me
> with a one-time token to re-activate the cert at my will
> 
> There are other similar scenarios (like I forgot where I put
> my smart-card, and later I find it) where I don't want to
> have the burden of revoking and reissuing certs.
> 
> So I'd like to see this scenario supported by the following
> technical details:
> - a status code returned by an OCSP server to tell that a
> cert is SUSPENDED

This is already possible in OCSP - see my previous mail on this
topic.

> - a long term memory that a cert was suspended during a
> certain period of time; this should be provided by a CSL,
> which closely resembles the format (but not the meaning) of
> a CRL
> 
> Opinions?
> 
> Antonio Lioy
> 

Not quite sure what the CSL bought you - keeping track of all these
suspensions - particularly if every user is going to suspend their
cert on an average once a week will get pretty expensive very soon.

Regards,
Ambarish

---

From: Antonio Lioy <[email-masked]>
Date: Fri, 28 Jan 2000 19:11:29 +0100

> I hope not! OCSP responses are signed and can very much be used for

Sorry but there are several legislation in place (Italy and
Germany at least) where it is clearly stated the only
legally binding way to prove that a cert was not valid at a
certain date is to provide a CRL (or a CSL!!!) that includes
it.

There are not trusted 3-parties that can substitute it.

> IN THE STATUS OF ALL THE CERTS. However, it isn't any more non-repudiable

In these legal schemes, OCSP only buys you benefits in that
a client has not to process the whole CRL, but it can go to
court based only on the signed OCSP-response: it will need
to provide evidence of the CRL used by the OCSP server.
That's way in several cases it would be sufficient to have
non-signed OCSP responses over a trusted channel (e.g. SSL
with pure server authentication).
 
> This is already possible in OCSP - see my previous mail on this

I don't understand: OCSP primaty status is REVOKED (even if
reason is OnHold) and therefore that cert could never become
valid again. Or perhaps the word REVOKED is used with a
different meaning (i.e. not valid at this point in time)
from the one used in the CRL definition?
 
> cert on an average once a week will get pretty expensive very soon.

I agree that CSL doesn't look attractive, but I'm here
expressing a real need collected from some users (see
another mail of mine), and trying to understand what's the
correct technical solution with legal value.

Best regards,

Antonio Lioy