Subject: PKIX error message content

From: "Christopher Williams" <[email-masked]>
Date: Thu, 30 Mar 2000 10:26:56 +0100

The ErrorMsgContent structure is defined in RFC 2510 (and subsequent drafts)
as follows:

ErrorMsgContent ::= SEQUENCE {
         pKIStatusInfo          PKIStatusInfo,
         errorCode              INTEGER           OPTIONAL,
         -- implementation-specific error codes
         errorDetails           PKIFreeText       OPTIONAL
         -- implementation-specific error details
     }

The PKIStatusInfo structure already has fields for the error code and error
text, so what is the purpose of the same fields in ErrorMsgContent?

Chris Williams,
NetLexis

---

From: Carlisle Adams <[email-masked]>
Date: Thu, 30 Mar 2000 09:53:54 -0500

Hi Chris,

> ----------
> From: 	Christopher Williams[SMTP:[email-masked]]
> Sent: 	Thursday, March 30, 2000 4:26 AM
> To: 	PKIX Mailing List
> Subject: 	PKIX error message content
> 
 
As noted in the comments, these fields are for sending
implementation-specific details, as opposed to the generic code/text carried
in PKIStatusInfo.  If you have good knowledge of the implementation on the
receiving end (for example, during product testing, or interoperability
trials, etc., although it's not confined to this) then these fields may come
in handy.

We were just trying to make life a little easier for implementers...  :-)

Carlisle.