Subject: Re: DER in ac509prof-03

From: "Rich Ankney" <[email-masked]>
Date: Wed, 10 May 2000 14:55:37 -0400

-----Original Message-----
From: Peter Gutmann <[email-masked]>
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Date: Wednesday, May 10, 2000 1:28 PM
Subject: Re: DER in ac509prof-03

>Paul Koning <[email-masked]> writes:
>
>>Also, while old RFCs are still available, 12 year old ITU specs may only
>>exist in antique shops by now.
>
>It's the same for ASN.1 books, Prof.Larmouth's book is for current versions
of
>ASN.1 rather than the obsolete versions referenced in RFC's, so it would
>probably do more to confuse than help.  The only reference for the obsolete
>variant of ASN.1 is Douglas Steedmans "Tutorial and Reference", which is
>useful for that version but doesn't apply to any current version.  This
book
>has been out of print for years, so you'd actually have to go to antique
>shops (well, used book stores) to find it.
>

Well, Larmouth's book does discuss these earlier artifacts (macros and
ANY DEFINED BY), although it's certainly not very detailed.

>>Clearly, it is not acceptable to have an RFC that points to an outside
>>standard unless that outside standard is available.
>
>It could be argued that the ASN.1 specs, being ISO standards, aren't
usefully
>"available" no matter whether it's an obsolete or current version which is
>being referenced :-).
>

I heard from a generally reliable source that ITU-T is going to cave in and
distribute the ASN.1 specs (X.680 and X.690) for free via their website.
I heard this about a month ago, and they are still charging, but after all
this
IS the ITU we're talking about.  Has anyone else heard this?
>Peter.
Regards,
Rich

---

From: Paul Koning <[email-masked]>
Date: Wed, 10 May 2000 14:59:15 -0400 (EDT)

>>>>> "Rich" == Rich Ankney <[email-masked]> writes:

 Rich> I heard from a generally reliable source that ITU-T is going to
 Rich> cave in and distribute the ASN.1 specs (X.680 and X.690) for
 Rich> free via their website. 

That would be cool.  But what about X.208-1988?  Given the discussion
we just had, if *that* one isn't available (free or for money) we have
a real problem.

  paul

---

From: "Phillip H. Griffin" <[email-masked]>
Date: Wed, 10 May 2000 15:43:20 -0400

> >>exist in antique shops by now.

Not sure, but I think that the 1990 version
is still available on the ITU-T web site.

> ANY DEFINED BY), although it's certainly not very detailed.

The text on holes could give more details on
ANY and ANY DEFINED BY, but it seems to spend
more time on holes that work without the 
interoperability failures of these deprecated
types. As for MACROs, it seems rare when two
people can read one and come to the same 
conclusion. In general, they can not be 
mechanically processed in a reliable manner.
 
> IS the ITU we're talking about.  Has anyone else heard this?

At the ASN.1 meeting in Geneva in March, the ASN.1
Study Group recommended (again) that the ITU-T make
electronic copies of the standards available on their
web site for free. It has been agreed by the ITU-T to
follow this recommendation and to do so, but I am still
waiting on notice of the actual URL. 

There is other work related to this that must also be
completed. There are instructions for converting from
X.208 to the current standards that will be added to
the web site, and there is also new text to be added
that that there is no further need for retention of 
X.208 and X.209 as standards. Not sure if this actual
text has yet been approved, but the recommended text
to be displayed on the X.208 and X.209 pages was:

 "CCITT Recommendation X.208 has been superseded by 
 ITU-T Recommendations X.680-683 (1997).  All known
 defects in X.208 have been corrected in ITU-T 
 Recommendations X.680-683 (1997). Please note that 
 Rec. X.208 is scheduled for withdrawal.  If you are
 a protocol designer creating new ASN.1 notation, you
 should use the 1997 version of ASN.1 as defined in 
 ITU-T Recommendations X.680-683 (1997) instead of 
 using CCITT Recommendation X.208."

> Rich

Phil
----
Phillip H. Griffin      Griffin Consulting
http://asn-1.com        Secure ASN.1 Design & Implementation
+1-919-832-7008         1625 Glenwood Avenue, Five Points
+1-919-832-7390 [fax]   Raleigh, North Carolina  27608  USA
------------------------------------------------------------