Subject: RE: SubjectAltName verification

From: Peter Williams <[email-masked]>
Date: Tue, 23 May 2000 15:38:30 -0700

Steve:

   "Some communities will need to supplement, or possibly replace, this
   profile in order to meet the requirements of specialized application
   domains or environments with additional authorization, assurance, or
   operational requirements.  However, for basic applications, common
   representations of frequently used attributes are defined so that
   application developers can obtain necessary information without
   regard to the issuer of a particular certificate or certificate revo-
   cation list (CRL)." [RFC 2459, http://www.ietf.org/rfc/rfc2459.txt]

Do you affirm the above to be group consensus?

Peter.

-----Original Message-----
From: Stephen Kent [mailto:[email-masked]]
Sent: Tuesday, May 23, 2000 1:33 PM
To: Peter Williams
Cc: [email-masked]
Subject: RE: SubjectAltName verification

Peter,

>Steve:
>
>You question me if enough is said. I demurr from the
>suggested rewriting of my contribution, in what is
>hopefully my last message on this topic.
>
>I had not assumed any need for restatement of the
>IETF-community consensus concerning the legitimacy
>of intentional non-conformity - when operating
>Internet protocols and services.
>
>There was and perhaps is a continuing need to restate
>the *additional* "PKI-specific" consensus positions
>concerning "supplementing and replacing" PKIX
>recommendations and mandates, as stated in 2459.
>
>Perhaps we can be of one mind by engaging in a joint
>action:
>
>Perhaps we can both now reaffirm our support for the position
>that the obvious meaning of, if the not the very text of, the
>"supplement/replace language" present in the
>previously-referenced element of RFC 2459
>Section 2 should continue to be expressed in all subsequent
>versions of the Internet X.509 Certificate and CRL Profile.
>
>Do we reaffirm the consensus on MY point, or not?
>
>I think this is the real question.

For a native speaker of English, your writing often seems unduly obscure.

I don't recall what your proposed rewording of 2459 is. However, if 
it differs significantly from the first of two statement by me that 
Denis cited in his message, then it is probably the case that I do 
NOT affirm (much less reaffirm) a WG consensus on YOUR point.

Steve

---

From: Stephen Kent <[email-masked]>
Date: Wed, 24 May 2000 11:41:32 -0400

Peter,

>Do you affirm the above to be group consensus?

No, I do not agree.

It seems out of place to insert text into a standard saying that "we 
understand if you don't want to use this standard."  So the first 
sentence is out of the question.

The second sentence confuses me.  What do you mean by "common 
representations of frequently used attributes?"  The "representation" 
of an attribute is its syntax, which is certainly part of the 
standard, but not the focus of this discussion.

Steve