Subject: RE: SubjectAltName verification

From: Peter Williams <[email-masked]>
Date: Tue, 23 May 2000 13:17:34 -0700

Steve:

You question me if enough is said. I demurr from the
suggested rewriting of my contribution, in what is
hopefully my last message on this topic.

I had not assumed any need for restatement of the
IETF-community consensus concerning the legitimacy
of intentional non-conformity - when operating 
Internet protocols and services.

There was and perhaps is a continuing need to restate 
the *additional* "PKI-specific" consensus positions 
concerning "supplementing and replacing" PKIX 
recommendations and mandates, as stated in 2459.

Perhaps we can be of one mind by engaging in a joint 
action:

Perhaps we can both now reaffirm our support for the position
that the obvious meaning of, if the not the very text of, the 
"supplement/replace language" present in the 
previously-referenced element of RFC 2459 
Section 2 should continue to be expressed in all subsequent
versions of the Internet X.509 Certificate and CRL Profile.

Do we reaffirm the consensus on MY point, or not?

I think this is the real question.
 
Peter.

-----Original Message-----
From: Stephen Kent [mailto:[email-masked]]
Sent: Tuesday, May 23, 2000 12:30 PM
To: Peter Williams
Cc: [email-masked]
Subject: RE: SubjectAltName verification

Peter,

>Internet CAs are free, and must be free, to operate public-key
>certification according to wholly-private practices. This includes
>acting in PKIX-non-conforming or other PKIX opt-out manners, where
>(nationally-regulated) CAs and such CA's alone designate such practices
>to be appropriate to meet their interworking communities security needs.

Your message seems to cover the bases, i.e., a CA can always choose 
to be non-conforming with PKIX.

So, 'nuf said, right?

Steve

---

From: Stephen Kent <[email-masked]>
Date: Tue, 23 May 2000 16:33:00 -0400

Peter,

>I think this is the real question.

For a native speaker of English, your writing often seems unduly obscure.

I don't recall what your proposed rewording of 2459 is. However, if 
it differs significantly from the first of two statement by me that 
Denis cited in his message, then it is probably the case that I do 
NOT affirm (much less reaffirm) a WG consensus on YOUR point.

Steve