Subject: RE: Timestamp: id for token

From: Michael Zolotarev <[email-masked]>
Date: Wed, 31 May 2000 14:43:03 +1000

Case1:
Italian legislation mandates that a CA obtains a time stamp for each
published cert and CRLs. It also mandates that the TSA maintains the archive
of all issued timestamps for the life span of the TSA key. So that the CA
can be relieved from keeping the actual tokens.

Case2:
A document management system. Each document (e.g a purchase order) can be
timestamped any number of times at different stages of its life cycle. It
may be appropriate to have an archive containing just the progressing
versions of the document, and some associated references. It is not
necessarily possible/required to keep the document and its associated
timestamps together. Instead, a separate archive of timestamps can be
arranged, with the tokens referenced from other archives.

I know it all can be done in different ways -i.e. maintaining external
referencing, so that there is nothing in the token itself. Just saying that
there are some cases when a timestamp can be stored separately from the
document/message it was created for.

M

> -----Original Message-----
> From: Joerg Seidel [mailto:[email-masked]]
> Sent: Monday, May 29, 2000 8:21 PM
> To: Manger, James H
> Cc: [email-masked]'
> Subject: Re: Timestamp: id for token
> 
> 
> I agree on what James wrote. A unique identifier or serial 
> number is not
> necessary.
> 
> "Manger, James H" schrieb:
> > 
> > Is a standardised unambiguous identifier for a timestamp 
> token really needed
> > or wanted?
> > 
> > Such an identifier is useful for a certificate as a 
> certificate is used in
> > many messages (many SSL sessions, many S/MIME emails, many 
> transactions,
> > ...).  The certificate is independent of any particular 
> use.  A timestamp,
> > however, is only relevant to a single message - corresponding to its
> > messageImprint field.
> > 
> > The are no timestamp revocation lists.  There are no other 
> messages from a
> > TSA that need to refer to a specific timestamp.
> > 
> > It seems sensible to store a timestamp with its 
> corresponding message - so
> > now identifier is needed.  Even if they were stored separately the
> > implementation could its own labels to maintain the link, 
> i.e. it does not
> > need an explicit field within the timestamp.
>

---

From: Denis Pinkas <[email-masked]>
Date: Wed, 31 May 2000 09:12:21 +0200

Michael,

Thanks for your examples that illustrate that a unique reference for
the Time Stamps issued by a given CA name MAY be useful. 

Denis