Subject: Re: TSA Response serialNumber Field

From: Peter Sylvester <[email-masked]>
Date: Thu, 25 May 2000 18:34:05 +0200 (MET DST)

> Peter,
> 
> >Steve,
> >
> >Hm, the actual text says:
> >
> >     'strictly monotonical increasing'.
> >
> >At least the example in the text about non-consecutive
> >number is there.
> 
> The text I was referring to in the TSP draft states:
> 
> 3.  to include a monotonically incrementing integer for each
>           newly generated time stamp token.
> 
> "Monotonically increasing" means that the counter increments by 
> exactly one each time.  If it is not an increment by one, a phrase 
> such as "strictly increasing"
> would be appropriate.

"Monotonically increasing" means that a sequence is
monotonical, thus either always non-decreasing or non-increasing,
and increasing selects one of the possibilities. "Strictly"
means that you never have two numbers twice.

At least that is what I recall from initial math courses.  

I don't know what 'monotonically INCREMENTING" could mean. :-)

> 
> >
> >What you are asking for is to create consecutive time stamps.
> 
> Well, the time value will not be consecutive, which is why I though 
> Denis specified that the counter would be.  There can be legitimate 
> gaps in the time values.
Denis did not specify that. Just see the example. 

> 
> >
> >What you indicate is not mentioned in the text at all in the
> >text, maybe it was intended at some time (the usage of
> >'monotonically incrementing' may be an indication).
> >Maybe the original author's can comment on that.
> >
> >Your point is an interesting one. This is ONE method, if a TSA
> >is able and willing to increment by one, they can do that.
> 
> Yes, it's just one method. I assumed that it might have been 
> specified because its cheap to do and not patented, etc.
I guess I get your point :-)

> 
> >But that doesn't help,  a TSA can replace any stamp
> >and then claim in 30 years that the key was corrupted.
> >
> >If you imagine the possibility not to trust the TSA,*
> >then you might require that the TSA stores all stamps with
> >a notary, or whatever else third/forth/fifth tp to store
> >a complete archive of all tokens.
> 
> Elsewhere the document talks about recovery from a possible key 
> compromise and says:
> 
> . When the TSA private key has been compromised, then the
>          corresponding certificate SHALL be revoked. In this case,
>          any token signed by the TSA using that private key cannot
>          be trusted anymore.  For this reason, it is imperative that
>          the TSA's private key be guarded with proper security and
>          controls in order to minimize the possibility of compromise.
>          In case the private key does become compromised, an audit
>          trail of all tokens generated by the TSA MAY provide a means
>          to discriminate between genuine and false backdated tokens.
> 
> By sequentially numbering the TSTs, there may be some further 
> protection against back dating an audit log, but maybe this is such a 
> small added feature that it's not worth pursuing.

The problem was that this feature may be difficult to implement, and
in fact it doesn't solve anything. A TSA can easily generate random
hash numbers and time stamp them, and store them. This means they
can produce an audit trail that everything behaved in a +1 way
if you ask them. Nevertheless, since they have been the only ones
that have ever seen the radom stamps, they can still remove them
whenever you want. 

If you don't trust a TSA, you need someone else.

---

From: Tony Bartoletti <[email-masked]>
Date: Thu, 25 May 2000 10:45:14 -0700

>means that you never have two numbers twice.

Precisely.

Put another way, the sequence of differences never changes sign.
(Zero excluded as a "sign change".  Where zero IS included as a
sign change, one gets the "strictly monotonic" definition.)

>I don't know what 'monotonically INCREMENTING" could mean. :-)

It would be useful to have a term for "must increase by one."
Perhaps "unitarily increasing" ;)

___tony___

Tony Bartoletti 925-422-3881 <[email-masked]>
Information Operations, Warfare and Assurance Center
Lawrence Livermore National Laboratory
Livermore, CA 94551-9900