Subject: Re: Is possible indefinite form of length encoding in DER?

From: "Rich Ankney" <[email-masked]>
Date: Mon, 18 Sep 2000 23:03:36 -0400

To follow up, I suppose it could be one of those funky things that
most ASN.1 compilers don't handle well, like an EMBEDDED PDV
(which can signal encoding rules).

Regards,
Rich

-----Original Message-----
From: ChungKil Kim <[email-masked]>
To: [email-masked] <[email-masked]>
Date: Monday, September 18, 2000 10:41 PM
Subject: Q: Is possible indefinite form of length encoding in DER?

>In some S/MIME messages, there are indefinite form of length encoding.
>Is it possible?
>
>In PKCS specs, only use DER?
>

---

From: "Kwon, YongChul" <[email-masked]>
Date: Tue, 19 Sep 2000 13:12:26 +0900

> Hi Rich and ChungKil,
> 
> It's my understanding that for OCTET STRING you can use a 
> constructed OCTET
> STRING, which when you decode appears as one OCTET STRING. I used 
> to have an
> example file but I don't know where it is.

	following X.690, constructed encoding is not permitted for bit string,
	octetstring and restricted character string types in DER encoding.

	octetstring can be constructed only if it is tagged with EXPLICIT in DER.

---

From: "Rich Ankney" <[email-masked]>
Date: Tue, 19 Sep 2000 10:00:31 -0400

I don't think you can use constructed OCTET STRINGs in DER,
though. I'll try to unearth the 1994 standard today and verify this.
Or no doubt Phil Griffin is lurking on the list and can answer this
off the top of his head:-)

Regards,
Rich

-----Original Message-----
From: Aram Perez <[email-masked]>
To: [email-masked] <[email-masked]>
Date: Monday, September 18, 2000 11:20 PM
Subject: Re: Is possible indefinite form of length encoding in DER?

>Hi Rich and ChungKil,
>
>It's my understanding that for OCTET STRING you can use a constructed OCTET
>STRING, which when you decode appears as one OCTET STRING. I used to have
an
>Aram Perez
>> From: Rich Ankney <[email-masked]>
>> Date: Mon, 18 Sep 2000 23:01:36 -0400
>> To: ChungKil Kim <[email-masked]>, [email-masked]
>> Subject: Re: Is possible indefinite form of length encoding in DER?
>>
>> I think all of the RFC 2630 stuff needs to be DER.  It's not clear at all
>> what you can do about some ASN.1 wrapped in the eContent OCTET
>> STRING though.  If that were ASN.1 (wrapped in an OS) there's no
>> way to signal how it's encoded (although this sort of thing is a topic
>> in the new version of ASN.1).  Theoretically it could be anything but it
>> has to be signalled by the content type (IMHO).
>>
>> Regards,
>> Rich
>>

---

From: [email-masked]
Date: Tue, 19 Sep 2000 10:17:24 -0400

You're right, of course.  Constructed octet strings, like constructed
character strings and constructed bit strings, are legal in BER but not in
DER.  The same is true of indefinite lengths (length octet of 0x80 with a
matching EOC consisting of two zero octets at the end).

          Tom Gindin

"Rich Ankney" <[email-masked]> on 09/19/2000 10:00:31 AM

To:   "Aram Perez" <[email-masked]>, <[email-masked]>
cc:
Subject:  Re: Is possible indefinite form of length encoding in DER?

Regards,
Rich

-----Original Message-----
From: Aram Perez <[email-masked]>
To: [email-masked] <[email-masked]>
Date: Monday, September 18, 2000 11:20 PM
Subject: Re: Is possible indefinite form of length encoding in DER?

an