Subject: Re: 2459 disapproved by MSFT and VeriSign?

From: "Anders Rundgren" <[email-masked]>
Date: Tue, 19 Sep 2000 10:54:02 +0200

Steve, 

>This has a familiar ring. You often argue for modifying our standards 
>to accommodate some vendor approach, irrespective of architectural 
>merit. 

Why not wake up Warwick that both co-authored 2459 and is employed by
one of these "marginal" vendors that apparently don't care about it?

The E= in Subject *IS* a standard way of putting e-mail addresses in certificates! 
By far the most common solution also... 

To "criminalize" that is far too late.

The recommendation in 2459 has no important architectural merit. If it had, people 
would follow it. Quite simple logic there IMO. It is just a result of 
"historical" problems and 2459 should also say that. I.e. there are *two* EQUALLY
conformant solutions which is admittedly unfortunate but nothing to do about except accepting. 

Note that if VeriSign and Microsoft would change their email support in certificates 
a lot of custom software would probably fail. To change son-of-2459 does not hurt anybody. 

Regarding my "lust" for screwing up standards: 
I don't know exactly know what you refer to except that I have had (and still have) 
a lot of unanswered questions regarding QCs. Which is still in draft. 

I do know that I complained about the sudden deprecation of dnQualifier in the 
Subject field and was referring to existing *known* deployment of that while the s.c. 
conformant usage (that very few understood) is probably not used by anybody. 
Again: Too late to be changed without creating problems. REAL problems.

>That's not how the IETF pursues standards. That's why TLS is 
>not backwards compatible with SSL, for example.

No, but TLS is *upward* compatible with SSL which is about all you can 
require (in some cases) when you introduce enhanced standards. 

Anders

---

From: Stephen Kent <[email-masked]>
Date: Tue, 19 Sep 2000 10:05:58 -0400

Anders,

In conducting debates on mailing lists one sometimes has to decide 
that further exchanges are not productive, wasting one's own time as 
well as that of the WG members. This appears to be one of those 
cases. I'm sure you'll understand why I will no longer respond to 
your messages.

Steve