Subject: refine ment to question :Where does the certificate go?

From: "osama farook" <[email-masked]>
Date: Tue, 16 Apr 2002 23:23:19 +0200

ask about format
is it base64-encoded or der-encoded or pkcs#7 or pkcs#12
Another question:?
If there are any project that has been like mine and available on internet it is very kind of you to tell me about it.
if there is any resources (not standards or rfcs)
I'm so tired of RFC and standards.I make like who run in a circle.
I do my project using C#>

---

From: "Juan Carlos Perez A." <[email-masked]>
Date: Tue, 16 Apr 2002 20:02:20 -0400

The certificate is in pkcs#7. BAse-64 is a tex-format representation of any
binary, as pkcs#7 too.

I suggest to you visit: www.pki-page.org, www.sourceforge.net,
www.freshmeat.net . and the Getronics's free certificate library
http://www.getronicsgov.com/hot/cml_lib.htm

regsrds

j.c.

  -----Mensaje original-----
  De: [email-masked] [mailto:[email-masked]]En
nombre de osama farook
  Enviado el: martes, 16 de abril de 2002 17:23
  Para: [email-masked]
  Asunto: refine ment to question :Where does the certificate go?

  ask about format
  is it base64-encoded or der-encoded or pkcs#7 or pkcs#12
  Another question:?
  If there are any project that has been like mine and available on internet
it is very kind of you to tell me about it.
  if there is any resources (not standards or rfcs)
  I'm so tired of RFC and standards.I make like who run in a circle.
  I do my project using C#>

---

From: vivek saraf <[email-masked]>
Date: Tue, 16 Apr 2002 22:05:40 -0700 (PDT)

hello,

You can use both DER or PEM, the application in which
you are going to use the sertificates that should
support that. The IE accepts both DER and PEM formats.

If you want to give the user certificates along with
the CA certificate you must use pkcs #7.

If you are have generated the private and public key
pairs for the end user you must use pkcs #12, in this
you can even put CA certificate also along with user
private key and certificate.

For open source for CA you can refer openca.

vivek
 
--- osama farook <[email-masked]> wrote:
> If there are any project that has been like mine and
> available on internet it is very kind of you to tell
> me about it.

__________________________________________________
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax
http://taxes.yahoo.com/

---

From: "Housley, Russ" <[email-masked]>
Date: Wed, 17 Apr 2002 08:53:54 -0400

Vivek:

He said PER, which is the Packed Encoding Rules.
He was not talking about the PEM file format.

Russ