Subject: RE: Multiple paths in DPD

From: Hal Lockhart <[email-masked]>
Date: Mon, 29 Apr 2002 10:44:22 -0400

> > Handling this protocol when the information used to
> > construct the paths changes between requests seems
> > particularly challenging to me.
> 
> No.  One of the underlying assumptions is that no
> paramters change from the client.  The client is
> seeking a path compliant to a given set of parameters.
> As it may turn out, the server may have several
> such that qualify.  The iterative approach enables
> a client to acquire these in serial query fashion
> until it either finds the precise record/path
> it's looking for or the server runs out of data.

I was not talking about the client providing different inputs, but the fact
that server's based of information will be updated from time to reflect
revocations, expirations, new authorities, etc. I assume this service will
be in continuous operation. 

Hal

---

From: "Michael Myers" <[email-masked]>
Date: Mon, 29 Apr 2002 12:40:18 -0700

> -----Original Message-----
> From: [email-masked]
>       [mailto:[email-masked]]On Behalf Of
>       Hal Lockhart
> Sent: Monday, April 29, 2002 7:44 AM
> To: 'Michael Myers'; 'Peter Sylvester';
[email-masked]
> Cc: [email-masked]
> Subject: RE: Multiple paths in DPD

> I was not talking about the client providing different
> inputs, but the fact that server's based of information
> will be updated from time to reflect revocations,
> expirations, new authorities, etc. I assume this service
> will be in continuous operation.
>
> Hal

Hal,

I understand your point better now.  But would not the effects
of these dynamics apply equally well in both the enumerated and
iterated approaches?  I don't yet see how it is a discriminator
between the two.

Mike