Subject: RE: Multiple paths in DPD

From: Hal Lockhart <[email-masked]>
Date: Mon, 29 Apr 2002 16:59:39 -0400

> > I was not talking about the client providing different
> > inputs, but the fact that server's based of information
> > will be updated from time to reflect revocations,
> > expirations, new authorities, etc. I assume this service
> > will be in continuous operation.
> >

> 
> I understand your point better now.  But would not the effects
> of these dynamics apply equally well in both the enumerated and
> iterated approaches?  I don't yet see how it is a discriminator
> between the two.

My understanding of the other approach is that the set of paths is generated
afresh each time. (although only the first N may be sent) Therefore each
response is inherently consistent with itself and independant of any other
response.

BTW, I hold no brief for stateful or stateless. I am just trying to help
clarify for the list, the tradeoffs involved.

Hal

---

From: "Michael Myers" <[email-masked]>
Date: Mon, 29 Apr 2002 14:26:36 -0700

> -----Original Message-----
> From: Hal Lockhart [mailto:[email-masked]]
> Sent: Monday, April 29, 2002 2:00 PM
> To: 'Michael Myers'; Hal Lockhart; 'Peter Sylvester';
[email-masked]
> Cc: [email-masked]
> Subject: RE: Multiple paths in DPD
>
>

> My understanding of the other approach is that the set
> of paths is generated afresh each time. (although only
> the first N may be sent) Therefore each response is
> inherently consistent with itself and independant of
> any other response.  BTW, I hold no brief for stateful
> or stateless. I am just trying to help clarify for the
> list, the tradeoffs involved.
>
> Hal

Hal,

Interesting.  My assumption was that in either case there exists
between 1 and N paths defined by the initial context of the
client's query.

Mike