Subject: OCSP Nonce Syntax

From: "mars" <[email-masked]>
Date: Mon, 7 Oct 2002 12:53:56 -0500

Which RFCs or drafts contain a definition for a Nonce, besides 3161
(which uses an INTEGER)? 
Is it a standard practice to encode the NONCE as an OCTET STRING for
OCSP?
 
Thanks in advance,
 
Miguel A. Rodriguez
SeguriDATA
Mexico

---

From: David Hopwood <[email-masked]>
Date: Tue, 08 Oct 2002 06:32:06 +0000

-----BEGIN PGP SIGNED MESSAGE-----

"mars" <[email-masked]> wrote:
> Which RFCs or drafts contain a definition for a Nonce, besides 3161 (which
> uses an INTEGER)? 

See the earlier discussion in this group, archived at
<http://www.imc.org/ietf-pkix/mail-archive/thrd2.html#04040>, which
concluded that it should be an OCTET STRING.

<http://www.ietf.org/internet-drafts/draft-ietf-tls-extensions-05.txt>
(in the RFC queue) requires that it be an OCTET STRING for OSCP clients that
are used to implement the TLS 'status_request' extension.

- -- 
David Hopwood <[email-masked]>

Home page & PGP public key: http://www.users.zetnet.co.uk/hopwood/
RSA 2048-bit; fingerprint 71 8E A6 23 0E D3 4C E5  0F 69 8C D4 FA 66 15 01
Nothing in this message is intended to be legally binding. If I revoke a
public key but refuse to specify why, it is because the private key has been
seized under the Regulation of Investigatory Powers Act; see www.fipr.org/rip