Subject: Re: [TSP/RFC3161] PKIFailureInfo values

From: [email-masked] (Peter Gutmann)
Date: Fri, 8 Nov 2002 05:08:06 +1300 (NZDT)

Denis Pinkas <[email-masked]> writes:

>Is it fine with Peter (S), Andrew, Peter (G) and Phil  ?

Well, one comment:

>    <AB>The statusString field of PKIStatusInfo MAY be used to include reason(s)
>    text such as "messageImprint field is not correctly formatted".<BB>

Maybe this should be left as "reason text" - what do you do if there is > 1
failure reason?  Pick the most important one?  Put a comma between them?  A
linefeed?  Use the Windows-style \0 + \0\0?  It's better to imply there's a
single string, and not do any more with it than that.

Peter.

---

From: Ricardo Barroso <[email-masked]>
Date: Thu, 07 Nov 2002 19:41:45 +0000

>single string, and not do any more with it than that.
Peter, maybe you're right that can turn a little confuse!
In my opinion even maintaining here the original RFC sentence, it 
doesn't restrict that you can't have
for example a comma between more than one reason - that's still a valid 
string/"reason text" I suppose.
Do you agree with that? Do you think that a system that does that will 
not be compliant?
I think the format of that string is not important (if it's still a 
valid ASN.1 PKIFreeText) since it's just
a "friendly message", it's the BIT STRING values that give to the 
time-stamping "system" the knowledge
of how to proceed or what error(s) need to be handled...

Best regards,
Ricardo Barroso

MULTICERT S.A.
www.multicert.com <http://www.multicert.com>