Subject: Re: OID repository (was Re: Any Organization Certificates out there?)

From: Michael Ströder <[email-masked]>
Date: Tue, 13 Nov 2001 16:40:14 +0100

Tom Gindin wrote:
> 
>      There is one (more or less) at http://www.alvestrand.no/objectid/.
> Should this group try to encourage vendors to put their OID's there and
> link to it from the PKIX web site?  Some vendors are already there.

Peter Gutmann's dumpasn1.cfg is another one and has the advantage of
being machine-readable but being limited to PKI-related OIDs.

I remember some discussion on the XML-DSIG list about an URL scheme
for OIDs. Any results there? Rich? Anders?

Ciao, Michael.

---

From: "Tom Gindin" <[email-masked]>
Date: Tue, 13 Nov 2001 08:04:14 -0500

Tom Gindin
P.S. -    The suggestion above is mine, and not necessarily that of my
employer.

"todd glassey" <[email-masked]>@mail.imc.org on 11/10/2001
05:22:00 PM

Sent by:  [email-masked]

To:   "Peter Gutmann" <[email-masked]>
cc:   <[email-masked]>
Subject:  Re: Any Organization Certificates out there?

Peter, I suggested once or twice that this WG might
want to sponsor a Universal OID tree or perhaps the
IETF or IANA might  be put up to it. They (the IANA)
handle the PEN OIDs at least.

Of course I got slammed for the idea but what the hey -
it was a good one after all.

Todd

----- Original Message -----
From: "Peter Gutmann" <[email-masked]>
To: <[email-masked]>; <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Saturday, November 10, 2001 10:09 AM
Subject: Re: Any Organization Certificates out there?

>
> "Pei, Mingliang" <[email-masked]> writes:
>
> >The server certificate issued by VeriSign actually meet your need. "a
unique
> >ID" DUNS number is included in server certificates. When a customer
provides
> >their DUNS# during enrollment for retail Secure/Global server ID to
VeriSign
> >CA, the certificate issued always includes the DUNS# in the server id
> >extension which OID is 2.16.840.1.113733.1.6.15
>
> So 2.16.840.1.113733.1.6.15 = "Verisign serverID"?  Are
> any of these OIDs ever going to be documented anywhere?
> I've managed to add a few based to dumpasn1 on reverse-
> engineering and/or guesswork, but it'd be useful to have the full
> list in there.
>
> Peter.