Subject: Re: [TSP] misc comments

From: Peter Sylvester <[email-masked]>
Date: Fri, 20 Dec 2002 19:11:16 +0100 (MET)

> 
> > They are correct and do not need to be changed.
> 
> I disagree:
> 
> 'SHOULD' in the first sentence is referred to 'TimeStampToken',
> so the reader takes it as: it is recommended to produce a TimeStampToken
> with policy = reqPolicy.
> 
> So since this is only recommended, one could potentially create a 
> TimeStampToken with policy != reqPolicy which isn't the case, since the 
> second sentence says: there MUST be no TimeStampToken if the supported 
> policy != reqPolicy.
> 

Thomas, in my opinion you are quite correct in the reading of the 
first phrase. Otherwise, you could never have a MUST, because 
there is always the possibility of some error answer. 

The item had been discussed in length a few months ago, and
since there was a diversion from the editors towards some
negotiation protocol, the discussion stopped. 

What would be the problem if the MUST of policy == reqPolic
would be changed into a SHOULD as it was in earlier drafts.

It would not; IMO. The client is not really be simpler
since 

I repeat the suggestion which seems to be shared by
some number of real implmentors to change the phrase:

  'If a similar field was present in the
   TimeStampReq, then it MUST have the same value, 
   otherwise an error
   (unacceptedPolicy) MUST be returned.'

into 

  'If the TimeStampReq contained the field 'reqPolicy', the
   TSA SHOULD return the same value. The TSA MAY return
   an error 'unacceptablePolicy'. 

and make the rest of the text consistant, i.e., wherever
some other statements had been changed in a fast attempt
to achieve some consistency (which is still not the case
as Thomas pointed out). 

regards
peter

---

From: tho <[email-masked]>
Date: Sat, 21 Dec 2002 11:03:58 +0100

Peter,
 
>    an error 'unacceptablePolicy'.
 
Really, I support whatever choice (MUST/MUST, SHOULD/SHOULD) we shall
take.  My concern in this very moment is just having a coherent spec text
on which we can base our implementations.

> and make the rest of the text consistant,

It seems there is one only point which needs to be modified following
the change that you propose, in that the client is now forced to check
the policy field in the TSTInfo.

I.e. substitute SHOULD with MUST in: "Then, the client application SHOULD
check the policy field..."

Thomas